Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 06-23-2011, 07:22 AM   #1
okidogi
Hello world
okidogi began at the beginning.
 
Posts: 10
Karma: 10
Join Date: Jun 2011
Device: kindle
Lightbulb How to only get command line tool ebook-convert installed.

Hi,

I'm not sure if this the proper place for such a post, but I need a hackish solution probably...

I have a server which is Debian GNU/Linux 5.0.8 (lenny) where I want calibre get installed. After several tries, it's still not installed successfully. After then I realized that the functionality I need is just the command "ebook-convert". So I'm wondering if there are some way to just install this command line tool instead of the whole calibre package.
okidogi is offline   Reply With Quote
Old 06-23-2011, 10:05 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,116
Karma: 5101571
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
No, there isn't
kovidgoyal is offline   Reply With Quote
 
Enthusiast
Old 06-23-2011, 10:26 AM   #3
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,626
Karma: 857074
Join Date: Jan 2010
Location: France
Device: Many android devices
Moderator Notice
Moved out of development forum
chaley is offline   Reply With Quote
Old 06-23-2011, 10:52 AM   #4
okidogi
Hello world
okidogi began at the beginning.
 
Posts: 10
Karma: 10
Join Date: Jun 2011
Device: kindle
Quote:
Originally Posted by kovidgoyal View Post
No, there isn't
Do you have suggestions for installing calibre on linux distribution Debian GNU/Linux 5.0.8 (lenny)? I tried hard but failed. It always throw the exception,
"
Traceback (most recent call last):
File "site.py", line 55, in main
File "site.py", line 41, in set_qt_plugin_path
ImportError: cannot import name QCoreApplication
"
okidogi is offline   Reply With Quote
Old 06-23-2011, 10:59 AM   #5
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,626
Karma: 857074
Join Date: Jan 2010
Location: France
Device: Many android devices
Installing calibre on Lenny is unsupported, It is is very hard because glibc is too old. I once tried to get around it by selective upgrading, and ended up bricking my server.

If you really want to make this go, you can do it using chroot. See http://www.mobileread.com/forums/sho...2&postcount=16 for an example that worked for me. It requires a large amount of *nix sysadmin experience, a server you control, and a fair amount of disk space.
chaley is offline   Reply With Quote
Reply

Tags
installation

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable Cover for Command Line ebook-convert bcolflesh Calibre 9 02-21-2013 11:02 AM
ebook-convert: change settings from command line miwie Calibre 1 11-30-2010 02:05 PM
Command Line problems: ebook-convert, ebook-meta with tags: --series, --series-index omnivorous Calibre 4 11-07-2010 02:42 PM
python command line tool for kobo reed Kobo Reader 2 06-05-2010 02:07 AM
Command Line Options for ebook-convert godel10 Calibre 14 08-08-2009 08:28 AM


All times are GMT -4. The time now is 04:23 AM.


MobileRead.com is a privately owned, operated and funded community.