Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Library Management

Notices

Reply
 
Thread Tools Search this Thread
Old 07-10-2011, 12:00 AM   #1
Cheshirekat
Junior Member
Cheshirekat began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jul 2011
Device: iPad
No connection

My Calibre stopped connecting to the internet so it no longer will download covers, metadata, or anything. It didn't even notify me that an update had occurred. I read some older posts and tried resetting environment variables but this only seemed to make it worse. At least before it looked like it was trying to search, now it doesn't even bother. I restarted in debug mode and this is the information I got:

calibre Debug log
calibre 0.8.9
Windows-7-6.1.7600
Windows
('Windows', '7', '6.1.7600')
Python 2.7.1
Windows: ('7', '6.1.7600', '', 'Multiprocessor Free')
Starting up...
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}
Traceback (most recent call last):
File "site-packages\calibre\gui2\update.py", line 44, in run
File "site-packages\calibre\gui2\update.py", line 28, in get_newest_version
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_mechanize.py", line 203, in open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_mechanize.py", line 230, in _mech_open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_opener.py", line 193, in open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 344, in _open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 332, in _call_chain
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 1142, in http_open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 1084, in do_open
File "httplib.py", line 681, in __init__
File "httplib.py", line 706, in _set_hostport
InvalidURL: nonnumeric port: '<proxy server port>'
Started up in 5.07799983025
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}

Please, oh, please can someone tell me how to fix this mess?
Cheshirekat is offline   Reply With Quote
Old 07-10-2011, 12:05 AM   #2
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,254
Karma: 5495470
Join Date: Aug 2009
Location: The (original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by Cheshirekat View Post
My Calibre stopped connecting to the internet so it no longer will download covers, metadata, or anything. It didn't even notify me that an update had occurred. I read some older posts and tried resetting environment variables but this only seemed to make it worse. At least before it looked like it was trying to search, now it doesn't even bother. I restarted in debug mode and this is the information I got:

calibre Debug log
calibre 0.8.9
Windows-7-6.1.7600
Windows
('Windows', '7', '6.1.7600')
Python 2.7.1
Windows: ('7', '6.1.7600', '', 'Multiprocessor Free')
Starting up...
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}
Traceback (most recent call last):
File "site-packages\calibre\gui2\update.py", line 44, in run
File "site-packages\calibre\gui2\update.py", line 28, in get_newest_version
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_mechanize.py", line 203, in open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_mechanize.py", line 230, in _mech_open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_opener.py", line 193, in open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 344, in _open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 332, in _call_chain
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 1142, in http_open
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\_urllib2_fork.py", line 1084, in do_open
File "httplib.py", line 681, in __init__
File "httplib.py", line 706, in _set_hostport
InvalidURL: nonnumeric port: '<proxy server port>'
Started up in 5.07799983025
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}
Using proxies: {'http': '<proxy server ip>:<proxy server port>'}

Please, oh, please can someone tell me how to fix this mess?
Your IE is set to use a proxy server (setting) that no longer exists, probably due to an update or removal of network security software.

Make IE work and Calibre will work.
theducks is offline   Reply With Quote
Old 07-10-2011, 12:13 AM   #3
Cheshirekat
Junior Member
Cheshirekat began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jul 2011
Device: iPad
if IE is Internet Explorer then I don't actually use that, I use Mozilla Firefox. It did give me some proxy errors but I fixed that by setting the Advanced settings to auto-detect proxy settings. So it works but Calibre doesn't. I'm pretty much a novice with this so as such am stuck.
Cheshirekat is offline   Reply With Quote
Old 07-10-2011, 12:20 AM   #4
Cheshirekat
Junior Member
Cheshirekat began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jul 2011
Device: iPad
Red face Fixed!

Somehow, and don't ask me how, my LAN settings had the box checked to have my network use a proxy server even though there has never been one! This is a basic home computer setup. Windows7 strikes again!
Cheshirekat is offline   Reply With Quote
Old 07-10-2011, 12:23 AM   #5
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,254
Karma: 5495470
Join Date: Aug 2009
Location: The (original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by Cheshirekat View Post
if IE is Internet Explorer then I don't actually use that, I use Mozilla Firefox. It did give me some proxy errors but I fixed that by setting the Advanced settings to auto-detect proxy settings. So it works but Calibre doesn't. I'm pretty much a novice with this so as such am stuck.
Yes IE is Internet explorer. The Proxy settings it uses sets the System level.

I also use FF and only do IE for W7 updates.
theducks is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No connection wilkinson1 Amazon Kindle 3 07-08-2011 03:59 AM
No connection lvd4 Fictionwise eBookwise 1 10-10-2010 08:55 PM
3G Connection Majorix Amazon Kindle 3 01-26-2010 02:53 PM
Wireless internet connection frustrating IDS connection Socrates iRex 8 10-21-2009 12:46 PM
First connection Peregrine Sony Reader 5 11-02-2006 05:29 PM


All times are GMT -4. The time now is 09:17 PM.


MobileRead.com is a privately owned, operated and funded community.