Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive

Notices

 
 
Thread Tools Search this Thread
Old 05-14-2011, 10:42 AM   #1
natescape
Edge User
 
Battery issue with new PE

Hi all,

So two of the three PEs I got through Woot are great, but one won't charge and has a question mark in the upper corner where the battery meter should be. Are there things I should try, or should I attempt to contact Entourage or Woot to get a replacement one?
 
Old 05-14-2011, 11:20 AM   #2
sjarrel
Edge User
 
Try Settings > about Edge > Status and see what it says about your battery. Maybe it's not connected very well.
 
Old 05-14-2011, 11:26 AM   #3
natescape
Edge User
 
Thanks sjarrel!

I updated to Ermine thinking that might help. Now it's a red battery with a line through it.

Status says:
Battery Status: discharging
Battery Level: 0

I tried switching power cords, just in case, but that didn't seem to do anything.
 
Old 05-14-2011, 11:35 AM   #4
sjarrel
Edge User
 
Some members mentioned a charchingproblem before. I think one solution was to charge it overnight. I asume that your ac-connection is allright? The little pin is there and not broken?
 
Old 05-14-2011, 11:46 AM   #5
natescape
Edge User
 
It charged overnight, which is why I was frustrated that it didn't seem to take at all.

But, interestingly, now it says it's charging and shows the normal battery icon. Not sure what was going on, but it seems to be resolving itself.
 
Old 05-14-2011, 12:03 PM   #6
sjarrel
Edge User
 
Quote:
Originally Posted by natescape View Post
Thanks sjarrel!

I updated to Ermine thinking that might help. Now it's a red battery with a line through it.

Status says:
Battery Status: discharging
Battery Level: 0

I tried switching power cords, just in case, but that didn't seem to do anything.
Maybe my oversees magic? Hope it stays ok.
 
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-650 Charging issue - battery down to zero Alexander Turcic Sony Reader 66 07-23-2011 04:59 AM
Battery issue with 1.2 wymore Nook Color & Nook Tablet 3 05-09-2011 04:33 PM
Battery issue - please help! Akuli Astak EZReader 7 05-21-2010 02:21 PM
K2 and Battery Life Issue emellaich Amazon Kindle 25 03-18-2009 03:41 AM
Date/Battery? Issue Cogito Sony Reader 4 01-02-2007 08:12 PM


All times are GMT -4. The time now is 10:44 PM.


MobileRead.com is a privately owned, operated and funded community.