Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive


Thread Tools Search this Thread
Old 07-23-2010, 05:32 PM   #1
Edge User
config how to mount sdcard


I posted a question on the board a while ago.

It is about how to display chinese filename correctly.

I think I found the reason.

eDGe mount the sdcard without utf8 flag and default codepage (cp437) and default iocharset (iso8859-1)

my linux laptop mount the sdcard with utf8 flag.

Is there a way to change how eDGe mount the sdcard? (basically add utf8 flag) I think nowadays both windows and linux support utf8 well.

If not, could I ask it as a feature request?

Old 07-24-2010, 02:07 AM   #2
Edge User
I have try to change one of my PDF name to "PDF"
then put it to my 4GB SDCARD..
Use Library-->Storage to display SDCARD content.

the result is

the mount for /extsdcard shows

Last edited by keng2000; 07-24-2010 at 02:10 AM.
Old 07-24-2010, 09:42 AM   #3
Edge User
Thanks for the reply! I have been using the internal SDCARD through the mini usb. I did try an external SDCARD after reading your post, and it is working correctly.

Apparently eDGe treats internal and external SDCARD differently when mounting them. with utf8 flag for external SDCARD and without utf8 flag for internal SDCARD. Is there a reason to do this?

keng2000, can you try the same thing you did for the internal SDCARD? Then I think you can not read the Chinese character. Do you know if I can change how it mounts the internal SDCARD? (Like fstab file under Linux)

Old 07-24-2010, 12:12 PM   #4
Edge User
See this picture

There is no problem with internal SDCARD either.

But answer your question, To change how to mount?
You need to get the firmware and change at mount point in the update shell script as robot did for root the firmware.

Last edited by keng2000; 07-24-2010 at 12:15 PM.
Old 07-24-2010, 01:30 PM   #5
Edge User
are you running coyote 1.0 or a customized firmware? Can you check how your internal SDCARD is mounted? Mine was mounted without utf8 flag, which caused the problem.

Changing firmware seems too technical for me. Any more details available somewhere? Thanks!
Old 07-24-2010, 11:15 PM   #6
Edge User
the mount for internal SDCARD shows no utf8 flag.

Can you try copy from extSDCARD to internal using ES Explorer?
Old 07-24-2010, 11:29 PM   #7
Edge User
Originally Posted by keng2000 View Post
the mount for internal SDCARD shows no utf8 flag.

Can you try copy from extSDCARD to internal using ES Explorer?
That would be fine. The problem will occur when one mount the internal SDCARD through miniusb, since it will be mounted with utf8 flag, as most linux distributions will do. Hence if you can view it as a chinese filename in the internal SDCARD through edge, you won't see it after mounting it through miniusb.

I have to manually change to mounting it without utf8 flag, I can then see the filename.

Simple solutions would be to mount the internal SDCARD with utf8 flag by default. I don't know if there is an undesired reason why edge is not doing it right now.

How can I try to create a ticket and formally request this?
Old 07-25-2010, 09:51 AM   #8
Edge User
Originally Posted by borisb View Post
You can submit a formal feature request here:
thank you!

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
IQ SDCard speed UrbanNightmare PocketBook 1 03-07-2011 11:34 AM
Request Option to direct /sdcard to desired location techiem2 enTourage Archive 5 05-04-2010 11:19 AM
can not access sdcard after I formated to fat32 Kepe OpenInkpot 7 03-29-2010 03:18 AM
ebooks on more than one sdcard p3aul Sony Reader 2 07-24-2009 02:55 AM
Crash and SDCARD issues joblack Sony Reader 9 08-24-2007 02:04 AM

All times are GMT -4. The time now is 07:52 AM. is a privately owned, operated and funded community.