Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive

Notices

 
 
Thread Tools Search this Thread
Old 06-08-2010, 05:15 PM   #1
walt526
Edge User
 
RMAed :(

Well after several exchanges of emails with tech support, it looks like I'm going to have RMA my eDGe. The camera never worked (even after a reset to factory settings) and after reviewing the logs, the engineers concluded that it must be some sort of issue with the hardware.

Has anyone done a RMA with their eDGe? What is the turn around time between sending it down and getting it back (or a replacement)?

It's a pain in the butt to have to send it in, but I should say that the guys at tech/customer support have been excellent.
 
Old 06-08-2010, 09:31 PM   #2
cheyennedonna
Edge User
 
They are fast

I had to wait a bit, because I had a Black edge and all they had left at the time was White, but it was quick.
 
 
Enthusiast
Old 06-08-2010, 09:59 PM   #3
dcubed2
Edge User
 
Well, mine is being rma'd, too. It suddenly stopped charging, not even acknowledging being plugged in. Sigh. Hmm, maybe I should try the camera and see if it works.
 
Old 06-09-2010, 06:47 PM   #4
walt526
Edge User
 
I dropped it off at the local FedEx-Kinkos this afternoon. It's FedEx 2day service to McLean, VA. Will they just ship a replacement as soon as they receive my old one? Or will they try to fix the original unit?

I just ordered the standard Midnight Blue (I figured that I'd eventually get a Gelaskin or something, so paying $40 extra for a different color didn't seem prudent).
 
Old 06-10-2010, 08:50 AM   #5
ChrisF
Edge User
 
I had to RMA my eDGe for the same issue Walt. The good news is I am getting it back today. Somehow the 2day FedEx label took 5 days to get to enTourage, but they diagnosed, fixed, and shipped my eDGe on the same day. They really have the best support I have seen in technology products. Here is a big thanks to Jeff at tech support.

ps. Life for a week without my eDGe was tough. It has really become a part of my daily usage. But mostly I miss my books.
 
Old 06-15-2010, 12:10 AM   #6
walt526
Edge User
 
I got an email from tech support today that they found that the camera module was malfunctioning, but that it has been replaced. Most importantly, my eDGe is en route back to me with delivery expected this Wednesday!

Kudos to Entourage's tech support--I have never had a RMA process take place so quickly and painlessly.

For those wondering, the timeline of this process was:

Wednesday, June 2nd:
- originally contacted tech support with the complaint
- received a response within 4 hours, requesting confirmation that I was running the latest version of the firmware

Thursday, June 3rd:
- received an APK with instructions on how to log the issue for their engineers to review
- I didn't get a chance to send them a log file until after end of business

Friday, June 4th:
- received acknowledgment that they had received the log and that it had been forwarded to their engineers to review

Wednesday, June 9th:
- informed that the they needed to issue an RMA
- received a FedEx packing slip for 2day shipping (i.e., no out-of-pocket expense for me to ship it back to them)
- I dropped it off that afternoon

Friday, June 11th:
- the package was delivered by FedEx that afternoon to Entourage (McLean, VA)

Monday, June 14th:
- received word that the camera module was malfunctioning and had been replaced
- Entourage sent it back to me via FedEx 2Day, with delivery expected on Wednesday, June 16th

Last edited by walt526; 06-15-2010 at 12:22 AM.
 
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump


All times are GMT -4. The time now is 03:49 AM.


MobileRead.com is a privately owned, operated and funded community.