Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive

Notices

 
 
Thread Tools Search this Thread
Old 04-26-2010, 02:17 PM   #1
techiem2
Edge User
 
Fixing "Application cannot be installed on this phone" message?

I got the Seesmic client from the Android Market via the dev kit as mentioned in the other thread, and it installed fine.
There is now an updated version (apparently adds a widget and some other things), but this version gives me the Application Cannot be installed on this phone error when I try to install it on my Edge.
I have the apk unpacked, but I don't know what to look for to find out what is blocking the install.
I assume I need to change something in the AndroidManifest.xml file.
I'd already deleted the old apk, so I can't compare the file between the two versions to see what is different.
Any suggestions?
 
Old 04-26-2010, 03:18 PM   #2
techiem2
Edge User
 
It installed fine (and runs fine) on the dev image in the emulator, which is running Android 1.6.

Wait...I do have the old version..it's installed...:P
I'll back it up with Astro and see if I can tell a difference in the manifest between the 2 versions.

Last edited by techiem2; 04-26-2010 at 03:23 PM.
 
 
Enthusiast
Old 04-26-2010, 03:41 PM   #3
techiem2
Edge User
 
Ok, here's the diff between the 2 manifests. (< is old file, > is new file)
So, the version changed.
They added a couple new activities.
They added a widget.
They added the OnClearReceiver receiver (whatever that does).
They added the use of the google android maps library (hmm....).
They removed access to the user's contacts.

Code:
2c2
< <manifest android:versionCode="7" android:versionName="1.2.3" package="com.seesmic"
---
> <manifest android:versionCode="8" android:versionName="1.3" package="com.seesmic"
29a30,31
>         <activity android:label="@string/app_name" android:name=".ui.RetweetsSpace" />
>         <activity android:label="@string/app_name" android:name=".ui.RetweetsTimeline" />
50a53
>         <activity android:label="@string/app_name" android:name=".ui.TweetMap" />
51a55
>         <service android:name=".ui.widget.WidgetService" />
52a57
>         <receiver android:name=".core.OnClearReceiver" />
57a63,77
>         <activity android:theme="@android:style/Theme.Dialog" android:name=".ui.widget.Widget1Configure">
>             <intent-filter>
>                 <action android:name="android.appwidget.action.APPWIDGET_CONFIGURE" />
>             </intent-filter>
>         </activity>
>         <receiver android:name=".ui.widget.Widget1">
>             <intent-filter>
>                 <action android:name="android.appwidget.action.APPWIDGET_UPDATE" />
>                 <action android:name="com.seesmic.ui.widget.UPDATE_ALL" />
>                 <action android:name="com.seesmic.ui.widget.CLICK_NEXT" />
>                 <action android:name="com.seesmic.ui.widget.CLICK_PREVIOUS" />
>             </intent-filter>
>             <meta-data android:name="android.appwidget.provider" android:resource="@xml/widget1_info" />
>         </receiver>
>         <uses-library android:name="com.google.android.maps" />
68d87
<     <uses-permission android:name="android.permission.READ_CONTACTS" />
 
Old 04-26-2010, 04:38 PM   #4
techiem2
Edge User
 
My suspicion as well.
 
Old 04-27-2010, 08:26 AM   #5
ChrisF
Edge User
 
I know this sounds silly but this worked for me on other apps. Did you try to uninstall the old app first? I was receiving the same error message when I tried to overwrite an app with a new version.
 
Old 04-27-2010, 12:44 PM   #6
techiem2
Edge User
 
No, I hadn't tried that.
I'll give it a shot and see what happens.
 
Old 04-27-2010, 12:49 PM   #7
techiem2
Edge User
 
Nope, no go.
"Application not installed. Seesmic could not be installed on this phone."
 
Old 05-10-2010, 03:15 AM   #8
mba
Edge User
 
Hi.

I can confirm the problem is on
<uses-library android:name="com.google.android.maps" />
which can only be run on an device with google apis.

I'm actually working on a project that use google apis just to display a map, and I have to remove this line to install it on my Edge.

Question to Entourage in case they have already thought about this :
- as a developper, do you think there is way to display a map without MapActivity so my app can run on Edge ? I already tried using a WebView but I don't have the same possiblities ...
- would it be possible to modify Android so applications requiring Google Apis will install but only activity using Map will not run ? In my app, I have a lot of Activities but only one will use Map ...
 
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Access denied" to downloaded news - Windows Error message 5 SunFuLai Recipes 14 12-02-2011 02:20 AM
Error message : "Invalid Format" " Do you want to format your internal memory" narbeauchamp Sony Reader 11 07-22-2009 12:39 PM
"Fixing" PDF's BrendenM Sony Reader 0 01-03-2007 05:29 PM
"Fixing" the resulting text Nandokin Workshop 2 03-19-2006 01:21 PM


All times are GMT -4. The time now is 01:59 AM.


MobileRead.com is a privately owned, operated and funded community.