Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 06-04-2011, 04:34 AM   #1
gdm11
Junior Member
gdm11 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jun 2011
Device: kindle3
Unhappy calibre install on a vserver fails

Hi Guys,
i try to install calibre on my vserver (Ubuntu 8.04LTS minimal), but i can´t install it. i have to admit, i am not a linux/server pro. so it would be kind, if somebody have a hint for me.

here is the problem:
root@84-23-78-188:~# sudo python -c "import urllib2; exec urllib2.urlopen('http://status.calibre-ebook.com/linux_installer').read(); main()"
Enter the installation directory for calibre [/opt]:
Will download and install calibre-0.8.4-i686.tar.bz2
Downloading calibre-0.8.4-i686.tar.bz2
100% [================================================== ================================================== ================================================== ================================================== ==]

Downloaded 46028188 bytes
Checking downloaded file integrity...
Extracting files to /opt/calibre ...
Extracting application files...
Traceback (most recent call last):
File "site.py", line 55, in main
File "site.py", line 41, in set_qt_plugin_path
ImportError: cannot import name QCoreApplication

Run "calibre" to start calibre
root@84-23-78-188:~#

kind regards,

gdm11
gdm11 is offline   Reply With Quote
Old 06-04-2011, 05:19 AM   #2
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,031
Karma: 802238
Join Date: Jan 2010
Location: France
Device: Many android devices
Apparently that release of ubuntu is built on debian lenny, which is too old to support calibre.

I know that calibre runs under ubuntu 10 and up. I am not sure about 9.

Regarding installing on your vserver, do you actually run a GUI on it (X Windows)? If so, that must be incredibly slow. If not, then are you planning on using only the command line utilities and the server?
chaley is offline   Reply With Quote
 
Enthusiast
Old 06-04-2011, 06:46 AM   #3
gdm11
Junior Member
gdm11 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jun 2011
Device: kindle3
Quote:
Originally Posted by chaley View Post
Apparently that release of ubuntu is built on debian lenny, which is too old to support calibre.

I know that calibre runs under ubuntu 10 and up. I am not sure about 9.

Regarding installing on your vserver, do you actually run a GUI on it (X Windows)? If so, that must be incredibly slow. If not, then are you planning on using only the command line utilities and the server?
ok, ty for the tip. i install Ubuntu 10.04LTS minimal on my server right now, maybe calibre runs after the installation. no i dont use a gui, i want to use the command line.

edit:
ok now i got another error message:

root@84-23-78-188:~# sudo python -c "import urllib2; exec urllib2.urlopen('http://status.calibre-ebook.com/linux_installer').read(); main()"
Enter the installation directory for calibre [/opt]: calibre
Will download and install calibre-0.8.4-i686.tar.bz2
Downloading calibre-0.8.4-i686.tar.bz2
100% [================================================== ================================================== ================================================== ================================================== ==]

Downloaded 46028188 bytes
Checking downloaded file integrity...
tar: Record size = 8 blocks
Extracting files to /root/calibre/calibre ...
Extracting application files...
Traceback (most recent call last):
File "site.py", line 56, in main
File "site-packages/calibre/linux.py", line 11, in <module>
File "site-packages/calibre/customize/ui.py", line 15, in <module>
File "site-packages/calibre/customize/builtins.py", line 572, in <module>
File "site-packages/calibre/ebooks/pdf/output.py", line 18, in <module>
File "site-packages/calibre/ebooks/pdf/writer.py", line 15, in <module>
File "site-packages/calibre/ebooks/pdf/pageoptions.py", line 6, in <module>
ImportError: cannot import name QPrinter

i guess one packet/libary is missing but icant figure out wich one. do you have clue?

kind regards
gdm11

Last edited by gdm11; 06-04-2011 at 07:37 AM.
gdm11 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install fails with Kaspersky Internet Security 2011? khismet Calibre 5 02-28-2011 09:30 AM
Ubuntu Calibre 6.46 Install fails theducks Calibre 24 04-02-2010 09:27 AM
0.6.31 Linux install fails reread Calibre 3 12-28-2009 03:00 PM
Vista install fails bobzchemist Calibre 3 11-10-2009 03:26 AM
calibre install fails on Ubuntu hardy Xpi6 Calibre 16 11-16-2008 01:29 PM


All times are GMT -4. The time now is 06:48 AM.


MobileRead.com is a privately owned, operated and funded community.