Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 05-02-2011, 06:49 PM   #1
acemo
Junior Member
acemo began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2011
Device: pocketbook pro 603
Problems running on chakra linux.

Chakra is unable to run calibre since version 0.7.47.
We currently have version 0.7.46 working fine.
However all versions 0.7.47 and up are giving these same errors:
Code:
[acemo@twain ~]$ calibre-debug -g
Starting up...
Failed to load high performance sqlite C extension
'Connection' object has no attribute 'enable_load_extension'
ASSERT: "last >= first" in file kernel/qabstractitemmodel.cpp, line 2392
Aborted
I was hoping perhaps the developers would be able to help find the cause of this error?

Thanks,
acemo
acemo is offline   Reply With Quote
Old 05-02-2011, 07:48 PM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,317
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
I suggest you use the binary calibre install instead of compiling from source. That error is about being unable to load a sqlite C extension which tells me that most likely your sqlite library is too old.
kovidgoyal is online now   Reply With Quote
 
Advertisement
Old 05-03-2011, 02:52 PM   #3
acemo
Junior Member
acemo began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2011
Device: pocketbook pro 603
The problem with the binary installer is we get duplicated libraries and people can't rebuild their package with their prefered compiler settings. (installing from the binary installer does work though)

We have updated a lot of packages trying to get calibre working but with no effect.

What version of libsqlite3 are you using? we are using version 3.7.5 atm.

Thanks

Last edited by acemo; 05-03-2011 at 02:55 PM.
acemo is offline   Reply With Quote
Old 05-03-2011, 04:54 PM   #4
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,317
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
I agree, binary installs have drawbacks, but often it is the only way to distribute something as complex as calibre. sqlite >= 3.7 should be fine. Make sure the python sqlite.so module is also using sqlite >= 3.7
kovidgoyal is online now   Reply With Quote
Old 05-03-2011, 05:47 PM   #5
acemo
Junior Member
acemo began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2011
Device: pocketbook pro 603
Python has been rebuild for the latest sqlite3.
Did something get changed with calibre 0.7.46 -> 0.7.47 with sqlite?
Since we do have 0.7.46 working from source but any newer version fails.
acemo is offline   Reply With Quote
Old 05-03-2011, 06:14 PM   #6
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,317
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Looking at your error message, you need to update python to 2.7. Newer versions of calibre require python >= 2.7
kovidgoyal is online now   Reply With Quote
Old 05-03-2011, 07:23 PM   #7
abveritas
Junior Member
abveritas began at the beginning.
 
Posts: 1
Karma: 10
Join Date: May 2011
Device: none
Thank you for the quick response so far. I'd like to add some info to this thread, since I'm the packager for Chakra for this application.
Calibre was compiled for about 25 different versions leading up to .46, that one still works. Every version since has been compiled, starts, but as soon as any data is included into the the Calibre Library, the crash occurs with the output from the first post.
To try and find were the problem is, all the dependencies have been updated, or if no update available, rebuild. The python version is 2.7.1-5. All dependencies listed here:
http://calibre-ebook.com/download_linux
are newer in Chakra, only exception chmlib, that one is still at 0.40 also.
abveritas is offline   Reply With Quote
Old 05-03-2011, 09:28 PM   #8
user_none
Sigil & calibre developer
user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.
 
user_none's Avatar
 
Posts: 2,465
Karma: 986493
Join Date: Jan 2009
Location: Florida, USA
Device: Nook STR
My understanding of Chakra is it is very close to Arch Linux? Didn't it start life as Arch's KDEMod project then spin off into its own Arch based distro?

Is the Arch package having this same issue?

Also, you might be interested in these bugs I opened against the Arch package.
user_none is offline   Reply With Quote
Old 05-04-2011, 12:45 PM   #9
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,317
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
This error:

'Connection' object has no attribute 'enable_load_extension'

means that the sqlite module in python has no method named enable_load_extension. That method was introduced in python 2.7. As you can see here: http://docs.python.org/library/sqlit...ection-objects

Run this

calibre-debug -c "import sys; print sys.version_info"
kovidgoyal is online now   Reply With Quote
Old 05-13-2011, 05:58 PM   #10
mattepiu
Junior Member
mattepiu began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jun 2008
Device: PRS-650
I have tracked down very similar issue / second part of the issue:
ASSERT: "last >= first" in file kernel/qabstractitemmodel.cpp, line 2392
tracked down the guilty file is calibre/gui2/tag_view.py, in which for 3 times
beginInsertRows is used with last parameter lesser than second one, this is now forbidden in latest Qt.

(here at line 2393, the assert)
Still I haven't enough time to fix, sorry

Code:
/usr/lib64/calibre/calibre/gui2/tag_view.py:1266:                            self.beginInsertRows(category_index, 999999, 1) #len(data[key])-1)
/usr/lib64/calibre/calibre/gui2/tag_view.py:1299:                    self.beginInsertRows(category_index, 999999, 1)
/usr/lib64/calibre/calibre/gui2/tag_view.py:1335:                            self.beginInsertRows(category_index, 999999, 1)

Last edited by mattepiu; 05-13-2011 at 06:10 PM.
mattepiu is offline   Reply With Quote
Old 05-13-2011, 06:19 PM   #11
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,317
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
I committed a fix for that.
kovidgoyal is online now   Reply With Quote
Old 05-14-2011, 03:29 AM   #12
mattepiu
Junior Member
mattepiu began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jun 2008
Device: PRS-650
Thank you, it's starting now on gentoo linux.
mattepiu is offline   Reply With Quote
Old 05-14-2011, 11:01 AM   #13
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,317
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Quote:
Originally Posted by mattepiu View Post
Thank you, it's starting now on gentoo linux.
I'm somewhat surprised that you are having issues starting calibre on gentoo, considering that I develop it on ~amd64 gentoo.
kovidgoyal is online now   Reply With Quote
Old 05-21-2011, 04:31 AM   #14
mattepiu
Junior Member
mattepiu began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jun 2008
Device: PRS-650
It was depending on just the assert line in the latest 2 version of Qt I pointed above, if you're keeping Qt 4.7.1 you shouldn't find that issue.
(~amd64 gentoo here too)
mattepiu is offline   Reply With Quote
Old 05-24-2011, 07:39 AM   #15
acemo
Junior Member
acemo began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2011
Device: pocketbook pro 603
Quote:
Originally Posted by kovidgoyal View Post
I committed a fix for that.
We got it working again in chakra aswell.
acemo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OT-ish: Calibre in VirtualBox/Linux running Windows XP Client Gwen Morse Devices 9 04-14-2011 11:28 AM
kindlegen running on Linux JiYu Amazon Kindle 0 09-20-2010 07:08 AM
Anyone here running Linux from a USB drive? FizzyWater General Discussions 55 07-10-2010 12:09 AM
K4 Mac or PC getting Kindle4pc running in linux Lago Amazon Kindle 5 05-18-2010 07:27 PM
Ubuntu linux running on a Kindle 2 Jellby News 10 09-04-2009 06:49 PM


All times are GMT -4. The time now is 12:17 AM.


MobileRead.com is a privately owned, operated and funded community.