Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 02-01-2011, 11:34 AM   #1
Scavia
Junior Member
Scavia began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2011
Device: Kindle 3
Trouble emailing to Kindle

I am having trouble emailing to my Kindle. When I "Test Email" with my work email, i get the following error log:
Traceback (most recent call last):
File "site-packages\calibre\gui2\wizard\send_email.py", line 114, in test_email_settings
File "site-packages\calibre\utils\smtp.py", line 91, in sendmail
File "site-packages\calibre\utils\smtp.py", line 64, in sendmail_direct
File "site-packages\calibre\utils\smtp.py", line 56, in get_mx
File "site-packages\dnspython-1.9.1-py2.7.egg\dns\resolver.py", line 733, in query
File "site-packages\dnspython-1.9.1-py2.7.egg\dns\resolver.py", line 663, in query
File "site-packages\dnspython-1.9.1-py2.7.egg\dns\resolver.py", line 541, in _compute_timeout
Timeout


Log:
Find mail exchanger for free.kindle.com


When I use "Test email" with my Gmail account, I get the following:
Traceback (most recent call last):
File "site-packages\calibre\gui2\wizard\send_email.py", line 114, in test_email_settings
File "site-packages\calibre\utils\smtp.py", line 103, in sendmail
File "site-packages\calibre\utils\smtplib.py", line 303, in connect
File "site-packages\calibre\utils\smtplib.py", line 777, in _get_socket
File "socket.py", line 567, in create_connection
error: [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond


Log:


Any advice?
Scavia is offline   Reply With Quote
Old 02-01-2011, 11:54 AM   #2
Manichean
Wizard
Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!
 
Manichean's Avatar
 
Posts: 3,130
Karma: 80446
Join Date: Feb 2008
Location: Germany
Device: Cybook Gen3
The first event is a DNS timeout. I don't know how your computer is set up to reach your work email, but it says it can't reach a name server to look up the address of the server it needs. Is your work email server only reachable via an internal server? Can you normally access it from whereever you did the test?

The second error tells you that there was no response from the GMail server. That could have many reasons... Are you using the correct port (Did you configure it by clicking the big, friendly GMail button in the email preferences)? Is this a recurring error? If you have only tried it once, try it again, maybe the server is busy, or your connection unstable, or what have you.
Manichean is offline   Reply With Quote
 
Enthusiast
Old 02-01-2011, 01:10 PM   #3
Scavia
Junior Member
Scavia began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2011
Device: Kindle 3
Thanks

I am actually at work and on our network. So, I don't know why it can't connect.

I redid the Gmail set up using the big Use Gmai button. Here is the result of the test:
Traceback (most recent call last):
File "site-packages\calibre\gui2\wizard\send_email.py", line 114, in test_email_settings
File "site-packages\calibre\utils\smtp.py", line 103, in sendmail
File "site-packages\calibre\utils\smtplib.py", line 303, in connect
File "site-packages\calibre\utils\smtplib.py", line 281, in _get_socket
File "socket.py", line 567, in create_connection
error: [Errno 10061] No connection could be made because the target machine actively refused it


Log:
Scavia is offline   Reply With Quote
Old 02-01-2011, 03:22 PM   #4
Manichean
Wizard
Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!
 
Manichean's Avatar
 
Posts: 3,130
Karma: 80446
Join Date: Feb 2008
Location: Germany
Device: Cybook Gen3
That error is most often because of an intervening firewall. Something is blocking the connection between your computer and the GMail server. If you have a firewall running on your computer, you'll need to either disable it or, better, add an exception for Calibre. Same goes for an external firewall, though that might be more difficult if you're at work.
Manichean is offline   Reply With Quote
Old 02-01-2011, 05:15 PM   #5
Scavia
Junior Member
Scavia began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2011
Device: Kindle 3
Thanks again, but I already added and exception for Calibre. I am now at home and tried it again. No luck
Scavia is offline   Reply With Quote
Old 02-01-2011, 05:36 PM   #6
Manichean
Wizard
Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!
 
Manichean's Avatar
 
Posts: 3,130
Karma: 80446
Join Date: Feb 2008
Location: Germany
Device: Cybook Gen3
Okay, because we're seeing many help requests concerning this, I just went ahead and tested it using the configuration Calibre generated by pressing the big, helpful GMail button from a machine I know can send GMail via SMTP (I use it in Thunderbird). No problems.
If your configuration is correct otherwise, which is likely if you used said GMail button on the configuration page, there's something preventing Calibre from reaching the GMail server. Most probably it's a firewall of some sort. If you have configured your PC's firewall to allow Calibre access, there's still the possibility that your router, for whatever reasons, block SMTP to GMail servers (can you send mail via GMail from, say, Thunderbird or Outlook?). The last possibility is that your ISP prevents SMTP servers other than its own from being reached, which is not totally unheard of, though still incredibly rude, if you ask me.
It would help, for further troubleshooting, if you'd confirm that your settings are correct. (The working settings for me are smtp.gmail.com on port 587, TLS enabled. Your username should include the @gmail.com or @googlemail.com, though you'd get a different error if that was the problem.)

Last edited by Manichean; 02-01-2011 at 05:38 PM.
Manichean is offline   Reply With Quote
Old 02-01-2011, 05:38 PM   #7
Scavia
Junior Member
Scavia began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2011
Device: Kindle 3
I solved it (I hope). On another thread someone suggested changing the Gmail connection to use port 465 and SSL. When I made that change everything seemed to work fine. If you can explain why, I'd appreciate it!

Thanks
Scavia is offline   Reply With Quote
Old 02-01-2011, 05:43 PM   #8
Manichean
Wizard
Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!
 
Manichean's Avatar
 
Posts: 3,130
Karma: 80446
Join Date: Feb 2008
Location: Germany
Device: Cybook Gen3
Well, I would guess that port 587 is blocked, then. Which would be no fault of the GMail servers, but still a problem somewhere in between. 465 seems to not be blocked.
Manichean is offline   Reply With Quote
Old 02-01-2011, 05:47 PM   #9
Scavia
Junior Member
Scavia began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2011
Device: Kindle 3
Thanks for the help.
Scavia is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Emailing books through Calibre to Kindle new Amazon Kindle 9 10-05-2012 01:02 PM
Noob question about emailing the Kindle... leaston Amazon Kindle 2 01-07-2011 10:18 AM
emailing books to kindle krazy4katz Calibre 2 10-08-2010 12:07 AM
Emailing snippets from Kindle... gfmucci Amazon Kindle 0 05-17-2010 08:56 AM
Emailing PDF's to youremail@Kindle.com HaggisMacJedi Amazon Kindle 2 06-07-2008 01:48 PM


All times are GMT -4. The time now is 01:22 PM.


MobileRead.com is a privately owned, operated and funded community.