Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 09-27-2014, 10:50 AM   #1
GoSharks
SQUIRREL!!
GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.
 
GoSharks's Avatar
 
Posts: 1,463
Karma: 3890736
Join Date: Nov 2010
Location: California
Device: K-Fire, PW1, PW2
Question Calibre 1.48...Continue Updating Plugins?

For those of us with computer OS inadequacies (), should we continue updating the plugins as the updates come out or will the plugins eventually evolve to being not backward compatible?
Thanks!
GoSharks is offline   Reply With Quote
Old 09-27-2014, 11:06 AM   #2
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,860
Karma: 5654321
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by GoSharks View Post
For those of us with computer OS inadequacies (), should we continue updating the plugins as the updates come out or will the plugins eventually evolve to being not backward compatible?
Thanks!
Using 'Get Plugins' will not offer you PI that require Calibre versions above what is installed (Min. Version in the index).
theducks is offline   Reply With Quote
 
Enthusiast
Old 09-27-2014, 11:09 AM   #3
GoSharks
SQUIRREL!!
GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.GoSharks ought to be getting tired of karma fortunes by now.
 
GoSharks's Avatar
 
Posts: 1,463
Karma: 3890736
Join Date: Nov 2010
Location: California
Device: K-Fire, PW1, PW2
Quote:
Originally Posted by theducks View Post
Using 'Get Plugins' will not offer you PI that require Calibre versions above what is installed (Min. Version in the index).
Well that was simple...Thanks!!
GoSharks is offline   Reply With Quote
Old 09-27-2014, 06:12 PM   #4
stanking
Noob Developer
stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.stanking ought to be getting tired of karma fortunes by now.
 
Posts: 24
Karma: 219932
Join Date: Aug 2014
Location: Texas
Device: Nook Color
I regularly update to the latest version whenever Calibre prompts me, but as noob plugin developer, it would be nice to know the demographics of what versions are being used. Is there any tool out there that collects such data? Otherwise, I'd be tempted to create a plugin that works with the current version with no regard to the past.
stanking is offline   Reply With Quote
Old 09-27-2014, 07:05 PM   #5
BetterRed
null operator
BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.
 
Posts: 3,619
Karma: 2183656
Join Date: Mar 2012
Location: NSW Australia
Device: none
@stanking - there's this Usage Statistics for calibre - I don't know if Kovid has more granular stats - ie which versions of Windows, OS/X and Linux.

You could install 1.48 (portable if you have Windows) and do some tests against it. If your PI works you could make that the minimum version that would allow the folks stuck on older versions of XP & OS/X - I imagine they'd give you some brownie points for that.

But its inevitable that one day you'll have pull the plug on compatibility with old versions and change the minimum.

That said, given you're developing new PI's it would be more than reasonable for you to set the minimum calibre version to the one current at the time of the initial release of the PI.

There's nothing to stop a user changing minimum_calibre_version in __init__.py to there current version of calibre and trying. Most PI's don't change too often.

BR
BetterRed is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
calibre plugins whizbo Calibre 3 09-20-2013 04:08 PM
Aura HD Calibre Plugins and Tricks thoreau Kobo Reader 1 05-06-2013 02:49 PM
Calibre Portable like the Calibre on PC (espec. settings and plugins)? manawydan Devices 6 01-23-2013 06:45 AM
Updating plugins paulfiera Plugins 2 11-04-2011 09:12 AM
Best Calibre plugins/tweaks baronrus Kobo Reader 2 05-24-2011 11:09 PM


All times are GMT -4. The time now is 05:29 PM.


MobileRead.com is a privately owned, operated and funded community.