Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 01-05-2011, 02:14 AM   #1
Robotech_Master
Evangelist
Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.Robotech_Master ought to be getting tired of karma fortunes by now.
 
Posts: 422
Karma: 351205
Join Date: May 2006
Python not installing on Ubuntu

When I try to install Calibre in Linux, using the instructions on the Calibre download page, I get the following. Can anyone tell me how to fix this?


root@terrania:/home/robotech/calibre# python setup.py install
Failed to run pkg-config: None for: poppler
Failed to run pkg-config: None for: poppler-qt4
Traceback (most recent call last):
File "setup.py", line 13, in <module>
import setup.commands as commands
File "/home/robotech/calibre/setup/commands.py", line 28, in <module>
from setup.translations import POT, GetTranslations, Translations, ISO639
File "/home/robotech/calibre/setup/translations.py", line 14, in <module>
from setup.build_environment import pyqt
File "/home/robotech/calibre/setup/build_environment.py", line 155, in <module>
popplerqt4_inc_dirs = poppler_inc_dirs + [poppler_inc_dirs[0]+'/qt4']
IndexError: list index out of range
Robotech_Master is offline   Reply With Quote
Old 01-05-2011, 07:08 AM   #2
user_none
Sigil & calibre developer
user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.
 
user_none's Avatar
 
Posts: 2,460
Karma: 986493
Join Date: Jan 2009
Location: Florida, USA
Device: Nook STR
That error is because you do not have Poppler and Poppler Qt 4 development packages installed.

I would recommend against installing from source as there are a large number of dependencies. Also, some dependencies require a specific version that Ubuntu's repositories may or may not have.

Use the binary installer method . If you want to develop calibre or make changes directly (not through a plugin) then use the binary installer method detailed in the user manual.
user_none is offline   Reply With Quote
 
Enthusiast
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Old Thread] Problem installing on Ubuntu Linux bgcamroux Calibre 6 05-23-2012 02:30 AM
Installing latest Calibre in Ubuntu 10.04 maitrayei Calibre 4 09-10-2010 02:48 AM
Problems Installing on Lunix Ubuntu machine Snackb0y11 Calibre 2 12-28-2009 11:04 AM
Installing Python? luqmaninbmore PocketBook 2 11-20-2009 01:41 AM
calibre python-lxml problem on ubuntu carpii Calibre 5 11-29-2008 05:34 AM


All times are GMT -4. The time now is 12:34 PM.


MobileRead.com is a privately owned, operated and funded community.