Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 01-03-2011, 01:48 AM   #1
silver84
Member
silver84 began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Nov 2010
Device: Archos 7 H.T. Archos 70 Samsung E60
loader problem with old Ubuntu Hardy

Hi,

I have read that 0.6.17 work with this old Ubuntu Hardy, but I dont find it; so I have installed the oldest I found on sourceforge, the 0.6.18.


sudo LD_DEBUG=libs /opt/calibre/calibre-debug -c "print 1" 2>&1 | less
give me this error :
Quote:
...
4834: search cache=/etc/ld.so.cache
4834: trying file=/lib/tls/i686/cmov/libc.so.6
4834:
4834:
4834: calling init: /lib/tls/i686/cmov/libc.so.6
4834:
4834:
4834: initialize program: /bin/sh
4834:
4834:
4834: transferring control: /bin/sh
4834:
/opt/calibre/loader: 1: ^?ELF^B^A^A^B: not found
/opt/calibre/loader: 2: Syntax error: ")" unexpected
I unzip loader.zip : same error

I also installed python-lxml_2.1.1-2.1_i386.deb but I have the same error.

Can you help me ?
silver84 is offline   Reply With Quote
Old 01-03-2011, 11:55 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,436
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
that's a little too old, for anyone to remember. I'd suggest instead trying the newer version. You will need a version of glibc >= 2.10, you can either compile it yourself or google for a precompiled one for Hardy and put it into /opt/calibre/libs
kovidgoyal is offline   Reply With Quote
 
Advertisement
Old 01-04-2011, 07:42 AM   #3
silver84
Member
silver84 began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Nov 2010
Device: Archos 7 H.T. Archos 70 Samsung E60
Many thanks for your answer.
I was surely a little tired by the end of years festivities
Its not Hardy, but Intrepid...

Compile last sources need Python 2.6, I have only 2.4 and 2.5 and dont find any .deb calibre working on Intrepid on the net.
silver84 is offline   Reply With Quote
Old 01-04-2011, 09:10 AM   #4
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,908
Karma: 12755553
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by silver84 View Post
Many thanks for your answer.
I was surely a little tired by the end of years festivities
Its not Hardy, but Intrepid...

Compile last sources need Python 2.6, I have only 2.4 and 2.5 and dont find any .deb calibre working on Intrepid on the net.
Do as Kovid suggests then try a binary install as described here or vice-a-versa.
DoctorOhh is offline   Reply With Quote
Old 01-04-2011, 09:49 AM   #5
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,907
Karma: 1217216
Join Date: Jan 2010
Location: France
Device: Many android devices
I think that Intrepid is too old to run the binary installer. If intrepid was built from Debian Sarge or Lenny, then it certainly is.

At one point I tried to get calibre running on Lenny. I succeeded in getting the content server to run. My guess is that the GUI could have run after installing and configuring the rest of X, but I never tried it as my machine is headless. Some short documentation on what I did is here. Note that setting up a chrooted jail is not your run-of-the-mill configuration chore. If you are not comfortable with the command line and system administration, I suggest you don't attempt it.

However, all would be much easier if you upgraded.
chaley is offline   Reply With Quote
Old 01-04-2011, 10:24 AM   #6
silver84
Member
silver84 began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Nov 2010
Device: Archos 7 H.T. Archos 70 Samsung E60
@dwanthny :
Thanks, but of course I have try to install last binary, it dont work, so I try :
Quote:
Note

* You need GLIBC 2.10 or higher to run versions greater than 0.6.29. If you receive an error about GLIBC you can downgrade to an older version by getting the .tar.bz2 file for your architecture (32bit or 64bit) from sourceforge. Then delete the contents of /opt/calibre and extract the downloaded .tar.bz2 file into /opt/calibre.
...
.
And got the error in my first post above


Compiling need :
Quote:
Source install

1. Make sure your system has python ≥ 2.6
...
read my second post above.
(And the current binary version "speak" about Python 2.7)


@chaley
Thanks, but your "chrooted" solution is very complicated, not flexible.

Sure, one "easy"solution is to upgrade Intrepid, but its not so simple, I have many softwares, some of them are not in standard packages, this migration need many, many hours and must be done on 3 computers


[sorry, my English is very bad]

Last edited by silver84; 01-04-2011 at 10:36 AM.
silver84 is offline   Reply With Quote
Old 01-04-2011, 10:28 AM   #7
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,907
Karma: 1217216
Join Date: Jan 2010
Location: France
Device: Many android devices
Well, my guess is that with your constraints, you won't be able use calibre.
chaley is offline   Reply With Quote
Old 01-04-2011, 10:46 AM   #8
silver84
Member
silver84 began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Nov 2010
Device: Archos 7 H.T. Archos 70 Samsung E60
The solution seem to get the 0.6.17 version but I dont find this archive on the net.
silver84 is offline   Reply With Quote
Old 01-04-2011, 12:00 PM   #9
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 15,260
Karma: 6020309
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
My bad, stops at 6.18

Last edited by theducks; 01-04-2011 at 12:17 PM.
theducks is offline   Reply With Quote
Old 01-04-2011, 12:34 PM   #10
silver84
Member
silver84 began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Nov 2010
Device: Archos 7 H.T. Archos 70 Samsung E60
Bingo !

I dont know if its the reason, I have installed Python 2.6 minimal, its here :

http://jaredforsyth.com/blog/2009/ja...hon-26-ubuntu/


And now 0.6.18 seem to work !

Now, I will try with newest version of calibre
silver84 is offline   Reply With Quote
Old 01-04-2011, 03:47 PM   #11
silver84
Member
silver84 began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Nov 2010
Device: Archos 7 H.T. Archos 70 Samsung E60
The continuation :

Now calibre seem to work till 6.29 version

6.30 dont work, because it requires glibc 2.9 (Intrepid uses, on my computer, glibc 2.8).

Quote:
ImportError: (ImportError("/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.9' not found (required by /opt/calibre/libQtCore.so.4)",), <built-in function _unpickle_enum>, ('PyQt4.QtCore', 'SortOrder', 1))
OK I install Glibc 2.9 from here :

http://mirrors.kernel.org/ubuntu/pool/main/g/glibc/

This installation need to repair my old libc6 (with glibc 2.8) broken.

And now calibre 6.3 dont ask for glibc 2.9, but for glibc 2.10 :

Quote:
...
ImportError: /lib/tls/i686/cmov/.so.6: version `GLIBC_2.10' not found (required by /opt/calibre/libQtNetwork.so.4)
Hi, hi, hi...

Since 1979 I never get bored anymore, I use, work with computers

Last edited by silver84; 01-04-2011 at 03:50 PM.
silver84 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu hardy problem with binary install `Illegal instruction` lampadena Calibre 2 02-10-2009 03:57 AM
Ubuntu Hardy Calibre Problem vakya Calibre 27 01-26-2009 05:15 PM
downloading calibre in ubuntu hardy ElizabethN Calibre 1 12-29-2008 01:56 AM
calibre install fails on Ubuntu hardy Xpi6 Calibre 16 11-16-2008 02:29 PM
New versions of calibre in Ubuntu Hardy 64 Bit deedward9 Calibre 19 10-18-2008 12:21 AM


All times are GMT -4. The time now is 01:20 PM.


MobileRead.com is a privately owned, operated and funded community.