Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle

Notices

Reply
 
Thread Tools Search this Thread
Old 12-03-2010, 01:54 PM   #1
Hyperinflation
Junior Member
Hyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enough
 
Posts: 3
Karma: 666
Join Date: Dec 2010
Device: Kindle3
Set Kindle3 Timezone *WITHOUT* Whispernet???

Hi Guys.

I have a US Wifi Kindle 3 in Thailand. I am really frustrated trying to get the timezone to set properly.

I do not have access to a Wifi network or Whispernet. I have jailbreak'ed and installed USBNetworking.

From the Linux command line, everything looks good. I get the following when I ssh into the device:

[root@kindle /etc]# date
Sat Dec 4 01:56:40 ICT 2010
[root@kindle /etc]# hwclock
Fri Dec 3 18:56:44 2010 0.000000 seconds
[root@kindle /etc]#

This is all correct. ICT is the correct Timezone, and represents GMT+7. The hardware clock is properly set to UTC. The problem is, on the Kindle itself, it isn't picking up the Linux timezone. It still shows at GMT!

What gives? How can I force the Kindle timezone to the correct value? It apparently ignores the OS settings. Anyone know where this information is stored?

Thanks for any assistance.
Hyperinflation is offline   Reply With Quote
Old 12-03-2010, 03:16 PM   #2
Hyperinflation
Junior Member
Hyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enoughHyperinflation will become famous soon enough
 
Posts: 3
Karma: 666
Join Date: Dec 2010
Device: Kindle3
An update to this:

Currently I have fixed the problem by changing the start.sh file located in:

/opt/amazon/ebook/bin/start.sh

I modified line 188 to add "-Duser.timezone=Asia/Bangkok" to the $opts variable that is used to start the Java VM. I now get the correct time displayed, but this seems like an awful hack.

Anybody have a more elegant solution?
Hyperinflation is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting kindle3 gmail desrtfreak Amazon Kindle 6 09-22-2010 10:28 PM
V 0.6.41 - Timezone aware - how to use this feature? solitaire Calibre 3 02-20-2010 05:10 AM
iLiad Set Timezone on your iLiad scotty1024 iRex Developer's Corner 14 05-19-2007 02:59 AM


All times are GMT -4. The time now is 12:04 PM.


MobileRead.com is a privately owned, operated and funded community.