Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 10-11-2010, 11:45 AM   #1
RockSlice
Junior Member
RockSlice began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2010
Device: Kindle (3)
K3 splitting words in Mobi

New Calibre user here.

When I view a mobi file I've created, my K3 splits words in order to fill the horizontal space. I know this isn't because of the Kindle, because mobi files I get from Amazon will stretch out the word gaps.

Is there any way to fix this?
RockSlice is offline   Reply With Quote
Old 10-11-2010, 11:48 AM   #2
desertgrandma
Enjoying the show....
desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.desertgrandma ought to be getting tired of karma fortunes by now.
 
desertgrandma's Avatar
 
Posts: 14,277
Karma: 8205255
Join Date: Jun 2008
Location: Arizona
Device: A K1, Kindle Paperwhite, an Ipod, IPad2, Iphone, an Ipad Mini & macAir
Welcome to MobileRead, RockSlice
desertgrandma is offline   Reply With Quote
Old 10-11-2010, 11:52 AM   #3
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,991
Karma: 5036765
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Use the etxt justification option under look & feel in the conversion settings.
kovidgoyal is offline   Reply With Quote
Old 10-11-2010, 12:08 PM   #4
RockSlice
Junior Member
RockSlice began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2010
Device: Kindle (3)
Guess I need to update. (On deployment, so not easy) Using 0.7.13 right now, from the MaximumPC disc.
Thank you.
RockSlice is offline   Reply With Quote
Old 11-12-2010, 12:20 PM   #5
RockSlice
Junior Member
RockSlice began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2010
Device: Kindle (3)
I managed to update to the version that's live on the site (0.7.27), and can't see the etxt justification option. Under justification, the only options are "original", "left", and "justified".

Tried various options, but can't get anything to stop the words from being split.

What am I missing?
RockSlice is offline   Reply With Quote
Old 11-12-2010, 12:28 PM   #6
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,991
Karma: 5036765
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
justified is the setting you need. Another cause of this could be if your input document includes soft hyphens in it.
kovidgoyal is offline   Reply With Quote
Old 11-12-2010, 12:51 PM   #7
RockSlice
Junior Member
RockSlice began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2010
Device: Kindle (3)
It's still not working. I don't think it's due to soft hyphens in the input document, as the input document is txt.
RockSlice is offline   Reply With Quote
Old 11-29-2010, 10:04 AM   #8
RockSlice
Junior Member
RockSlice began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2010
Device: Kindle (3)
My apologies. It's not a mobi problem. It seems to be a problem with converting from text, whether to mobi or epub, or any other format, and the problem follows the file, so going txt -> epub -> mobi doesn't help.

In the Calibre viewer, the problem is seen as every paragraph being on one line, with no wrapping of text (except at dashes). I've tried looking at the exploded epub to find differences between the same file converted from txt, and one where I pasted the text into an rtf file, then converted it (which worked properly), but couldn't find any differences that solved the issue.
When I hit port next, I'll upload the test files if you want me to. In the meantime, is there anything you can suggest?
RockSlice is offline   Reply With Quote
Old 11-29-2010, 11:07 AM   #9
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,991
Karma: 5036765
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
explore the options under txt input for line breaking. for example, 'treat each line as a paragraph'
kovidgoyal is offline   Reply With Quote
Old 11-29-2010, 04:58 PM   #10
ldolse
Wizard
ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.
 
Posts: 1,337
Karma: 123455
Join Date: Apr 2009
Location: Malaysia
Device: PRS-650, iPhone
Try the treat each line as a paragraph option under text input as Kovid mentioned. Also, just in case soft-hyphens are your problem you can also enable the 'preprocess input file to possibly improve structure detection' option under the structure detection options. that should remove any soft-hyphens buried in the doc.
ldolse is offline   Reply With Quote
Old 11-30-2010, 03:26 AM   #11
RockSlice
Junior Member
RockSlice began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2010
Device: Kindle (3)
Found it! The setting was "Preserve spaces"

The txt files were using hex value '20' as a space, which if "preserve spaces" was off got converted into 'C2 A0'

Both the K3 and Calibre viewer show this as a blank, but don't seem to treat it as a valid character with which to separate words, so they treat the entire paragraph as a single word.

This also explains why it stuck through conversions, as the '20' space was still present to be carried over to the next format.

Thank you for your help in this. I don't know if you want to treat this as a "bug", as the setting was preserving the spaces as they were.
RockSlice is offline   Reply With Quote
Old 12-31-2010, 01:38 AM   #12
fmoses
Junior Member
fmoses began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Nov 2010
Device: none
I was having this problem with Pages (on a Mac) documents exported as ePubs and then converted to Mobi in Calibre. I eventually found that if in Pages I made the text full justified then the words did not split at end of lines anymore on the Kindle. With a Mac, this seems to be the easiest way to get beautifully organized documents with a full TOC onto a Kindle:
1. In Pages create the document using Styles to set up the TOC where you want breaks (Heading 1, Heading 2, etc.) Use the Inspector to setup the TOC and which styles will be displayed in the TOC.
2. ***Make sure all paragraphs are full justified alignment. For some reason left-justified text shows up on the Kindle but words are split at end of lines. Full justification seems to fix this.
3. Export file as ePub.
4. Import into Calibre and convert to MOBI format.
5. Send to Kindle.
fmoses is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After conversion to mobi words get always wrapped nielsk Calibre 5 10-01-2010 01:34 PM
PDF to MOBI conversion - unable to detect any words qwerty123456 Calibre 1 07-22-2010 07:54 AM
Splitting files... or something? *Angie* Calibre 4 09-14-2009 07:42 PM
Splitting an ebook in 2 Spectralist Workshop 5 06-07-2009 08:01 AM
Splitting help needed tibiafry Workshop 1 05-18-2009 08:16 AM


All times are GMT -4. The time now is 10:49 AM.


MobileRead.com is a privately owned, operated and funded community.