Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > More E-Book Readers > iRex > iRex Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 12-25-2007, 04:57 AM   #46
ericshliao
Guru
ericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enough
 
Posts: 974
Karma: 687
Join Date: Nov 2007
Device: Dell X51v; iLiad v2
After some tedious experiment and research, I think that Stardict 3.0.1 is not able to port to iLiad. I was blocked because it requires GTK+ 2.12 above. The current SDK released by iRex uses GTK+2.6.7.
With this experience, I would suggest that checking lib dependency of the software you want to port to iLiad is important. Older linux software may have higher possibility to make sussefull porting to iLiad.
ericshliao is offline   Reply With Quote
Old 01-05-2008, 04:45 AM   #47
King Mook Mook
Member
King Mook Mook began at the beginning.
 
King Mook Mook's Avatar
 
Posts: 12
Karma: 10
Join Date: Dec 2007
Device: Kindle 2 International
Problem HELP!!

When I try to download the stardict program it says that the host is not found I have tried to download other things but they have the same result. If some could help that would be greatly appreciated. I have attached a picture of it saying host not found.

King Mook Mook

King Mook Mook is offline   Reply With Quote
Old 03-08-2008, 01:11 PM   #48
Talisman
Junior Member
Talisman began at the beginning.
 
Talisman's Avatar
 
Posts: 6
Karma: 10
Join Date: Mar 2008
Device: iLiad :)
My solution of this problem:
1) login as root
2) change dir to /scratchbox/users/<your scrbox username>/
3) use wget
4) login as scratchbox and compile it
Talisman is offline   Reply With Quote
Old 03-08-2008, 01:16 PM   #49
Talisman
Junior Member
Talisman began at the beginning.
 
Talisman's Avatar
 
Posts: 6
Karma: 10
Join Date: Mar 2008
Device: iLiad :)
but I have another problem:
Attached Thumbnails
Click image for larger version

Name:	lgsl.JPG
Views:	386
Size:	30.2 KB
ID:	11338  

Last edited by Talisman; 03-08-2008 at 02:38 PM.
Talisman is offline   Reply With Quote
Old 03-14-2008, 12:19 PM   #50
Luka Trifunovic
Member
Luka Trifunovic began at the beginning.
 
Posts: 14
Karma: 10
Join Date: Mar 2008
Device: None
Quote:
Originally Posted by King Mook Mook View Post
When I try to download the stardict program it says that the host is not found I have tried to download other things but they have the same result. If some could help that would be greatly appreciated. I have attached a picture of it saying host not found.

King Mook Mook

This is because wget is not working properly in scratchbox. Does somebody know how to reinstall some program in scratchbox? Another way is to modify dl-and-install script to use lynx (I tried to download file using lynx from scbox and it works) for download instead wget (this is not so simple because one must use "expect" command or "here document" redirection << and >>)

Regards,

Luka
Luka Trifunovic is offline   Reply With Quote
Old 03-17-2008, 09:56 PM   #51
Luka Trifunovic
Member
Luka Trifunovic began at the beginning.
 
Posts: 14
Karma: 10
Join Date: Mar 2008
Device: None
The easiest solution is to edit dl-and-install script this way:
find the line "wget $i" and change it to "lynx -dump $i > `basename $i`" and that it!

The only problem is that you don't see progress while downloading... so you have to be patient.
Luka Trifunovic is offline   Reply With Quote
Old 05-16-2008, 05:19 AM   #52
mojojojo
Junior Member
mojojojo began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Dec 2007
Device: Irex Iliad
Debian openssl security flaw relevance

Hi!

As I understand it, this vmware image was built on debian. Is the openssl library installed on it, and is it one of the versions affected by the recent debian openssl critical security flaw?
I'm referring to
http://www.debian.org/security/2008/dsa-1571

In short, what the above link says, is that on debian linux distributions any public keys generated by the flawed openssl library is easily predicted, and unfortunately the flawed openssl version has been in production since late 2006, I believe.
mojojojo is offline   Reply With Quote
Old 05-16-2008, 06:46 AM   #53
Alexander Turcic
Fully Converged
Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.Alexander Turcic ought to be getting tired of karma fortunes by now.
 
Alexander Turcic's Avatar
 
Posts: 17,331
Karma: 10995944
Join Date: Oct 2002
Location: Switzerland
Device: Sony PRS-650 / Nexus 7 / Kindle PW
Quote:
Originally Posted by mojojojo View Post
Hi!

As I understand it, this vmware image was built on debian. Is the openssl library installed on it, and is it one of the versions affected by the recent debian openssl critical security flaw?
I'm referring to
http://www.debian.org/security/2008/dsa-1571

In short, what the above link says, is that on debian linux distributions any public keys generated by the flawed openssl library is easily predicted, and unfortunately the flawed openssl version has been in production since late 2006, I believe.
Thanks for the heads-up, mojojojo. Indeed it's a nasty flaw and we've been busy the last days updating all our server keys. In general, keys generated before September 2006 are not affected by the flaw. The recommended procedure is to update openssh/openssl (via aptitude dist-upgrade), replace the host keys, and to run ssh-vulnkey afterwards to check for weak user keys.

Since the VMWare image was created more than one year ago, I suspect there are other security updates necessary as well. So when you download it, it's best to run a system upgrade first before using it.
Alexander Turcic is offline   Reply With Quote
Old 06-16-2008, 09:08 AM   #54
kran
Member
kran began at the beginning.
 
Posts: 21
Karma: 10
Join Date: Jun 2008
Device: iLiad
Hi,
Thanks for the VMWare image, it's really great ! ... However, I can't compile my programs... In fact, I got a long error message when I run the makefile, saying packages are not found (libcurl for example)

do you know where I made a mistake ?
kran is offline   Reply With Quote
Old 06-16-2008, 09:59 AM   #55
Adam B.
Addicted to Porting
Adam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the rough
 
Adam B.'s Avatar
 
Posts: 1,695
Karma: 7194
Join Date: Oct 2006
Location: Indianapolis, IN
Device: iRex iLiad, Nokia 770, Samsung i760
The image probably doesn't have every package you need. You likely need to download, compile, and install the latest version of curl.
Adam B. is offline   Reply With Quote
Old 06-17-2008, 05:47 AM   #56
kran
Member
kran began at the beginning.
 
Posts: 21
Karma: 10
Join Date: Jun 2008
Device: iLiad
I tried "sudo apt-get install libcurl3 libcurl3-dev" ... But it seems it didn't work... any idea ?

EDIT : lol ... hum, I think I wasn't really awake when I wrote that ... For people who will read this post in the future, just do as usual when you install a package :

wget http://curl.haxx.se/download/curl-7.15.5.tar.gz (for example)
and then use the super script unpack-n-patch-n-build-install.sh ....


However, I get now :
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'

... so I try to install gtk+-2.0, but there I have this error :

configure: error: Library requirements (glib-2.0 >= 2.0.0 atk >= 1.0.0 pango >= 1.0.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

??? Have I to re-install every library ?!?

Last edited by kran; 06-17-2008 at 07:02 AM.
kran is offline   Reply With Quote
Old 06-17-2008, 10:35 AM   #57
Adam B.
Addicted to Porting
Adam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the rough
 
Adam B.'s Avatar
 
Posts: 1,695
Karma: 7194
Join Date: Oct 2006
Location: Indianapolis, IN
Device: iRex iLiad, Nokia 770, Samsung i760
I depends which version of GTK you're using. If you use the most recent, then yeah, you'll have to compile all of it's dependencies. You may want to see the minimum version required for your program and use that.

Welcome to building Linux packages from scratch.
Adam B. is offline   Reply With Quote
Old 06-17-2008, 02:59 PM   #58
yokos
Pac-Man catched my iLiad.
yokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with others
 
yokos's Avatar
 
Posts: 720
Karma: 2571
Join Date: Apr 2006
Location: Germany; next to Baltic Sea
Device: 1st gen iRex iLiad with 2nd ed. battery/case
The scratchbox environment in VM has got an installed gtk+-2.0.

I built GTK+ 2.12.x because I was bored/some apps needed more recent gtk dep libraries. ;-)
yokos is offline   Reply With Quote
Old 06-20-2008, 11:51 PM   #59
joblack
Wizard
joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.joblack ought to be getting tired of karma fortunes by now.
 
Posts: 1,278
Karma: 1418786
Join Date: Jul 2006
Location: Somewhere on earth
Device: Kindle Paperwhite, Kindle DX, JBC, Onyx M92
I´m interested in including the dev.pack in my debian installation? Is there a howto / description what packages are needed?
joblack is offline   Reply With Quote
Old 06-21-2008, 04:59 AM   #60
yokos
Pac-Man catched my iLiad.
yokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with othersyokos plays well with others
 
yokos's Avatar
 
Posts: 720
Karma: 2571
Join Date: Apr 2006
Location: Germany; next to Baltic Sea
Device: 1st gen iRex iLiad with 2nd ed. battery/case
Quote:
Originally Posted by joblack View Post
I´m interested in including the dev.pack in my debian installation? Is there a howto / description what packages are needed?
http://wiki.mobileread.com/wiki/Note...sing_crosstool
Or you can use the official SDK (download sextion on the iRex site).

@the one who have problems with wget in scratchbox environment:
./configure, make the latest version of wget & copy the binary wget to /scratchbox/tools/bin/wget
You have to change the rights with chmod outside of scratchbox to get writing rights in /scratchbox/tools/bin
Then are the "host not found" messages gone.
Anybody interested in the binary?
yokos is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
iRex DR1000 Development VMWare Image Adam B. iRex 9 08-19-2010 05:23 AM
DR800 Developement VMWare Image? CoolDragon iRex 8 04-04-2010 06:30 AM
calibre VMWare development environment kovidgoyal Calibre 30 12-30-2009 01:43 PM
iLiad iRex iLiad development enviroment on VMware image Alexander Turcic iRex Developer's Corner 0 03-31-2007 03:02 PM


All times are GMT -4. The time now is 01:55 AM.


MobileRead.com is a privately owned, operated and funded community.