Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Reading and Management

Notices

Reply
 
Thread Tools Search this Thread
Old 12-11-2009, 09:10 AM   #1
leonnyan
Enthusiast
leonnyan began at the beginning.
 
Posts: 27
Karma: 10
Join Date: Aug 2009
Location: Singapore
Device: PRS700BC
Sony Reader 3.1 software - bad again?

Hi,

I just installed the Reader 3.1 software from Sony. I booted normally (not Safe mode) on my W7 PC and the eBook software offered an update. I ran it. End of the installer, it asks if I'd like the software to launch, it doesn't.

I can see in the Task Manager Reader Library Launcher is running, but if I try to run Reader Library it launches and fails without ever showing me a dialog. I've restarted and tried again, same issue. I am not looking forward to troubleshooting this (Sony technical support is poor) on my own.

Anyone else have an experience yet?

Suffice it to say Sony continues to make mind boggling junk software IMHO. The install experience alone this time just make me hate them more.

--Leon
leonnyan is offline   Reply With Quote
Old 12-11-2009, 09:16 AM   #2
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 38,507
Karma: 19637653
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2), Sony PRS-650, Sony PRS-T1, nook STR, iPad 1, iPhone 5
I did install 3.1 on my Windows XP Pro system and it works fine. No issues at all. I did stp the Reader Library Launcher from running and starting on boot. But other then that, all is well.
JSWolf is online now   Reply With Quote
Old 12-11-2009, 09:46 AM   #3
leonnyan
Enthusiast
leonnyan began at the beginning.
 
Posts: 27
Karma: 10
Join Date: Aug 2009
Location: Singapore
Device: PRS700BC
I am cursed then. I just uninstalled and re-installed the software. Same issue. I can in Task Manager the .exe kick off, but it then fails and goes away. Any ideas anyone? I am warming up to a Kindle now...this software is just killing me.
leonnyan is offline   Reply With Quote
Old 12-11-2009, 05:15 PM   #4
toolio
Enthusiast
toolio has learned how to read e-bookstoolio has learned how to read e-bookstoolio has learned how to read e-bookstoolio has learned how to read e-bookstoolio has learned how to read e-bookstoolio has learned how to read e-bookstoolio has learned how to read e-books
 
Posts: 33
Karma: 870
Join Date: Oct 2003
Location: Brazil
Device: Sony Reader/IPAQ 210/Ipod Touch
This software is really annoying me. My 3.0 stopped working about a week ago..it loads and appears in Vista processes but nothing appears on the desktop. Reinstalled it and tried various recommended fixes. Cleaned the registry of all remnants and reinstalled. Etc. Thought 3.1 might magically get it working, but it's the same old crap. I know I can (and do) use calibre to manage my Sony Reader, but without this software working I have no way to buy books on the Sony store.

You'd think a company that only allows you to buy books through your computer would make software that works.
toolio is offline   Reply With Quote
Old 12-11-2009, 05:57 PM   #5
rwsimon
Connoisseur
rwsimon has a complete set of Star Wars action figures.rwsimon has a complete set of Star Wars action figures.rwsimon has a complete set of Star Wars action figures.
 
Posts: 50
Karma: 288
Join Date: Jun 2007
Location: Upstate New York
Device: 2 Sony PRS-500s, iPad
I too cannot launch 3.1 on my machine, but I believe that it is because I am running it on a virtual PC on my Mac. According to Sony, this won't work (that's a first... anything else has always worked on the virtual PC.)

However, there is apparently another way that 3.1 won't launch. Perhaps this might help some people:
http://www.kb.sony.com/selfservice/v...Id=1&mdl=null#
rwsimon is offline   Reply With Quote
Old 12-11-2009, 05:58 PM   #6
dn ereader
Junior Member
dn ereader began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Dec 2009
Device: prs - 505
new download does not work again

just downloaded the new software, but should have knoen better.
again it does not work, click the icon and nothing happens.

tried to use karinc instructions which were so helpful last time, but no success.

who can help????
dn ereader is offline   Reply With Quote
Old 12-11-2009, 07:32 PM   #7
leonnyan
Enthusiast
leonnyan began at the beginning.
 
Posts: 27
Karma: 10
Join Date: Aug 2009
Location: Singapore
Device: PRS700BC
I'm glad I'm not alone. I now have no working software and am not looking forward to a rip and reinstall with only a slim hope it will work. I'll update the forum if I figure out a successful reinstall that works with Win 7. So far, no love.

--Leon
leonnyan is offline   Reply With Quote
Old 12-12-2009, 12:29 AM   #8
Coyotebd
Junior Member
Coyotebd began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Sep 2009
Device: Sony PR-600
Ugh, when am I going to learn to stop automatically installing the latest version, since every time it kills the program for me. Isn't there some steps to completely wipe the software?
Coyotebd is offline   Reply With Quote
Old 12-12-2009, 12:35 AM   #9
Coyotebd
Junior Member
Coyotebd began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Sep 2009
Device: Sony PR-600
The executable is different in this version. If you turned DEP on for any reason (like following Sony's directions to enable DEP so you can tell Windows that the software shouldn't fall under DEP, even though you already have DEP off for everything) you may want to follow the steps again.
Coyotebd is offline   Reply With Quote
Old 12-12-2009, 12:36 AM   #10
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 38,507
Karma: 19637653
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2), Sony PRS-650, Sony PRS-T1, nook STR, iPad 1, iPhone 5
Reader Library wrks for me under XP and Win 7. 3.0.x worked for me under XP and Vista and Win 7. I no longer have Vista so cannot test 3.1. So if it works for me, then there is something screwy witht eh setting for the computers where it doesn't work.
JSWolf is online now   Reply With Quote
Old 12-12-2009, 07:10 AM   #11
kfarmer
Gizzzzmo Nerd
kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.kfarmer ought to be getting tired of karma fortunes by now.
 
Posts: 116
Karma: 1035585
Join Date: Dec 2007
Location: Mill Creek, WA
Device: PRS-505
Quote:
Originally Posted by JSWolf View Post
Reader Library wrks for me under XP and Win 7. 3.0.x worked for me under XP and Vista and Win 7. I no longer have Vista so cannot test 3.1. So if it works for me, then there is something screwy witht eh setting for the computers where it doesn't work.
Are you using x86 or x64 OS?

It's failing on my (x64) system as well. My system is not screwy, thank you.

The process starts. The process hangs, consistently. No messages are written to the event log. DEP doesn't affect this.

On the off-chance it was failing to locate a digital editions DLL (since I didn't have *that* installed), I installed DE. Still no go.

On the more likely off-chance it was failing to distinguish the x86 vs x64 program files settings, I copied to both. Still didn't work.

I wiped the reader's appdata folder after uninstalling. I removed all traces I could locate, and reinstalled. Still no change in behavior.
kfarmer is offline   Reply With Quote
Old 12-12-2009, 11:06 AM   #12
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 38,507
Karma: 19637653
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2), Sony PRS-650, Sony PRS-T1, nook STR, iPad 1, iPhone 5
Quote:
Originally Posted by kfarmer View Post
Are you using x86 or x64 OS?

It's failing on my (x64) system as well. My system is not screwy, thank you.

The process starts. The process hangs, consistently. No messages are written to the event log. DEP doesn't affect this.

On the off-chance it was failing to locate a digital editions DLL (since I didn't have *that* installed), I installed DE. Still no go.

On the more likely off-chance it was failing to distinguish the x86 vs x64 program files settings, I copied to both. Still didn't work.

I wiped the reader's appdata folder after uninstalling. I removed all traces I could locate, and reinstalled. Still no change in behavior.
The Win 7 is Home Premium X86. We have no firewalls running. The Defender thingy is turned off. Comodo is installed with the firewall off. UAC is set to default. Never had to touch DEP.

What exactly do you have running when the machine starts? You could run msconfig and try to turn EVERYTHING off on a start and that includes any services that your startup software runs.
JSWolf is online now   Reply With Quote
Old 12-12-2009, 12:11 PM   #13
dmyrick
Junior Member
dmyrick began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Nov 2009
Device: sony prs-505
Just chatted with Sony support since I lost the store software when downloading the update. My vista system hangs giving error code 1935 and the tech said to wait until tonight or in the morning to download the update when the rollout is complete. The system is still updating....so I will wait. Also said to delete all older version of the bookstore.

Now the real question, why make somthing available when it is not completely ready? Way to go SONY!
dmyrick is offline   Reply With Quote
Old 12-12-2009, 01:35 PM   #14
pilotbob
Grand Sorcerer
pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.
 
pilotbob's Avatar
 
Posts: 19,634
Karma: 11390499
Join Date: Jan 2007
Location: Tampa, FL USA
Device: Kindle Touch
Quote:
Originally Posted by kfarmer View Post
I wiped the reader's appdata folder after uninstalling. I removed all traces I could locate, and reinstalled. Still no change in behavior.
Did you delete the kinoma folder?

BOb
pilotbob is offline   Reply With Quote
Old 12-12-2009, 02:12 PM   #15
Mrgauth
Addict
Mrgauth has a complete set of Star Wars action figures.Mrgauth has a complete set of Star Wars action figures.Mrgauth has a complete set of Star Wars action figures.Mrgauth has a complete set of Star Wars action figures.
 
Posts: 206
Karma: 310
Join Date: Mar 2009
Location: Tulsa OK
Device: K3
Quite simply, yes.
Mrgauth is offline   Reply With Quote
Reply

Tags
bad, experience, software, sony

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I love my Sony Reader, but I hate Sony (software question)... Ler0y Jenkins Sony Reader 1 09-17-2010 12:09 PM
Reader not showing up on Sony Software GatorDeb Sony Reader 4 12-20-2009 04:19 PM
PRS-500 eBook Library Software, not as bad as I expected stevejay Sony Reader Dev Corner 10 06-26-2009 02:02 AM
Is the Sony Library Software really this Bad? drmathprog Sony Reader 20 11-26-2008 11:41 AM
One week with the Sony reader...the good, the bad and the ugly! CanadianContent Sony Reader 13 11-14-2008 12:15 AM


All times are GMT -4. The time now is 03:38 PM.


MobileRead.com is a privately owned, operated and funded community.