Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > More E-Book Readers > iRex > iRex Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 06-21-2008, 02:12 PM   #61
bobj
Enthusiast
bobj is on a distinguished road
 
Posts: 25
Karma: 67
Join Date: May 2008
Device: iRex iLiad
How to fix DNS

For me, the problem was not with wget. The problem was with DNS resolution. (I could wget from IP addresses, but not domain names.)

There are separate DNS configurations for both inside and outside of scratchbox.

I fixed DNS inside scratchbox by doing the following: First, make sure you're not in scratchbox. (The prompt should be "developer@debian:~$" not "[sbox-iliad-dev: ~]".)

Then
Code:
developer@debian:~$ sudo nano /scratchbox/etc/resolv.conf
Erase the stuff that's there, and replace it with
Code:
nameserver IP.ADDRESS.OF.YOUR.DNS
For some configurations, "nameserver 192.168.0.1" will work properly.

If you need to figure out your DNS IP in Windows, open up a command prompt and type "ipconfig /all". Then look for a line like:
Code:
     DNS Servers . . . . . . . . . . . : 192.168.0.1
Now to fix DNS outside of scratchbox, do "sudo nano /etc/resolv.conf". (I personally got lucky on this part because it's set by default to 192.168.0.1.)
bobj is offline   Reply With Quote
Old 06-23-2008, 07:23 PM   #62
bobj
Enthusiast
bobj is on a distinguished road
 
Posts: 25
Karma: 67
Join Date: May 2008
Device: iRex iLiad
So when I run certain programs in the iliad-dev scratchbox, I get mysterious (to me) errors like:

Code:
rpm: relocation error: /lib/libpthread.so.0: symbol __libc_stack_end, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference

/iliad/bin/ping: /lib/libc.so.6: version `GLIBC_2.3.4' not found (required by /iliad/bin/ping)

./conftest: relocation error: /lib/libpthread.so.0: symbol __libc_stack_end, version GLIBC_PRIVATE not define
d in file ld-linux.so.2 with link time reference

/usr/local/bin/glib-genmarshal: relocation error: /lib/libpthread.so.0: symbol __libc_stack_end, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference

/lib/libpthread.so.0: undefined reference to `__libc_fork@GLIBC_2.1.2'
/lib/libpthread.so.0: undefined reference to `__libc_stack_end@GLIBC_PRIVATE'
I'd greatly appreciate any explanation about what those errors are about. I'm guessing they have something to do with the different levels at work in scratchbox, which I haven't completely wrapped my mind around.

Update: After wasting away many hours, I finally figured out what was going wrong. There's something wrong with the pthread library in /lib/. There's a better one elsewhere, so I fixed it with:
Code:
export LD_LIBRARY_PATH=/scratchbox/compilers/arm-linux-iliad-softfloat/gcc-3.4.2-glibc-2.3.3/arm-softfloat-linux-gnu/arm-softfloat-linux-gnu/lib:$LD_LIBRARY_PATH

Last edited by bobj; 06-28-2008 at 12:52 AM. Reason: Nobody else answered my question
bobj is offline   Reply With Quote
Old 07-18-2008, 06:31 AM   #63
Antartica
Evangelist
Antartica has learned how to read e-booksAntartica has learned how to read e-booksAntartica has learned how to read e-booksAntartica has learned how to read e-booksAntartica has learned how to read e-booksAntartica has learned how to read e-booksAntartica has learned how to read e-books
 
Posts: 415
Karma: 754
Join Date: Jun 2006
Location: Madrid, Spain
Device: iliad, onhandpc, newton, zaurus
Just updated dependencies_helper with fixed dl-and-install.sh

Hi all!

I was going to compile something for the iliad and noticed that dl-and-install.sh didn't work anymore. I've updated the script so that it works again and uploaded the new version to:

http://projects.mobileread.com/iliad...80718-1.tar.gz

YFYI .
Antartica is offline   Reply With Quote
Old 09-11-2008, 01:48 PM   #64
Tomek
Enthusiast
Tomek began at the beginning.
 
Posts: 29
Karma: 10
Join Date: Sep 2008
Location: USA
Device: Kindle DX
First of all, Adam, thanks for the VMWare image!

I haven't received my iLiad yet but I can't wait to do some development for it. I downloaded the image and successfully built startdict (although I did have to build libpcre first in case anyone else has problems with it)

I'm running into problems however when trying to start the matchbox-window-manager. Has anyone experienced the following errors:

developer@debian:~$ scratchbox

Welcome to Scratchbox, the cross-compilation toolkit!

Use 'sb-menu' to change your compilation target.
See /scratchbox/doc/ for documentation.

[sbox-iliad-irex: ~] > cd /
[sbox-iliad-irex: /] > DISPLAY=192.168.74.7:1
[sbox-iliad-irex: /] > export DISPLAY
[sbox-iliad-irex: /] > /iliad.sh usr/bin/matchbox-window-manager -use_titlebar no -use_cursor no &
[1] 24638
[sbox-iliad-irex: /] > Unsupported setsockopt level=1 optname=9

(process:24641): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (1000)

[sbox-iliad-irex: /] >
Tomek is offline   Reply With Quote
Old 09-11-2008, 02:25 PM   #65
Tomek
Enthusiast
Tomek began at the beginning.
 
Posts: 29
Karma: 10
Join Date: Sep 2008
Location: USA
Device: Kindle DX
Nevermind, I solved both of my problems.

The "Unsupported setsockopt level=1 optname=9" seems to be only a warning and the process still starts and appears to work.

My other problem was I pulled down by mistake stardict-tools package instead of startdict itself, which is probably why I needed to build libpcre.

In any case, I successfully build, executed, and used stardict in the VMWare image which is a great start.

Thanks!
Tomek is offline   Reply With Quote
Old 10-25-2008, 10:03 PM   #66
Iņigo
Guru
Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.
 
Posts: 712
Karma: 72743
Join Date: Feb 2008
Location: Here or there
Device: iRex iLiad, in love with iRex DR800S. Also a K4NT. Now a Kobo Aura
how to create iliad-irex target?

Hi,

I'm following antartica's http://wiki.mobileread.com/wiki/Ilia...cial_toolchain to create my iliad development environment.
Everything works ok, except the last part "testing applications using VNC".

There, when I execute:
Code:
sbox$ /iliad/iliad.sh usr/bin/matchbox-window-manager -use_titlebar no -use_cursor no
it fails with an error about it can't find matchbox theme.

I presume this is because I only have the target "iliad", and that command expects to be executed as another target ("iliad-irex"), whose root is the directory where "iliad.sh" is located.

Reading http://www.mobileread.com/forums/sho...8&postcount=35 confirms it.

So the question is: how to create this iliad-irex target pointing to iliad filesystem?

Thanks, Iņigo
Iņigo is offline   Reply With Quote
Old 10-26-2008, 01:09 AM   #67
ericshliao
Guru
ericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enough
 
Posts: 974
Karma: 687
Join Date: Nov 2007
Device: Dell X51v; iLiad v2
Quote:
Originally Posted by Iņigo View Post
So the question is: how to create this iliad-irex target pointing to iliad filesystem?

Thanks, Iņigo
I think that you can create a iliad-irex target just as you created the previous target. The only difference is their target names.
ericshliao is offline   Reply With Quote
Old 10-26-2008, 07:02 AM   #68
Iņigo
Guru
Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.
 
Posts: 712
Karma: 72743
Join Date: Feb 2008
Location: Here or there
Device: iRex iLiad, in love with iRex DR800S. Also a K4NT. Now a Kobo Aura
Quote:
Originally Posted by ericshliao View Post
I think that you can create a iliad-irex target just as you created the previous target. The only difference is their target names.
but how can i associate the new target with the new root directory?

target 'iliad' has / as root and I uncompressed file system package in /iliad.
So the hierhachy is something like
Code:
/
/bin
...
/iliad/bin
/iliad/...
/iliad/usr
...
/usr
...
The second target 'iliad-irex' expects /iliad to be its / and that's the reason the error messages I get. This is the problem I don't know how to solve.

Thanks, Iņigo
Iņigo is offline   Reply With Quote
Old 10-27-2008, 11:40 AM   #69
ericshliao
Guru
ericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enoughericshliao will become famous soon enough
 
Posts: 974
Karma: 687
Join Date: Nov 2007
Device: Dell X51v; iLiad v2
Quote:
Originally Posted by Iņigo View Post
The second target 'iliad-irex' expects /iliad to be its / and that's the reason the error messages I get. This is the problem I don't know how to solve.

Thanks, Iņigo
Every target in ScratchBox has its own fake (simulated) root directory. You may be wrong thinking that "The second target 'iliad-irex' expects /iliad to be its /".
ericshliao is offline   Reply With Quote
Old 02-25-2009, 12:10 PM   #70
DesiLinguist
Computational Linguist
DesiLinguist doesn't litterDesiLinguist doesn't litter
 
Posts: 110
Karma: 100
Join Date: Feb 2009
Device: iLiad BE, iPhone, Kindle DX
fontconfig issues when compiling ipdf

OK, so I took Eric's suggestion for setting up the toolchain myself and everything (starting up the virtual machine, setting the target to 'iliad-dev' etc.) went absolutely fine until I tried compiling ipdf. During the 'configure' pass, I get the following error:

Code:
checking for fontconfig >= 2.2... Package fontconfig was not found in the pkg-config search path.
Perhaps you should add the directory containing `fontconfig.pc'
to the PKG_CONFIG_PATH environment variable
However, I looked in /usr/local/lib/pkgconfig (which is the default value of PKG_CONFIG_PATH) and there *is* a fontconfig.pc there. What's more surprising is that pkg-config *does* seem aware of fontconfig. If I manually run all the tests that 'configure' seems to be running:

Code:
$> pkg-config --exists "fontconfig >= 2.2"
$> echo $?
0
$> pkg-config --libs "fontconfig >= 2.2"
-L/usr/local/lib -lfontconfig
$> pkg-config --cflags "fontconfig >= 2.2"
-I/usr/local/include
you can see that everything checks out fine. So, I would really appreciate any help or advice here since I am stumped and don't know what to do.

Last edited by DesiLinguist; 02-25-2009 at 12:15 PM.
DesiLinguist is offline   Reply With Quote
Old 02-25-2009, 01:30 PM   #71
DesiLinguist
Computational Linguist
DesiLinguist doesn't litterDesiLinguist doesn't litter
 
Posts: 110
Karma: 100
Join Date: Feb 2009
Device: iLiad BE, iPhone, Kindle DX
OK, I figured out a solution to the fontconfig problem. 'autogen.sh' in jharker's source code was setting PKG_CONFIG_PATH to be something that wasn't correct for the VMWare image. Then I ran into an issue of it not being able to find liberscribble. I found that on iRex's developer website and put that in the proper place. Then 'configure' finished properly. However, when I run make, I now get the following error:

Code:
main.cc: In member function `virtual void* StandardSecurityHandler::getAuthData()':
main.cc:130: error: `StandardAuthData' has not been declared
So I looked around iRex's web repository of their released source code and found that the latest version of 'SecurityHandler.h' under 'poppler/include' defines 'StandardAuthData' but the 'SecurityHandler.h' in the VMWare image does not. I guess this means that the poppler library is also out of date.

So, does that mean the VMWare image is out of date and there is no solution other than installing the iRex sources from scratch on a pure debian installation?

Any help/advice/suggestions will be greatly appreciated!

Last edited by DesiLinguist; 02-25-2009 at 03:09 PM.
DesiLinguist is offline   Reply With Quote
Old 02-25-2009, 03:43 PM   #72
DesiLinguist
Computational Linguist
DesiLinguist doesn't litterDesiLinguist doesn't litter
 
Posts: 110
Karma: 100
Join Date: Feb 2009
Device: iLiad BE, iPhone, Kindle DX
OK, I just realized that if I cannot compile my own binary, at least I can strip the binary produced by Fellball and release a new version of the all-in-one ipdf installer. Please see these two threads for details.

I have tested the new binary and it works perfectly fine!

Thanks to Fellball!
DesiLinguist is offline   Reply With Quote
Old 08-18-2009, 04:27 PM   #73
marcins
Member
marcins has a complete set of Star Wars action figures.marcins has a complete set of Star Wars action figures.marcins has a complete set of Star Wars action figures.marcins has a complete set of Star Wars action figures.marcins has a complete set of Star Wars action figures.
 
marcins's Avatar
 
Posts: 17
Karma: 444
Join Date: Jul 2009
Device: iRex DR1000S, Sony PRS-650
Hi,
one simple question: is there possibility to run the iLiad emulation (I mean default user interface and so on) with this image and vmware player?
marcins is offline   Reply With Quote
Old 11-15-2009, 09:47 AM   #74
w.m.vanvliet
Computer science student
w.m.vanvliet began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Jul 2008
Location: Enschede, the Netherlands
Device: Iliad
Version of GTK/GLIB/Pango/Atk

I want to give a heads up to users of the VMWare image. The library versions of gtk+, glib, pango and possibly atk are different in the dev and irex environment. This will cause weird errors when compiling in the dev environment works, but running it in the irex environment breaks, for instance on calls g_intern_static_string().

One of the main difference is that gtk 2.8 uses the Cairo backend for drawing, whereas the version on the iliad does not.

I fixed this by manually downgrading the libs in the development environment to match the iliad versions, which are:

GTK+2.0 --> 2.6.7
GLIB2.0 --> 2.6.6
Pango --> 1.8.2

I didn't downgrade the ATK lib, since it was not needed for my project, but my guess is that it is also newer in the dev environment.
w.m.vanvliet is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
iRex DR1000 Development VMWare Image Adam B. iRex 9 08-19-2010 04:23 AM
DR800 Developement VMWare Image? CoolDragon iRex 8 04-04-2010 05:30 AM
calibre VMWare development environment kovidgoyal Calibre 30 12-30-2009 12:43 PM
iLiad iRex iLiad development enviroment on VMware image Alexander Turcic iRex Developer's Corner 0 03-31-2007 02:02 PM


All times are GMT -4. The time now is 04:52 AM.


MobileRead.com is a privately owned, operated and funded community.