Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 11-28-2008, 07:05 AM   #1
carpii
Enthusiast
carpii began at the beginning.
 
Posts: 38
Karma: 16
Join Date: Nov 2008
Device: Iliad or Sony
calibre python-lxml problem on ubuntu

Hi,
Ive tried to install calibre using the easy install option....

PHP Code:
sudo apt-get install  python-setuptools python-imaging  libqt4-core libqt4-gui \
 
python-qt4 python-mechanize imagemagick \
 
xdg-utils python-dbus python-lxml python-beautifulsoup \
 
help2man
sudo easy_install 
-U calibre 
When i run
PHP Code:
sudo calibre_postinstall 
I get
PHP Code:
Trying to setup udev rules...
 * 
Restarting Hardware abstraction layer hald                                                               OK ]
Setting up bash completion... You need python-lxml >= 2.0.5 for calibre 

When I check what version of python-lxml was downloaded in step one, it says

PHP Code:
Get4 http://gb.archive.ubuntu.com hardy/main python-lxml 1.3.6-1 [619kB] 
Whats the best way to resolve this? It looks like calibre has since been updated to require a newer version that what is in Ubuntu's repositories

Thanks
carpii is offline   Reply With Quote
Old 11-28-2008, 07:05 AM   #2
carpii
Enthusiast
carpii began at the beginning.
 
Posts: 38
Karma: 16
Join Date: Nov 2008
Device: Iliad or Sony
Forgot to say, trying to run calibre anyway obviously fails...

PHP Code:
calibre
Traceback 
(most recent call last):
  
File "/usr/bin/calibre"line 8in <module>
    
load_entry_point('calibre==0.4.108''gui_scripts''calibre')()
  
File "/usr/lib/python2.5/site-packages/pkg_resources.py"line 277in load_entry_point
    
return get_distribution(dist).load_entry_point(groupname)
  
File "/usr/lib/python2.5/site-packages/pkg_resources.py"line 2179in load_entry_point
    
return ep.load()
  
File "/usr/lib/python2.5/site-packages/pkg_resources.py"line 1912in load
    entry 
__import__(self.module_nameglobals(),globals(), ['__name__'])
  
File "build/bdist.linux-i686/egg/calibre/gui2/main.py"line 15in <module>
  
File "build/bdist.linux-i686/egg/calibre/ebooks/metadata/meta.py"line 12in <module>
  
File "build/bdist.linux-i686/egg/calibre/ebooks/metadata/lit.py"line 12in <module>
  
File "build/bdist.linux-i686/egg/calibre/ebooks/lit/reader.py"line 384in <module>
  
File "build/bdist.linux-i686/egg/calibre/ebooks/lit/reader.py"line 387in LitReader
TypeError
'resolve_entities' is an invalid keyword argument for this function 
carpii is offline   Reply With Quote
Old 11-28-2008, 02:18 PM   #3
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,376
Karma: 4961459
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
You'll have to install python-lxml from source
kovidgoyal is offline   Reply With Quote
Old 11-28-2008, 09:20 PM   #4
carpii
Enthusiast
carpii began at the beginning.
 
Posts: 38
Karma: 16
Join Date: Nov 2008
Device: Iliad or Sony
Thanks, I managed to build and install python-lxml 2.6.27

But calibre still fails. I reran 'sudo calibre_postinstall'...

PHP Code:
sudo calibre_postinstall
Trying to setup udev rules
...
 * 
Restarting Hardware abstraction layer hald                                                                                                                             OK ]
Setting up bash completion... failed
Traceback 
(most recent call last):
  
File "build/bdist.linux-i686/egg/calibre/linux.py"line 172in setup_completion
  File 
"build/bdist.linux-i686/egg/calibre/gui2/lrf_renderer/main.py"line 18in <module>
  
File "build/bdist.linux-i686/egg/calibre/gui2/library.py"line 17in <module>
  
File "build/bdist.linux-i686/egg/calibre/library/database2.py"line 19in <module>
  
File "build/bdist.linux-i686/egg/calibre/library/database.py"line 11in <module>
  
File "build/bdist.linux-i686/egg/calibre/ebooks/metadata/meta.py"line 12in <module>
  
File "build/bdist.linux-i686/egg/calibre/ebooks/metadata/lit.py"line 12in <module>
  
File "build/bdist.linux-i686/egg/calibre/ebooks/lit/reader.py"line 13in <module>
ImportErrorNo module named lxml
Traceback 
(most recent call last):
  
File "/usr/bin/calibre_postinstall"line 8in <module>
    
load_entry_point('calibre==0.4.108''console_scripts''calibre_postinstall')()
  
File "build/bdist.linux-i686/egg/calibre/linux.py"line 446in post_install
  File 
"build/bdist.linux-i686/egg/calibre/linux.py"line 318in setup_completion
UnboundLocalError
local variable 'manifest' referenced before assignment 
Its like lxml is installed, but maybe not registered with python (or maybe linux).

Do you have any ideas please?
carpii is offline   Reply With Quote
Old 11-28-2008, 10:01 PM   #5
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,376
Karma: 4961459
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
how did you install lxml? Make sure you do


sudo python setup.py install


to install lxml
kovidgoyal is offline   Reply With Quote
Old 11-29-2008, 05:34 AM   #6
carpii
Enthusiast
carpii began at the beginning.
 
Posts: 38
Karma: 16
Join Date: Nov 2008
Device: Iliad or Sony
I fixed my lxml install, but then calibre was complaining about QtWebKit

In the end I noticed other people on Ubuntu were using the binary installer
I tried this and it worked without a hitch

Thanks for your help!
carpii is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre 6.40 upgrade problem on Ubuntu 9.04 splashd Calibre 2 02-18-2010 08:20 PM
Problem Installing Calibre on EeePC 901 (Ubuntu Jaunty) andavane Calibre 4 11-08-2009 02:05 PM
Problem with Calibre and Ubuntu azurita Calibre 2 05-03-2009 08:22 PM
Ubuntu Hardy Calibre Problem vakya Calibre 27 01-26-2009 04:15 PM
upgrade failed - but not python-lxml fault alexxxm Calibre 7 10-06-2008 09:36 AM


All times are GMT -4. The time now is 07:06 AM.


MobileRead.com is a privately owned, operated and funded community.