Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Formats > Workshop

Notices

Reply
 
Thread Tools Search this Thread
Old 11-19-2008, 01:50 PM   #31
tompe
Grand Sorcerer
tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.
 
Posts: 6,966
Karma: 3454321
Join Date: Oct 2007
Location: Link÷png, Sweden
Device: Nexus 7, Nexus 4, iPad 2, Notion Ink Adam Qi, Kindle WiFi, Kindle PW
Quote:
Originally Posted by AZed View Post
Hm. The main new feature from 5.10 that I'm using is the smart-match operator, which is a lot faster than the alternatives (some of which are incredibly messy). Perl 5.10 was released almost a year ago, and I hadn't figured people would still be seriously having problems obtaining it. (You're running Debian Stable on a desktop machine? Why? I'm a Debian developer and even I will cheerfully admit that Stable is generally already obsolete almost by the time it's released.)
This was my work machine and we have standardized on Debian stable. And I want to avoid having to install an extra Perl installation but of course it is easy to install 5.10 if you need it. My unstable laptop at home had 5.10 (but was that no a recent change?). I have to read about the smart operators to see if I want to use them myself. I have been bad at keeping up with new versions of Perl.
tompe is offline   Reply With Quote
Old 11-19-2008, 02:07 PM   #32
tompe
Grand Sorcerer
tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.
 
Posts: 6,966
Karma: 3454321
Join Date: Oct 2007
Location: Link÷png, Sweden
Device: Nexus 7, Nexus 4, iPad 2, Notion Ink Adam Qi, Kindle WiFi, Kindle PW
Quote:
Originally Posted by nrapallo View Post
I'm also stuck using ActivePerl 5.8.8 (build 820) for my Mobi2IMP package since it was originally based on tompe's html2mobi.pl. I don't want to lose/break anything if I get Perl 5.10.

Now, if tompe migrates to 5.10, so would I.
I am really not so interested in finding out how to compile to a Windows binary using 5.10. But some of the new syntactical things in 5.10 were really nice...

A Windows binary for MobiPerlhave been very good for getting people to use it but the disdvantage is that I will get more problem trying to change to Perl 5.10.
tompe is offline   Reply With Quote
 
Enthusiast
Old 11-19-2008, 02:13 PM   #33
AZed
Connoisseur
AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.
 
Posts: 57
Karma: 307
Join Date: Oct 2008
Device: PalmOS PDA
Quote:
Originally Posted by tompe View Post
This was my work machine and we have standardized on Debian stable. And I want to avoid having to install an extra Perl installation but of course it is easy to install 5.10 if you need it. My unstable laptop at home had 5.10 (but was that no a recent change?). I have to read about the smart operators to see if I want to use them myself. I have been bad at keeping up with new versions of Perl.
If there's not a really great need for me to make everything compatible with Perl 5.8, I'd really rather not (and I can't go back any earlier than that at all because proper Unicode support didn't show up until 5.8). If you and nrapallo decide that you really want to stick with 5.8, however (or if I start getting feedback that 5.10 is a major nuisance to get installed for people that want to use this), I do know what I'd technically need to do to yank the 5.10-specific code.

You might also find the following guides to the new 5.10 features informative:

Smart-Match
Defined-Or
5.10 Regular Expressions
Given/When (Switch)
All 5.10 changes

The big things to me were the smart-match, named regular expression, and speed improvements.
AZed is offline   Reply With Quote
Old 11-19-2008, 02:18 PM   #34
AZed
Connoisseur
AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.
 
Posts: 57
Karma: 307
Join Date: Oct 2008
Device: PalmOS PDA
Quote:
Originally Posted by tompe View Post
I am really not so interested in finding out how to compile to a Windows binary using 5.10. But some of the new syntactical things in 5.10 were really nice...

A Windows binary for MobiPerlhave been very good for getting people to use it but the disdvantage is that I will get more problem trying to change to Perl 5.10.
Well, the ActiveState dev kit shouldn't have any more problem compiling 5.10 perl to exes than 5.8, but the major problem with the ActiveState 5.10 distribution is that its support for CPAN is basically broken (they've got some kind of critical bug with their YAML parser that breaks it), so you're limited to PPM-installs.

I've been meaning to test Strawberry Perl to see if that's a better general solution.
AZed is offline   Reply With Quote
Old 11-19-2008, 02:24 PM   #35
kennedyzor
Banned
kennedyzor began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Nov 2008
Device: none
Hi tompe

Could tell about TIVO clauses ? I would gladly hear some opinions & even better if a little explanation comes with the name.
Thank you.
kennedyzor is offline   Reply With Quote
Old 11-19-2008, 02:29 PM   #36
pilotbob
Grand Sorcerer
pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.
 
pilotbob's Avatar
 
Posts: 19,469
Karma: 11248282
Join Date: Jan 2007
Location: Tampa, FL USA
Device: Kindle Touch
Quote:
Originally Posted by tompe View Post
A Windows binary for MobiPerlhave been very good for getting people to use it but the disdvantage is that I will get more problem trying to change to Perl 5.10.
I do know that Mac comes with 5.8 pre installed... so I have not had to install or upgrade it at all. I assume I could install 5.10 using macports or maybe go to ActivestatePerl instead.

BOb
pilotbob is offline   Reply With Quote
Old 11-19-2008, 02:41 PM   #37
AZed
Connoisseur
AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.
 
Posts: 57
Karma: 307
Join Date: Oct 2008
Device: PalmOS PDA
Quote:
Originally Posted by pilotbob View Post
I do know that Mac comes with 5.8 pre installed... so I have not had to install or upgrade it at all. I assume I could install 5.10 using macports or maybe go to ActivestatePerl instead.
What a mess. Okay, I'll yank the 5.10 code in the next release.

Could you please run 'perl -v' for me on your Mac and let me know exactly what version is installed? Early versions of 5.8 had some really ugly bugs that I'd rather not have to think about, IIRC, so I'm tempted to force at least 5.8.8, but I need to know if the MacOSX Perl can be counted on to be at least that high.
AZed is offline   Reply With Quote
Old 11-19-2008, 03:00 PM   #38
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,285
Karma: 4961457
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Quote:
Originally Posted by AZed View Post
What a mess. Okay, I'll yank the 5.10 code in the next release.

Could you please run 'perl -v' for me on your Mac and let me know exactly what version is installed? Early versions of 5.8 had some really ugly bugs that I'd rather not have to think about, IIRC, so I'm tempted to force at least 5.8.8, but I need to know if the MacOSX Perl can be counted on to be at least that high.
OS X Tiger has perl 5.8.6. OSX's support for open source libraries is in general very poor, they tend to be outdated and buggy, which is why I decided to bundle custom compiled versions with calibre.
kovidgoyal is offline   Reply With Quote
Old 11-19-2008, 03:01 PM   #39
pilotbob
Grand Sorcerer
pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.
 
pilotbob's Avatar
 
Posts: 19,469
Karma: 11248282
Join Date: Jan 2007
Location: Tampa, FL USA
Device: Kindle Touch
Quote:
Originally Posted by AZed View Post
What a mess. Okay, I'll yank the 5.10 code in the next release.

Could you please run 'perl -v' for me on your Mac and let me know exactly what version is installed? Early versions of 5.8 had some really ugly bugs that I'd rather not have to think about, IIRC, so I'm tempted to force at least 5.8.8, but I need to know if the MacOSX Perl can be counted on to be at least that high.
I think it is 5.8.6 on Tiger and 5.8.8 on Leopard. But, I would have to double check when I get home to my Mac. Also, if someone here has Tiger they can verify what version it has. Tiger released with 5.8.6 but subsequent updates could have brought it to 5.8.8.

Like I said... it is possible to upgrade it... but then I would have to modify my whole installing mobiperl tutorial. don't let me hold you back. I know how frustrating it is as a dev not being able to keep up to date with various tools.

BOb
pilotbob is offline   Reply With Quote
Old 11-19-2008, 03:13 PM   #40
AZed
Connoisseur
AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.
 
Posts: 57
Karma: 307
Join Date: Oct 2008
Device: PalmOS PDA
Ugh, again. Releasing an entire distribution of Perl along with the module is not an option for me. I was able to confirm that Leopard is 5.8.8, though. I'm going to make that the minimum requirement, because 5.8.6 had a known bug dealing with using substr on unicode strings

I reserve the right to reclaim 5.10 features once 5.10 is standard both on Debian Stable and MacOSX, however.
AZed is offline   Reply With Quote
Old 11-19-2008, 03:26 PM   #41
nrapallo
GuteBook/Mobi2IMP Creator
nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.
 
nrapallo's Avatar
 
Posts: 2,958
Karma: 2530531
Join Date: Dec 2007
Location: Toronto, Canada
Device: REB1200 EBW1150 Device: T1 NSTG iLiad_v2 NC Device: Asus_TF Next1 WPDN
Quote:
Originally Posted by AZed View Post
I reserve the right to reclaim 5.10 features once 5.10 is standard both on Debian Stable and MacOSX, however.
Sounds like a very good solution for all!

Thanks for your cross-platform support and understanding!

Now to get started on IMP.pm...
nrapallo is offline   Reply With Quote
Old 11-19-2008, 03:44 PM   #42
AZed
Connoisseur
AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.AZed has a complete set of Star Wars action figures.
 
Posts: 57
Karma: 307
Join Date: Oct 2008
Device: PalmOS PDA
Quote:
Originally Posted by nrapallo View Post
Sounds like a very good solution for all!

Thanks for your cross-platform support and understanding!

Now to get started on IMP.pm...
0.3.2 has been uploaded, and should show up on CPAN whenever the CPAN indexer gets around to putting it there. Be aware that I don't actually have any dev boxes with 5.8.8 installed, so I can't test it directly, but in theory this should work on 5.8.8 or above now. It should also build now even if Module::Build isn't available. That may eventually go away again, but I won't change it until I actually implement something using the new Module::Build features.

Like I said, IMP.pm is going to take me a while, and I make no promises, but I am looking at it.
AZed is offline   Reply With Quote
Old 11-19-2008, 03:55 PM   #43
nrapallo
GuteBook/Mobi2IMP Creator
nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.nrapallo ought to be getting tired of karma fortunes by now.
 
nrapallo's Avatar
 
Posts: 2,958
Karma: 2530531
Join Date: Dec 2007
Location: Toronto, Canada
Device: REB1200 EBW1150 Device: T1 NSTG iLiad_v2 NC Device: Asus_TF Next1 WPDN
Quote:
Originally Posted by AZed View Post
Like I said, IMP.pm is going to take me a while, and I make no promises, but I am looking at it.
No worry, I'm happy to contribute, explain, educate, ....
nrapallo is offline   Reply With Quote
Old 11-19-2008, 04:04 PM   #44
tompe
Grand Sorcerer
tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.
 
Posts: 6,966
Karma: 3454321
Join Date: Oct 2007
Location: Link÷png, Sweden
Device: Nexus 7, Nexus 4, iPad 2, Notion Ink Adam Qi, Kindle WiFi, Kindle PW
Quote:
Originally Posted by AZed View Post
Well, the ActiveState dev kit shouldn't have any more problem compiling 5.10 perl to exes than 5.8, but the major problem with the ActiveState 5.10 distribution is that its support for CPAN is basically broken (they've got some kind of critical bug with their YAML parser that breaks it), so you're limited to PPM-installs.
PPM-install probably is OK. The problem is the par support for building a Windows binary. I basically spent a day or so testing all possible permutations to get it to work on 5.8.8. But maybe it works better in 5.10.
tompe is offline   Reply With Quote
Old 11-19-2008, 04:08 PM   #45
tompe
Grand Sorcerer
tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.tompe ought to be getting tired of karma fortunes by now.
 
Posts: 6,966
Karma: 3454321
Join Date: Oct 2007
Location: Link÷png, Sweden
Device: Nexus 7, Nexus 4, iPad 2, Notion Ink Adam Qi, Kindle WiFi, Kindle PW
Quote:
Originally Posted by kennedyzor View Post
Hi tompe

Could tell about TIVO clauses ? I would gladly hear some opinions & even better if a little explanation comes with the name.
Thank you.
http://en.wikipedia.org/wiki/Tivoization
tompe is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
eBook Tools software available for download Icarusbop Workshop 11 02-26-2011 08:52 AM
Section for non major ebook tools Zorz Feedback 0 01-22-2010 02:09 AM
Useful tools for the iLiad LittleTalker iRex 24 05-15-2006 08:28 AM
Gmail tools ignatz Lounge 8 06-29-2004 11:48 AM


All times are GMT -4. The time now is 07:33 PM.


MobileRead.com is a privately owned, operated and funded community.