Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 10-19-2008, 08:33 AM   #1
sahlberg
Junior Member
sahlberg began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Oct 2008
Device: prs-505
Problem: after upgrade to 0.4.98 calibre crashes

Hi,

I followed the instructions on
http://calibre.kovidgoyal.net/download_ubuntu
and upgraded to 0.4.98.

After this calibre will not run anymore :

sahlberg@ronnie:~$ calibre
Traceback (most recent call last):
File "/usr/bin/calibre", line 8, in <module>
load_entry_point('calibre==0.4.98', 'gui_scripts', 'calibre')()
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 277, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2179, in load_entry_point
return ep.load()
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1912, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "build/bdist.linux-i686/egg/calibre/gui2/main.py", line 14, in <module>
File "build/bdist.linux-i686/egg/calibre/ebooks/metadata/meta.py", line 11, in <module>
File "build/bdist.linux-i686/egg/calibre/ebooks/metadata/lit.py", line 12, in <module>
File "build/bdist.linux-i686/egg/calibre/ebooks/lit/reader.py", line 384, in <module>
File "build/bdist.linux-i686/egg/calibre/ebooks/lit/reader.py", line 387, in LitReader
TypeError: 'resolve_entities' is an invalid keyword argument for this function


Please help.


ronnie sahlberg
sahlberg is offline   Reply With Quote
Old 10-19-2008, 01:12 PM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,312
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
you need python-lxml >= 2.0.5
kovidgoyal is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre 6.40 upgrade problem on Ubuntu 9.04 splashd Calibre 2 02-18-2010 09:20 PM
Calibre crashes Finder in OS X hyperact Calibre 9 04-15-2009 04:36 PM
Calibre 0.5.0 crashes on startup gilamon Calibre 28 03-20-2009 01:42 AM
Calibre 73 crashes, won't open in OS X Mitchll Calibre 2 06-22-2008 06:50 PM
My installation of calibre crashes dynabook Calibre 1 06-02-2008 06:04 PM


All times are GMT -4. The time now is 12:54 PM.


MobileRead.com is a privately owned, operated and funded community.