Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 10-02-2008, 07:02 AM   #1
alexxxm
Addict
alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.
 
Posts: 205
Karma: 356
Join Date: Aug 2007
Device: Rocket; Hiebook; N700; Sony 505; Kindle DX ...
upgrade failed - but not python-lxml fault

I saw similar problems in a previous post, but your suggestion that the fault comes from python-lxml < 2.0.5 suggests my problem is different: I'm on Fedora fc8, and I have python-lxml-2.0.7-1.fc8 installed.

During install:
Code:
...
Setting up bash completion... failed
Traceback (most recent call last):
  File "build/bdist.linux-i686/egg/calibre/linux.py", line 176, in setup_completion
  File "build/bdist.linux-i686/egg/calibre/ebooks/lrf/comic/convert_from.py", line 21, in <module>
  File "build/bdist.linux-i686/egg/calibre/ebooks/epub/__init__.py", line 13, in <module>
  File "build/bdist.linux-i686/egg/calibre/ebooks/html.py", line 16, in <module>
  File "/usr/lib/python2.5/site-packages/lxml/html/soupparser.py", line 7, in <module>
    from BeautifulSoup import \
ImportError: No module named BeautifulSoup
Traceback (most recent call last):
  File "/usr/bin/calibre_postinstall", line 8, in <module>
    load_entry_point('calibre==0.4.89', 'console_scripts', 'calibre_postinstall')()
  File "build/bdist.linux-i686/egg/calibre/linux.py", line 430, in post_install
  File "build/bdist.linux-i686/egg/calibre/linux.py", line 304, in setup_completion
UnboundLocalError: local variable 'manifest' referenced before assignment
and trying to run it:
Code:
[root@lambda2 mnt]# calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 8, in <module>
    load_entry_point('calibre==0.4.89', 'gui_scripts', 'calibre')()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 277, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2179, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1912, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "build/bdist.linux-i686/egg/calibre/gui2/main.py", line 37, in <module>
  File "build/bdist.linux-i686/egg/calibre/gui2/tools.py", line 14, in <module>
  File "build/bdist.linux-i686/egg/calibre/gui2/dialogs/epub.py", line 16, in <module>
  File "/usr/lib/python2.5/site-packages/PIL/__init__.py", line 13, in <module>
    
  File "build/bdist.linux-i686/egg/calibre/ebooks/html.py", line 16, in <module>
  File "/usr/lib/python2.5/site-packages/lxml/html/soupparser.py", line 7, in <module>
    from BeautifulSoup import \
ImportError: No module named BeautifulSoup
any idea about it?


alessandro
alexxxm is offline   Reply With Quote
Old 10-02-2008, 07:06 AM   #2
alexxxm
Addict
alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.
 
Posts: 205
Karma: 356
Join Date: Aug 2007
Device: Rocket; Hiebook; N700; Sony 505; Kindle DX ...
possibly related: during the 1st install part (yum install...): I never noticed it, maybe it always did it in the past, but this is what it says now:

Code:
[root@lambda2 mnt]# yum install  python-setuptools-devel python-imaging  qt4 PyQt4 python-mechanize \
>              ImageMagick xdg-utils dbus-python python-lxml python-beautifulsoup \
>              help2man
Setting up Install Process
Parsing package install arguments
Package python-imaging - 1.1.6-4.fc8.i386 is already installed.
Package python-mechanize - 0.1.6-0.2.b.fc8.noarch is already installed.
Package ImageMagick - 6.3.5.9-1.fc8.i386 is already installed.
Package xdg-utils - 1.0.2-2.fc8.noarch is already installed.
Package dbus-python - 0.82.0-2.fc8.i386 is already installed.
No package python-beautifulsoup available.
Package help2man - 1.36.4-1.fc6.noarch is already installed.
Nothing to do
alessandro
alexxxm is offline   Reply With Quote
Old 10-02-2008, 11:55 AM   #3
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,913
Karma: 5035037
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
sudo easy_install -U BeautifulSoup
kovidgoyal is offline   Reply With Quote
Old 10-03-2008, 04:57 AM   #4
alexxxm
Addict
alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.
 
Posts: 205
Karma: 356
Join Date: Aug 2007
Device: Rocket; Hiebook; N700; Sony 505; Kindle DX ...
that command worked, and after that "calibre_postinstall" worked too without errors.

But calibre dies at launch with:

Code:
Traceback (most recent call last):
  File "/usr/bin/calibre", line 8, in <module>
    load_entry_point('calibre==0.4.89', 'gui_scripts', 'calibre')()
  File "build/bdist.linux-i686/egg/calibre/gui2/main.py", line 1252, in main
  File "build/bdist.linux-i686/egg/calibre/gui2/main.py", line 74, in __init__
  File "build/bdist.linux-i686/egg/calibre/gui2/main_ui.py", line 135, in setupUi
AttributeError: setHeaderHidden
alessandro
alexxxm is offline   Reply With Quote
Old 10-03-2008, 11:06 AM   #5
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,913
Karma: 5035037
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
What version of qt and pyqt do you have?
kovidgoyal is offline   Reply With Quote
Old 10-03-2008, 11:34 AM   #6
alexxxm
Addict
alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.
 
Posts: 205
Karma: 356
Join Date: Aug 2007
Device: Rocket; Hiebook; N700; Sony 505; Kindle DX ...
qt-3.3.8b-2.fc8
qt4-4.3.5-1.fc8
qt4-x11-4.3.5-1.fc8
qt-devel-3.3.8b-2.fc8
PyQt-3.17.4-1.fc8
PyQt-devel-3.17.4-1.fc8
PyQt4-4.3.3-1.fc8

I know there is a requirement PyQt >= 4.4.2, but up to now I did not have any problems...

alessandro
alexxxm is offline   Reply With Quote
Old 10-03-2008, 11:37 AM   #7
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,913
Karma: 5035037
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
yeah well you do need qt 4.4.2
kovidgoyal is offline   Reply With Quote
Old 10-06-2008, 09:36 AM   #8
alexxxm
Addict
alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.alexxxm has a complete set of Star Wars action figures.
 
Posts: 205
Karma: 356
Join Date: Aug 2007
Device: Rocket; Hiebook; N700; Sony 505; Kindle DX ...
damn. Oh well, migrating to the binary version...

alessandro
alexxxm is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firmware Upgrade Failed! greenapple Ectaco jetBook 6 07-06-2010 03:30 AM
Segmentation Fault after Qt upgrade reader42 Calibre 8 03-21-2010 06:58 PM
Having some trouble with Calibre 0.4.109(python upgrade) ould Calibre 13 12-04-2008 03:28 PM
calibre python-lxml problem on ubuntu carpii Calibre 5 11-29-2008 05:34 AM
Upgrade to 0.4.84 failed BrendenM Calibre 14 10-24-2008 06:25 PM


All times are GMT -4. The time now is 10:11 PM.


MobileRead.com is a privately owned, operated and funded community.