Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil

Notices

Reply
 
Thread Tools Search this Thread
Old 05-04-2013, 10:48 PM   #16
yekim54
What the Dog Saw
yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.
 
yekim54's Avatar
 
Posts: 305
Karma: 981684
Join Date: Jul 2008
Location: Dunn Loring
Device: Sony PRS-505, PRS-650, Asus TF101
Quote:
Originally Posted by theducks View Post
Another known NO GO is old AMD processors that don't have SSE2
Ah, apparently that's the ticket. The one old PC that runs Sigil 0.7.2 has an AMD processor with SSE2. The two PCs that don't run 0.7.2 have AMD processors with SSE (not SSE2). But they all run Sigil 0.6.2 just fine.
yekim54 is offline   Reply With Quote
Old 05-05-2013, 01:13 AM   #17
AnotherCat
Evangelist
AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.
 
Posts: 424
Karma: 1202401
Join Date: May 2012
Device: Sony PRS-T1
I am not familiar with the innards of Sigil at all, so the following is made with no sense of authority whatsoever , but maybe a -sse2 switch was incorrectly (or correctly depending on ones point of view ) set somewhere during the build of 0.6.2 for 32bit MSWindows (64 bit CPU's all support SSE2)?
AnotherCat is offline   Reply With Quote
Old 05-05-2013, 04:11 AM   #18
Toxaris
Wizard
Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.Toxaris ought to be getting tired of karma fortunes by now.
 
Toxaris's Avatar
 
Posts: 3,101
Karma: 5861069
Join Date: Oct 2009
Location: Heemskerk, NL
Device: PRS-300, PRS-T1
I believe the issue is not the compiling of Sigil, but actually Qt5.
Toxaris is offline   Reply With Quote
Old 05-05-2013, 09:24 AM   #19
Gian Carlo M.
Junior Member
Gian Carlo M. began at the beginning.
 
Posts: 8
Karma: 10
Join Date: May 2013
Device: none
Quote:
Originally Posted by DiapDealer View Post
But the Xerces component of Sigil also requires SSE2--has for a long time. The OP indicated he was able to run Sigil 0.6.x on that same hardware--which should be impossible unless he was running a patched, custom build of Sigil (unless Sigil's Xerces component is configured in the Windows build without the SSE2 requirements that the Linux config has).
The version of Sigil 0.6.2 I've been used is not patched and this is what I see on Help->Info:
Version: 0.6.2
Qt: 4.8.4
Gian Carlo M. is offline   Reply With Quote
Old 05-05-2013, 10:30 AM   #20
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,424
Karma: 43260000
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by Gian Carlo M. View Post
The version of Sigil 0.6.2 I've been used is not patched and this is what I see on Help->Info:
Version: 0.6.2
Qt: 4.8.4
Yes. There's two separate issues here. And I was admittedly confused on some of the Windows aspects of it.

1) The Xerces component of Sigil. The Windows binaries of Sigil 0.6.x (and earlier) appear to have been built/configured without the hardcoded Xerces SSE2 requirement that plagues the Linux side of things. That's why you're able to run 0.6.x. Sigil's source can be patched fairly easily to be able to build/run 0.6.x on non-SSE2 Linux platforms.

2) Qt5. The precompiled binaries for Qt5Webkit--the same ones that get distributed with the Windows installer for Sigil 0.7.x--are configured with an SSE2 requirement. And I see no (easy) way to custom build Qt5WebKit without the special SSE2 instructions (on any platform). This is the current deal breaker for hardware that doesn't support SSE2.

So unless Qt5WebKit gets changed/patched/whatever to remove the SSE2 requirement, Windows users with non-SSE2 processors are likely limited to Sigil 0.6.2 and earlier. It's that simple.

Linux users with non-SSE2 processors are limited to Sigil versions earlier than 0.3--if they're not willing/able to patch the source. And they're still limited to 0.6.x and earlier even if they are willing/able.

As I said earlier: For all practical purposes, it appears that Qt5WebKit (and thus Sigil >= 0.7.x) is now officially a no-go on hardware that doesn't support SSE2.
DiapDealer is online now   Reply With Quote
Old 05-05-2013, 11:46 AM   #21
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 15,098
Karma: 5939999
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Old hardware is soon (if not already) to be a plague on developers.

For many of us that do not run the Latest Video games, The old P4 series or AMD Athelon (XP series) was getting the job done for WEB browsing and mail. That may no longer be true.

Is there a pre-install tool that could be packaged with the distribution that runs a series of Hardware (and possibly, some incompatible software ) Tests and make an Announcement: 'Your Hardware does not support resources needed by version 7.X of Sigil. This is not a bug." or "We have detected XYZ program which is known to conflict with version 7.x of Sigil" if found. This would save hours of handling Bug reports/ MR posts.
theducks is offline   Reply With Quote
Old 05-05-2013, 04:55 PM   #22
Gian Carlo M.
Junior Member
Gian Carlo M. began at the beginning.
 
Posts: 8
Karma: 10
Join Date: May 2013
Device: none
Quote:
Originally Posted by DiapDealer View Post
As I said earlier: For all practical purposes, it appears that Qt5WebKit (and thus Sigil >= 0.7.x) is now officially a no-go on hardware that doesn't support SSE2.
Thank you for your exaustive explanation.
Gian Carlo M. is offline   Reply With Quote
Reply

Tags
sigil 0.7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-505 Reader Unable to start voyage_34 Sony Reader 5 11-23-2011 07:21 AM
Unable to start Sigil weedfreak Sigil 3 08-15-2011 04:28 AM
Unable to read Quick Start Guide redcomyn Calibre 6 01-27-2011 01:11 PM
Unable to start Openinkpot 0.2 lighty OpenInkpot 3 12-12-2009 07:39 PM
Unable to start Calibre after reinstall cuffy Calibre 2 03-26-2009 02:51 PM


All times are GMT -4. The time now is 09:27 PM.


MobileRead.com is a privately owned, operated and funded community.