Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil

Notices

Reply
 
Thread Tools Search this Thread
Old 04-21-2013, 01:28 PM   #16
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,848
Karma: 5654321
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by whenster View Post
Seems most likely that the lack of sse2 support for the CPU is the cause of the problem (as per signum and PeterT).

I searched for earlier threads and found these:

http://www.mobileread.com/forums/sho...d.php?t=124267

http://www.mobileread.com/forums/sho...d.php?t=177979

In particular posts 10 & 11 of the 2nd link. Not sure if a workaround is possible. May have to upgrade my computer if I want to run Sigil.

It would have been helpful if this issue was mentioned in the installation instructions of the Sigil wiki.

BTW. Bought the computer in 12/2003.
I have the same CPU (1.5G RAM) on one of my older XP machines. Just tried the upgrade to Sigil 7. (was Sigil 6.4)

Install ran.
But No Joy when I tried to run. (I did reboot)
I have the XP crash log if the devs are interested.
theducks is online now   Reply With Quote
Old 04-22-2013, 02:13 AM   #17
roger64
Wizard
roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.
 
Posts: 1,444
Karma: 846401
Join Date: Jan 2009
Device: KoboGlo
double post

Last edited by roger64; 04-22-2013 at 02:21 AM.
roger64 is offline   Reply With Quote
Old 04-22-2013, 02:17 AM   #18
roger64
Wizard
roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.roger64 ought to be getting tired of karma fortunes by now.
 
Posts: 1,444
Karma: 846401
Join Date: Jan 2009
Device: KoboGlo
Hi

Did you try using Sigil with Wine?

I am a Linux user (LMDE64bits) and also a dedicated Sigil user. A number of Linux users had trouble with the Sigil 0.7 release.

- After some difficulties too, I managed to compile Sigil 0.7.0 (using Diap-Dealer's advice) on my 64 bits computer. I did not find a more convenient way to launch it than using a start-up script. I did not update to 0.7.2. I should for this have downloaded the binary of Qt .0.2 and after that compiled again Sigil 0.7.2 and I thought it was not worth the trouble.

- On the other hand, Sigil 0.7.2 is now installed on my computer using Wine. It was a no brain install. I can start it like any other program. It's of course a 32 bit program but for a mere EPUB I really can't notice any drop in performance. The most important is that we can do it with a plain and small 25 MB install.

- Then I have a third Sigil, which is the old 0.6 version which is handy enough for many tasks and that I keep I do not know really why.

I think I will follow on using Sigil this way till the day when Qt5 will be distributed as a standard for Debian. It can be several months away. Life has become not too easy for Sigil Linux users.

To conclude with it: my best advice for now would be to use Sigil with Wine.

Last edited by roger64; 04-22-2013 at 02:24 AM.
roger64 is offline   Reply With Quote
Old 04-22-2013, 09:21 AM   #19
whenster
Member
whenster began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Apr 2013
Location: UK
Device: Nexus 7 FBReader
I cannot run Sigil > 0.2.4 on Windoze XP or via Wine because the CPU does not support SSE2.

I've installed Sigil 0.2.4 and that does run. I'll have to use that until I upgrade motherboard and CPU, or build another system (I'm planning to build a 64 bit machine).
whenster is offline   Reply With Quote
Old 04-22-2013, 11:19 AM   #20
PeterT
Taking a break; Fed up
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 6,970
Karma: 44005669
Join Date: Nov 2007
Location: Toronto
Device: Wife: Touch, Arc, Vox Me: Nexus 7, Glo
@Whenster: You might like to try one more thing....

In the file [B]sigil-0.7.2/src/src/Xerces/B] I see the following

Quote:
if( CMAKE_COMPILER_IS_GNUCXX )
# SSE2 autodetection sometimes fails on Linux, so we'll just
# require the presence of SSE2. Everything since the year 2000 (Pentium 4)
# has it, so it's not like we're leaving anyone out.
add_definitions( -msse2 )
endif()
Try commenting out the add_definitions( -msse2 ) and then regenerate the makefiles (ie redo the cmake command) and then redo the make as well.

To be tidy I actually blew away the entire sigil-0.7.2/ directory tree and started from scratch.

*EDIT*: Never mind... Disabling SSE2 caused compilation errors in building the Xerces component. Time for me to keep plugging away to see if there is any workaround.

**EDIT**: In sigil-0.7.2/src/src/Xerces/xercesc/util/Xerces_autoconf_config.hpp there is a section
Quote:
#ifndef __APPLE__
# define XERCES_HAVE_SSE2_INTRINSIC 1
#endif
Remove or comment out those lines (easiest way to comment them out is to add // before each line).

Same required for
Quote:
#ifndef __APPLE__
# define XERCES_HAVE_EMMINTRIN_H 1
#endif

Last edited by PeterT; 04-22-2013 at 11:54 AM.
PeterT is online now   Reply With Quote
Old 04-22-2013, 03:14 PM   #21
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,266
Karma: 42123822
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
You beat me to it!

I was able to compile using the -mno-sse2 flag (just to be sure) after making changes similar to yours in the "sigil-0.7.2/src/src/Xerces/xercesc/util/Xerces_autoconf_config.hpp" file.
(I basically just downloaded the xerces source and ran configure using the --disable-sse2 switch to see what it produced, and then compared it to the source in Sigil)

No errors and it still runs on my machine, but I have no hardware that DOESN'T support SSE2 to truly test it on.

I created a patch to change those two files if it makes it any easier. Just drop it in the uppermost level of Sigil's source tree (sigil-0.7.2/src if you're using the official instructions), cd to that same location and issue:
Code:
patch -p1 < sigil-0.7.2-no-sse2.patch
before running cmake.
(I attached it as a txt file so it would let me upload it ... you can rename it to sigil-0.7.2-no-sse2.patch or modify the command accordingly.)
Attached Files
File Type: txt sigil-0.7.2-no-sse2.txt (1.8 KB, 41 views)

Last edited by DiapDealer; 04-22-2013 at 03:44 PM.
DiapDealer is online now   Reply With Quote
Old 04-22-2013, 05:08 PM   #22
PeterT
Taking a break; Fed up
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 6,970
Karma: 44005669
Join Date: Nov 2007
Location: Toronto
Device: Wife: Touch, Arc, Vox Me: Nexus 7, Glo
Same here.... my h/w HAS SSE2 but at least it did load and run!
PeterT is online now   Reply With Quote
Old 04-23-2013, 05:33 AM   #23
whenster
Member
whenster began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Apr 2013
Location: UK
Device: Nexus 7 FBReader
Thanks for taking the time to look at the code for a workaround to the sse2 problem.

I did try to disable sse2 but (like Peter T said) that caused compilation errors with Xerces. I gave up at that point, as my knowledge of coding is basic.

I'll test both proposed fixes, and report back with the results.
whenster is offline   Reply With Quote
Old 04-23-2013, 06:13 AM   #24
whenster
Member
whenster began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Apr 2013
Location: UK
Device: Nexus 7 FBReader
Found closed Issue 646 on the wiki. This seems to be when this problem was first raised.

#3 nathanva refers to a patch for the SSE2 issue, but I cannot find it.

https://code.google.com/p/sigil/issues/detail?id=646

What happened to the wiki FAQ? Cannot find that either.

Last edited by whenster; 04-23-2013 at 02:34 PM.
whenster is offline   Reply With Quote
Old 04-23-2013, 02:33 PM   #25
whenster
Member
whenster began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Apr 2013
Location: UK
Device: Nexus 7 FBReader
Patch 1 (PeterT).
Commented out the 6 lines in sigil-0.7.2/src/src/Xerces/xercesc/util/Xerces_autoconf_config.hpp and nothing else.
This installed OK, but would not run. Illegal instruction error.

Patch 2 (DiapDealer).
Got an error when I ran:
Code:
patch -p1 < sigil-0.7.2-no-sse2.patch
Quote:
patching file src/Xerces/CMakeLists.txt
Hunk #1 FAILED at 165.
1 out of 1 hunk FAILED -- saving rejects to file src/Xerces/CMakeLists.txt.rej
patching file src/Xerces/xercesc/util/Xerces_autoconf_config.hpp
The alteration to src/Xerces/CMakeLists.txt failed. So I'm checking to find out what is wrong with this patch before trying to install or manually altering the code in src/Xerces/CMakeLists.txt

Is the problem the added line:
Quote:
add_definitions( -mno-sse2 )
I'm guessing, should it be:
Quote:
add_definitions( -mnosse2 )

Last edited by whenster; 04-23-2013 at 02:35 PM.
whenster is offline   Reply With Quote
Old 04-23-2013, 02:58 PM   #26
PeterT
Taking a break; Fed up
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 6,970
Karma: 44005669
Join Date: Nov 2007
Location: Toronto
Device: Wife: Touch, Arc, Vox Me: Nexus 7, Glo
I'd just remove that line fully.

The man page for gcc lists -msse2 as a valid option but does NOT list -mno-sse2 or any variant as valid.
PeterT is online now   Reply With Quote
Old 04-23-2013, 03:02 PM   #27
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,266
Karma: 42123822
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by whenster View Post
Patch 1 (PeterT).
Commented out the 6 lines in sigil-0.7.2/src/src/Xerces/xercesc/util/Xerces_autoconf_config.hpp and nothing else.
This installed OK, but would not run. Illegal instruction error.

Patch 2 (DiapDealer).
Got an error when I ran:
Code:
patch -p1 < sigil-0.7.2-no-sse2.patch

The alteration to src/Xerces/CMakeLists.txt failed. So I'm checking to find out what is wrong with this patch before trying to install or manually altering the code in src/Xerces/CMakeLists.txt

Is the problem the added line:
Code:
add_definitions( -mno-sse2 )
I'm guessing, should it be:
Code:
add_definitions( -mnosse2 )
No, it's definitely -mno-sse2
I'm guessing you didn't apply the patch to virgin Sigil source-code (or I didn't create the patch from virgin source). Perhaps you'd already commented out the add_definitions( -msse2 ) part as per PeterT's instructions before applying the patch? Or maybe there was some other change made to the src/Xerces/CMakeLists.txt file before applying the patch.

The change to the src/Xerces/CMakeLists.txt file was nothing more than changing
Code:
add_definitions( -msse2 )
to
Code:
add_definitions( -mno-sse2 )
Regardless, both procedures (PeterT's and mine) are essentially the same thing. If what he suggested didn't result in a binary you could launch than it's not likely you'd have any different results had the patch worked.

There's just no guarantee that there hasn't been even more special instruction code creeping into other parts of Sigil's source since the days of 0.3.x that your processor is incapable handling.
DiapDealer is online now   Reply With Quote
Old 04-23-2013, 03:05 PM   #28
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,266
Karma: 42123822
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by PeterT View Post
I'd just remove that line fully.

The man page for gcc lists -msse2 as a valid option but does NOT list -mno-sse2 or any variant as valid.
http://gcc.gnu.org/onlinedocs/gcc/i3...4-Options.html
DiapDealer is online now   Reply With Quote
Old 04-24-2013, 02:58 PM   #29
whenster
Member
whenster began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Apr 2013
Location: UK
Device: Nexus 7 FBReader
Some success at last.

Manually applied patch to Sigil 0.3.0. Installation was successful, and it ran. Repeated the same with Sigil 0.6.2. Same result. Installation was successful, and it ran.

When patch is applied to Sigil 0.7.2 it gives Hunk error as per #25 (patch was applied to clean source). I manually altered src/Xerces/CMakeLists.txt file. Installation was successful, but it fails to run, and gives 'Illegal instruction' error.

So I guess the problem with 0.7.2 is in some way related to Qt5.

Last edited by whenster; 04-25-2013 at 12:00 PM.
whenster is offline   Reply With Quote
Old 04-24-2013, 04:44 PM   #30
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,266
Karma: 42123822
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
The Hunk error was definitely my fault. I clearly didn't do the diff on the original. Sorry about that.

I think you're spot on, about it being Qt5 related, though. I fired up some old hardware (no sse2) and was able to compile 0.7.2 without the SSE2 instructions in xerces just fine, but gdb reveals that the illegal instruction error had then moved from Sigil to libQt5Webkit.

Looks like the only option left to you would be to compile Qt5 yourself on that hardware.

Last edited by DiapDealer; 04-24-2013 at 04:46 PM.
DiapDealer is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in Installing Calibre in ubuntu 11.10 yogesh605 Development 4 12-14-2011 02:58 AM
Problem in Installing Calibre in ubuntu 11.10 yogesh605 Introduce Yourself 4 12-12-2011 02:27 PM
Python not installing on Ubuntu Robotech_Master Calibre 1 01-05-2011 07:08 AM
Installing latest Calibre in Ubuntu 10.04 maitrayei Calibre 4 09-10-2010 02:48 AM
Problems Installing on Lunix Ubuntu machine Snackb0y11 Calibre 2 12-28-2009 11:04 AM


All times are GMT -4. The time now is 01:12 PM.


MobileRead.com is a privately owned, operated and funded community.