Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 01-06-2013, 09:43 AM   #1
kaistian
Junior Member
kaistian began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jan 2013
Device: none
calibre-server: Doesn't server up newly added files

When I add new files to Calibre Library they show up on the web page with cover but is missing the "Get" button.
If I go to the the mobile version I get the link to the file and when I click it I get the following message:
Code:
404 Not Found
book: 338 does not have format: EPUB
Powered by CherryPy 3.2.2
Open the files I added a while back works on the web and all files open without problem in the client so it's just the web that is the problem.
Code:
$ pwd
/data/calibre_bibliotek/Linux Journal/Linux Journal January 2013 (338)

$ ls -1
cover.jpg
Linux Journal January 2013 - Linux Journal.epub
metadata.opf
I have also tried restarting the calibre-server but that did not help. And the server is started as root like this:
Code:
/usr/bin/python2.7 /usr/bin/calibre-server --auto-reload --with-library=/data/calibre_bibliotek --pidfile=/var/run/calibre-server.pid --port=7777 --max-cover=300x400 --username=test --password=test --daemonize
The server_error_log.txt doesn't show any error messages.

From the server_access_log.txt
Code:
192.168.1.182 - test [06/Jan/2013:14:58:34] "GET /get/EPUB/Linux Journal-Linux Journal January 2013_338.epub HTTP/1.1" 404 723 "http://192.168.1.10:7777/mobile" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0"
I have tried "Check library" but it shows no problems.

Some info:
Kubuntu 12.04 AMD64
Calibre 0.8.38 from Universe
Firefox 17 and Chrome 23

Anyone have some hints?
kaistian is offline   Reply With Quote
Old 03-10-2013, 09:58 AM   #2
willemwortel
Junior Member
willemwortel began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Mar 2013
Device: sony-prst1
No hints but exactly the same problem here with Ubuntu 12.04.2.
Have you already gotten any further with this?
willemwortel is offline   Reply With Quote
Old 03-10-2013, 10:08 AM   #3
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 24,759
Karma: 4369667
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Dont use the repository version of calibre for a start. INstall the official binary from http://calibre-ebook.com/download_linux
kovidgoyal is offline   Reply With Quote
Old 03-10-2013, 10:37 AM   #4
willemwortel
Junior Member
willemwortel began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Mar 2013
Device: sony-prst1
I have removed the repository version stopped the server and ran the installer, removed the books that didn't work previously and added them again. Unfortunately I observe the same behavior, in the gui application everything works as expected, but on the web server the new books are displayed without a download link. In the mobile version there is a download link (epub) but I get the 404 error. Is there a possibility to enable some extra debug logging?
willemwortel is offline   Reply With Quote
Old 03-10-2013, 11:32 AM   #5
willemwortel
Junior Member
willemwortel began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Mar 2013
Device: sony-prst1
Ok, a reboot seems to have fixed this, so maybe a combination of the new version and the reboot. I never like when a problem gets fixed by a reboot, but I'm very happy that I can use calibre server again. Thanks for the suggestion!
willemwortel is offline   Reply With Quote
Old 03-17-2013, 11:54 AM   #6
kaistian
Junior Member
kaistian began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jan 2013
Device: none
@willemwortel, no I had not succeeded in making it work.
But i light of your success I looked at it one more time.

My library is stored in /data/calibre_bibliotek/, /data is mounted to a device.
When I unmounted /data I saw that my /data had a folder calibre_bibliotek with content.
I deleted the folder an mounted /data again an now Calibre server is working again :-D
kaistian is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre Content Server and Windows Home Server 2011 HughMcC Calibre 7 11-15-2013 06:10 PM
calibre-server OPDS catalog - manual move to web server HaakonME Related Tools 5 09-21-2012 03:11 AM
Calibre content server downloading doesn't include metadata cerasi Devices 0 09-08-2012 07:27 PM
500 Internal Server Error accessing content server Calibre 0.8.8 DaddyO57 Calibre 1 07-20-2012 06:08 PM
Calibre-server port not open issue on Fedora server stueyboy Devices 0 08-17-2011 04:57 PM


All times are GMT -4. The time now is 12:47 AM.


MobileRead.com is a privately owned, operated and funded community.