Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 02-15-2013, 12:56 PM   #76
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
Quote:
Originally Posted by salomon View Post
@entodoays: My PRS-T1 do not connected with computer. I don't known why?
Can you explain a bit better what are you doing and when are you getting stuck?
entodoays is offline   Reply With Quote
Old 03-11-2013, 01:39 PM   #77
blazm
Junior Member
blazm doesn't litterblazm doesn't litter
 
Posts: 8
Karma: 124
Join Date: Jan 2013
Device: Sony PRS-T1
Guys, back in the game again... After almost 2 moths I have received back my reader I have sent to Sony Service for repairs. Guess what - NOTHING was done with it, I received back same device I have sent to them, with same error still persisting. I have provided them with 123 recipe for failure and it still worked when I received the device...
Clean case for Sony Listens.

Hey entodoays, I am glad to see you managed to figure out some things. Right now I will try your recipe with backing up, cleaning partition tables and restoring the backup. Will check if this work. If it does not, I have access to working PRS-T1 and will try with that. Thanks for all the work you have put into resolving this issue. Really appreciate it.
blazm is offline   Reply With Quote
 
Enthusiast
Old 03-11-2013, 03:27 PM   #78
blazm
Junior Member
blazm doesn't litterblazm doesn't litter
 
Posts: 8
Karma: 124
Join Date: Jan 2013
Device: Sony PRS-T1
Followed the procedure entodoays described. Got stuck when creating a disk image with Ubuntu Disks. Did a little research:
- managed to do dd of all partitions (sdb1..sdb10) withot problems,
- failed to do dd of "unused space" at the beginning of the drive, stuck at 9,4 MB (or 13,4 MB if conv=noerror used),
- badblocks reported 4 bad blocks (9600-9603) when doing read-only test on /dev/sdb

So I am out of luck I guess. I can still try and overwrite existing partitions 1..10 by the ones from working device but having those bad blocks is not something I wanted to see.

I wrote to Sony Listens about my case, I wonder what they will do. Usually they understand the situation and do something good
blazm is offline   Reply With Quote
Old 03-12-2013, 05:21 AM   #79
blazm
Junior Member
blazm doesn't litterblazm doesn't litter
 
Posts: 8
Karma: 124
Join Date: Jan 2013
Device: Sony PRS-T1
Thanks to entodoays I managed to fix my reader! Followed the procedure to make partition by partition backup of working unrooted device. Restored partitions 1,2,5,6,7,8,9,10 on my faulty reader (did not delete the partition table, diff showed that my partition table and partition table from working reader are identical). End voila, everything worked, problems with dictionary are solved. Rooted with latest package and still everything is working.

I then also rooted working device (since I have full backup). Checked the diff between dumps of un-formatted space and yup, there is some difference, so root-ing will change that part of FLASH and YOU SHOULD DO BACKUP. To bad I did not do it for my faulty device but now it should not matter.

My faulty reader has some bad blocks in un-formatted part of the flash. Probably that caused the errors. My speculation is that during the factory reset part of the information from un-formatted partition is written to some other partition. It's a very speculative guess though...

Thanx
blazm is offline   Reply With Quote
Old 03-13-2013, 04:37 AM   #80
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
@blazm. Before I erased the partition table, I did find bad blocks too on my Reader and I had marked them as bad. I shouldn't have done that because that was blocking me from doing backups.

Luckily I had done a backup of the faulty reader, while it was faulty but before checking and marking bad blocks. Therefore I was able to erase the partition table (and therefore bad block markings), restore faulty backup and then restore partitions from good Reader.
entodoays is offline   Reply With Quote
Old 03-13-2013, 01:22 PM   #81
blazm
Junior Member
blazm doesn't litterblazm doesn't litter
 
Posts: 8
Karma: 124
Join Date: Jan 2013
Device: Sony PRS-T1
I had bad block in un-formatted space, before first partition. Blocks 9600-9603 while first partition /dev/sdX1 starts at 52xxx something. That is the part that is unique to each reader and should not be overwritten if copying partitions from another (working) reader. So there was no point for me to remove the partition table.

My reader is working fine for now, no problems with dictionary of WiFi or anything.
blazm is offline   Reply With Quote
Old 03-17-2013, 12:54 PM   #82
dedgod
Enthusiast
dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.
 
Posts: 30
Karma: 15302
Join Date: Oct 2011
Device: Kindle PW2
I think I was able to fix my dictionary problem using this method also.

When I got to the step of backing up the faulty Reader, it kept stopping in the dictionary partition. I backed up the good Readers dictionary partition and restored it to the faulty Readers dictionary partition. I have tried accessing definitions numerous times after sleep mode and no problems so far.

Thanks to entodoays and blazm for all your hard work and for sharing it.
dedgod is offline   Reply With Quote
Old 05-03-2013, 10:28 AM   #83
Br*ste1
Member
Br*ste1 began at the beginning.
 
Posts: 24
Karma: 10
Join Date: Jul 2012
Device: PRS-T1
I'm really stuck on this and would appreciate some help. My PRS-T1 keeps freezing in sleep mode - essentially, I have to push reset to wake it up.

I've tried the backup instructions for Windows posted here: http://translate.google.com/translat...hp%3Ft%3D23354

...but with both tools (Roadkil and wind32diskimager) I can't get past a CRC error at about 24% of the image.

So now I've tried switching the process to my little eePC running some Ubuntu flavor (as per the instructions in this thread), but I really can't see the woods for the trees. Fact is that I get a number of new drives listed when I plug in the PRS-T1 (automount being turned off). "Disk" doesn't have two cogs to create an image, can't use dd because there is no /dev/sda and generally I'm somehow expecting that, no matter what I do, I will run into that cursed CRC error again (what is it trying to tell me, anyway?!).

I'd really really appreciate some pointers here. Many thanks in advance!
Br*ste1 is offline   Reply With Quote
Old 05-03-2013, 01:16 PM   #84
rupor
Addict
rupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toys
 
rupor's Avatar
 
Posts: 207
Karma: 5658
Join Date: Jul 2007
Location: USA
Device: PRS 500,505,900,650,T1,T2, Nook ST
Br*ste1 - more than likely you have a bad block(s) in your flash (CRC error). Depending on what is the address of those block(s) it may be unrecoverable and needs physical fix - replacement of mmc device...
rupor is offline   Reply With Quote
Old 05-03-2013, 04:40 PM   #85
Br*ste1
Member
Br*ste1 began at the beginning.
 
Posts: 24
Karma: 10
Join Date: Jul 2012
Device: PRS-T1
Quote:
Originally Posted by rupor View Post
Br*ste1 - more than likely you have a bad block(s) in your flash (CRC error). Depending on what is the address of those block(s) it may be unrecoverable and needs physical fix - replacement of mmc device...
So this means it's safe to send my device to Sony for repairs? What I want to avoid, if possible, is that they send it back with a high bill, telling me the problem ocurred because it was rooted.

I'm assuming it's better not to tell them of the CRC error, but to play the naive customer?
Br*ste1 is offline   Reply With Quote
Old 05-03-2013, 06:14 PM   #86
rupor
Addict
rupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toys
 
rupor's Avatar
 
Posts: 207
Karma: 5658
Join Date: Jul 2007
Location: USA
Device: PRS 500,505,900,650,T1,T2, Nook ST
I have no idea really what is better, sorry. My only experience in this area comes from the times of PRS-500 which I sent them twice - problem with the screen, both times device was under warranty and both times it had custom firmware. They fixed the device without a single complain leaving firmware intact.

Since you cannot make a backup (assuming everything else is OK) and backup procedure does not root device and does not leave traces (all I do is mapping complete flash as a storage device rather than mapping various partitions as original Sony's firmware does) - I do not see how you could get in troubles.
rupor is offline   Reply With Quote
Old 05-03-2013, 07:02 PM   #87
Br*ste1
Member
Br*ste1 began at the beginning.
 
Posts: 24
Karma: 10
Join Date: Jul 2012
Device: PRS-T1
Quote:
Originally Posted by rupor View Post
Since you cannot make a backup (assuming everything else is OK) and backup procedure does not root device and does not leave traces (all I do is mapping complete flash as a storage device rather than mapping various partitions as original Sony's firmware does) - I do not see how you could get in troubles.
Well the full story is that I rooted the device first. Kept having those problems with the device not waking up anymore. So I unrooted, tried the restore package, tried the hard reset - problem remained.

But this is a dead end now with the CRC error, then I guess I have no other options than Sony support anyway.
Br*ste1 is offline   Reply With Quote
Old 05-04-2013, 09:42 AM   #88
rupor
Addict
rupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toys
 
rupor's Avatar
 
Posts: 207
Karma: 5658
Join Date: Jul 2007
Location: USA
Device: PRS 500,505,900,650,T1,T2, Nook ST
Br*ste1 since you unrooted and restored the device - I do not think they will even know about rooting...
rupor is offline   Reply With Quote
Old 05-04-2013, 10:45 AM   #89
Br*ste1
Member
Br*ste1 began at the beginning.
 
Posts: 24
Karma: 10
Join Date: Jul 2012
Device: PRS-T1
Quote:
Originally Posted by rupor View Post
Br*ste1 since you unrooted and restored the device - I do not think they will even know about rooting...
Ok - thanks.
Br*ste1 is offline   Reply With Quote
Old 05-16-2013, 04:26 AM   #90
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
@Br*ste1 One possible solution is to use a modified procedure of the one I posted.

Basically, you could try:

1. backing up the unique part of your Reader using dd. I don't remember the exact command line. @Rupor can you give the command to use.

2. Backup a good PRS-T1 completely.
3. Restore the backup to the faulty one followed immediately by
4. a restore of the unique raw data block at the beginning copied in the first step.

When I had checked my PRS-T1 for bad blocks it found some here and there but my procedure made my Reader behave "as new".
entodoays is offline   Reply With Quote
Reply

Tags
amr, hanging, prst1, sony

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-T1 PRS-T1 stuck off and unresponsive...but no serial to return samadam Sony Reader 3 06-15-2012 12:13 PM
PRS-350 Unresponsive Buttons mer10 Sony Reader 9 04-05-2012 04:41 PM
PRS-350 sony prs 350: blank unresponsive screen, blinking orange light halipleumon Sony Reader 5 05-30-2011 06:49 AM
Unresponsive Prs-505 Reader 101 Sony Reader 1 09-15-2008 04:19 AM
Unresponsive honeybunny Amazon Kindle 8 07-17-2008 05:18 PM


All times are GMT -4. The time now is 02:08 AM.


MobileRead.com is a privately owned, operated and funded community.