Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 01-07-2013, 12:43 PM   #136
ottischwenk
Member
ottischwenk began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Sep 2012
Device: trekstor Pyrus
Quote:
Originally Posted by porkupan View Post
The root stuff should go onto the READER drive (you can take the SD card out).

Looks like there is a weird problem with the driver that causes it to mistake the READER drive for SD, and vice versa. Don't know why. Haven't seen it anywhere else.
I succeeded - thank you.
I copied the stuff to sd
ottischwenk is offline   Reply With Quote
Old 01-09-2013, 05:51 PM   #137
Byske
Junior Member
Byske began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jan 2013
Device: Sony PRS-T2
Maybe the same problem as mine?
Repartitioning the card did solve it for me.

Edit: Oh, I didn't realize who was posting ;-) We already discussed my issue...

Last edited by Byske; 01-09-2013 at 06:27 PM.
Byske is offline   Reply With Quote
Old 01-16-2013, 10:04 AM   #138
metaphys
Junior Member
metaphys began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jan 2013
Device: sony prs-t2
Hello,

For those who have problem using right and left keys with other androids application this prs-T1 apk works very well with T2:
http://www.mobileread.mobi/forums/sh...d.php?t=187054
just install the apk reboot and you're done !

Just a question: would there be a way to activate screen refresh on T2, I tried package for the T1 bug they either bug the screen or even don't start...
metaphys is offline   Reply With Quote
Old 01-18-2013, 05:01 PM   #139
oldenburg
Junior Member
oldenburg began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jan 2013
Device: Sony PRS-T2
Hi!

Is it possible to perform this hack without the use of an SD-card?
Been trying to figure this out by myself but don't know if i can trust the google-translated russian site.

Last edited by oldenburg; 01-18-2013 at 05:06 PM.
oldenburg is offline   Reply With Quote
Old 02-08-2013, 10:54 AM   #140
oldenburg
Junior Member
oldenburg began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jan 2013
Device: Sony PRS-T2
Never mind, found that guide back in this thread. I've managed to follow the steps and my Reader indicated that the jailbreak was successful. However after looking at the .log file im not so sure.

"Starting /etc/rc.d/rcS
Image mmcblk2p9 not found
Image mmcblk2p10 not found
Image mmcblk2p1 not found
/initrd/mnt/sd/OS Firmware/files/new.mmcblk2p2.img: Checksum 77ea10509c4b013b82ed208885218d00 correct
Saving mmcblk2p2
dd: can't open '/initrd/mnt/sd/dumps/mmcblk2p2.img': No such file or directory
Flashing mmcblk2p2
10240+0 records in
10240+0 records out
Flashing mmcblk2p2 complete 0
"

Lots of "can't open"s and finishes with "complete 0", was it successful?

My device is a EU running SW 1.0.04.11081 , which is recommended?

Last edited by oldenburg; 02-10-2013 at 05:01 AM.
oldenburg is offline   Reply With Quote
Old 02-08-2013, 11:36 AM   #141
rupor
Addict
rupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toys
 
rupor's Avatar
 
Posts: 207
Karma: 5658
Join Date: Jul 2007
Location: USA
Device: PRS 500,505,900,650,T1,T2, Nook ST
All warnings are normal - jailbreak only requires mmcblk2p2 to be flashed, script is more generic...
rupor is offline   Reply With Quote
Old 02-10-2013, 05:03 AM   #142
oldenburg
Junior Member
oldenburg began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jan 2013
Device: Sony PRS-T2
Thanks for your reply, got it up and running the minimal android loader now. Great job, works flawlessly!
oldenburg is offline   Reply With Quote
Old 02-11-2013, 05:42 AM   #143
User0296
Junior Member
User0296 began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Feb 2013
Device: PRS-T2
Hi,
Last week I bought new device in Belgium. Firmware version is 1.0.04.11081. When I am trying to run jailbreak I can see the following messages on a screen:

C:\Reader\rupor-jailbreak>flash_reader.bat
Volume in drive D has no label.
Volume Serial Number is 420A-13E9
Continue? <Y/N> Y
.\OS Firmware\files\new.mmcblk2p2.img
.\OS Firmware\files\new.mmcblk2p2.md5
.\OS Firmware\files\update.img
.\OS Firmware\files\update.img.sig2
4 File(s) copied
Sony Reader MSC utility 1.07 (c) 2012 Igor Skochinsky, Vladimir Boroda
avail: 1
openDrive [\\.\D:]: 1
usbInitCheck: 0
Press any key to continue . . .

After reboot device doesn't show update screen and just starting. I am using 32 Gb SD card. Could it be a problem?
User0296 is offline   Reply With Quote
Old 02-11-2013, 04:08 PM   #144
rupor
Addict
rupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toysrupor shares his or her toys
 
rupor's Avatar
 
Posts: 207
Karma: 5658
Join Date: Jul 2007
Location: USA
Device: PRS 500,505,900,650,T1,T2, Nook ST
User0296

Are you sure that drive D: is actually SD card in the reader you are trying to jailbreak?
rupor is offline   Reply With Quote
Old 02-12-2013, 04:28 AM   #145
User0296
Junior Member
User0296 began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Feb 2013
Device: PRS-T2
Yes, I am sure, because after format in reader SD card doesn't have label.

D:\>dir
Volume in drive D has no label.
Volume Serial Number is 420A-13E9

Directory of D:\

08.02.2013 12:12 <DIR> Sony_Reader
08.02.2013 12:57 245 driveinfo.calibre
08.02.2013 12:53 7*031 metadata.calibre
07.02.2013 23:59 <DIR> OS Firmware
2 File(s) 7*276 bytes
2 Dir(s) 31*683*969*024 bytes free
Attached Thumbnails
Click image for larger version

Name:	Untitled.gif
Views:	106
Size:	41.5 KB
ID:	101116  
User0296 is offline   Reply With Quote
Old 02-13-2013, 03:37 AM   #146
silasg
Junior Member
silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.
 
Posts: 8
Karma: 472948
Join Date: Feb 2013
Device: Sony PRS-T2
Hi all,

when I try to uninstall apps, the (Android settings?) process crashes. I can go back to the list of installed apps directly but if I try to uninstall it a second time it crashs again.

Has anybody else the same problem -- or maybe a solution?

Thanks

Silas
silasg is offline   Reply With Quote
Old 02-14-2013, 02:09 AM   #147
silasg
Junior Member
silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.
 
Posts: 8
Karma: 472948
Join Date: Feb 2013
Device: Sony PRS-T2
Update: Even installing new apps seems to fail :/ After (successful) install of googleServicesFramework.apk and vending2.2.11-signed.apk I tried to install some browser from the market. This failed after download. I didn't care because it's known that lot of apps don't work. After that I transferred Moon+ Reader and Aldiko via Dropbox. At least Moon+ should work I think. But when I try to install them directly (I use Root Explorer to navigate to the APKs), Root Explorer crashs after I choose "Install" in the Message Box that asks me what to do with the APK.

Could be the case that I installed Update to 1.0.05 _after_ rooting the device? I have a Roadkil image of 1.0.03, should I recover this?

Thanks
silasg is offline   Reply With Quote
Old 02-14-2013, 06:26 PM   #148
vbkun
Enthusiast
vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.
 
Posts: 28
Karma: 544634
Join Date: Jan 2011
Device: Maybe sony
Quickdoubt:

I'm on 1.0.04.11081 Us model. Did the killroad backup and went to procced to jailbrake.

I noticed the jailbrake file's data that i got are from 2012/10 - 2012/09.

That's correct, and the file that was updated to the 1.0.4.1181 was just the ARM file right?

( just checking to be sure before proceding :3 )
vbkun is offline   Reply With Quote
Old 02-14-2013, 08:38 PM   #149
vbkun
Enthusiast
vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.vbkun ought to be getting tired of karma fortunes by now.
 
Posts: 28
Karma: 544634
Join Date: Jan 2011
Device: Maybe sony
Ok Stuff didn't went out really well here.

I did the jailbrake, the log had a bunch of errors about not finding images and in the end it flashed something (log attached).

I went then for the app2sd install, from the file rupor-enable-asec.7z. Then the reader flashed and after reboot it literally went on loop, halted at the spinning arrow. As i could not get the log for it I'm attaching a jpg of the cmd for it.

Any idea of what might have gone wrong?

---UPdate---

Doing the app2sd after the AMR solved it for me. everything is fine now =D
Attached Thumbnails
Click image for larger version

Name:	app2sd.JPG
Views:	112
Size:	44.4 KB
ID:	101271  
Attached Files
File Type: txt jailog.txt (388 Bytes, 65 views)

Last edited by vbkun; 02-17-2013 at 09:12 PM.
vbkun is offline   Reply With Quote
Old 02-18-2013, 07:55 AM   #150
silasg
Junior Member
silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.silasg ought to be getting tired of karma fortunes by now.
 
Posts: 8
Karma: 472948
Join Date: Feb 2013
Device: Sony PRS-T2
Quote:
Originally Posted by silasg View Post
Update: Even installing new apps seems to fail :/ After (successful) install of googleServicesFramework.apk and vending2.2.11-signed.apk I tried to install some browser from the market. This failed after download. I didn't care because it's known that lot of apps don't work. After that I transferred Moon+ Reader and Aldiko via Dropbox. At least Moon+ should work I think. But when I try to install them directly (I use Root Explorer to navigate to the APKs), Root Explorer crashs after I choose "Install" in the Message Box that asks me what to do with the APK.

Could be the case that I installed Update to 1.0.05 _after_ rooting the device? I have a Roadkil image of 1.0.03, should I recover this?

Thanks
Fixed it using restore-jail-1.0.05.12140, restore-set-1.0.04.11081-eu (I have an EU version) and rupor-minimal. In this order.
silasg is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Q] Can't get to settings after hacking holgalee Kindle Developer's Corner 11 05-26-2012 07:52 AM
K3 screen hacking arikfunke Kindle Developer's Corner 8 04-28-2012 10:43 AM
hacking in? omro Astak EZReader 5 12-09-2009 05:59 PM
Hacking like we had for the 500? TadW Sony Reader Dev Corner 2 04-03-2008 05:46 AM


All times are GMT -4. The time now is 07:48 AM.


MobileRead.com is a privately owned, operated and funded community.