Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 12-21-2012, 08:57 AM   #31
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
I'm still not completely convinced it is an epub problem. If I open the dictionary not from within a book and try to change the dictionary the problem occurs as well.

what if the partition table got corrupt and therefore every time I flash something data is not written properly to the Reader? If I root the unit again, and enable adb. Is there a way to analyse the partition table and if necessary repair it?

I'm familiar with Linux, I've partitioned PC hard disks many times. I never repaired partition tables before but I'm ready to learn.

Last edited by entodoays; 12-21-2012 at 09:06 AM.
entodoays is offline   Reply With Quote
Old 12-22-2012, 10:55 AM   #32
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
So I tried something else. To check if it is really the Calibre books causing the problem, I removed them all, leaving a few books I downloaded from feedbooks.

I tried using the dictionary, changing dictionary, open and close books. Everything worked as expected.

Then I tried to connect to the internet. The browser started loading the page and became unresponsive with the progress bar half-way. Back and menu buttons don't work. Finally I got an " Activity Browser (in application Browser) is not responding. Force Close or Wait. I tried clicking Force close but the unit seemed unresponsive. Then I got a black screen followed by "Pictures" where all pictures were without a thumbnail. I now deleted all custom images as well.

Is this a possibly related issue?

Now I downloaded again one Calibre created epub to see if it causes problems or not. I'll test it for a few days to see if this issue is solved or not.

Last edited by entodoays; 12-22-2012 at 11:06 AM. Reason: added detail.
entodoays is offline   Reply With Quote
Old 12-22-2012, 04:45 PM   #33
pe1dnn
Enthusiast
pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.pe1dnn ought to be getting tired of karma fortunes by now.
 
Posts: 31
Karma: 1315217
Join Date: Oct 2011
Device: PRS-T1
Quote:
Originally Posted by entodoays View Post
Is this a possibly related issue?
I just read thought this thread and really wonder what you expect from us.

First there is a page full of messages with attempts to reset your device. Then pages with your attempts to find the cause of your problem, providing hunches about buggy epubs from Calibre, then again not, now blaming the browser without specifying what you browsed. And it goes on and on.

Maybe you think, or at least act, like this is your personal log where you can scribble down every angle you try on your problem, but it is not. We, the reader, get a shit load of inconsistent and incomplete information. I can's see how we are supposed to help. And even if we could give you a hint it is most likely useless because you already got new insights and digged into another area already.

So some general advice about trouble shooting:

1) Bring the device back into its original state using rupor's advice. This is a known good state, the baseline. If the device does not work correctly in this state any analysis is futile. There is no need to go on if you do not get this right and nobody will be able to help you since this works okay for all other users. You should be able to get this right unless your reader is really broken. In the latter case it should be send to Sony for repair.
2) Don't throw everything back at once. Instead do it ONE thing at the time, and after each time test, test and test (seriously!).
3) When the problem occurs, make a note of the last step you did. Then repeat the procedure from point 1), but at point 2) do everything EXCEPT the step that caused a problem, skip over it.
4) When all other changes are applied in the end, except of the steps that caused problems, then you should have a fine working reader and a comprehensive list of the steps or activities that causes problems.

If you still want a solution form us, then come back after step 4 and tell which steps fail, what EXACTLY you did before this step, starting from the moment you restored the reader at step 1, then what it is you did EXACLTY at the failing steps, what kind of problems it caused and how it was detected. Describe it such way that someone else can replay/repeat your steps. So "start browser" is not enough, tell us how you started it and which site you visited and how you got back out of it to do your tests of the reader responsiveness.

If you are not systematic about it nobody can help you. It becomes blind guess work and also you will not be able to verify a solution if you cannot repeat the process steps leading to the problem. There is no need to report about the intermediate steps during your problem analysis. I hope this helps.
pe1dnn is offline   Reply With Quote
Old 12-24-2012, 07:09 AM   #34
dedgod
Enthusiast
dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.
 
Posts: 30
Karma: 15302
Join Date: Oct 2011
Device: Kindle PW2
"Then I tried to connect to the internet. The browser started loading the page and became unresponsive with the progress bar half-way. Back and menu buttons don't work. Finally I got an " Activity Browser (in application Browser) is not responding. Force Close or Wait. "

I have also gotten this message when accessing the dictionary. I don't use the browser much so I don't see it there. I can reliably reproduce this problem by accessing the dictionary several times. Conversely, I can avoid it by not accessing the dictionary.

If you google this message, you will find that numerous "Nook" users have gotten it too. I did not find a reliable fix among "Nook" users either.
dedgod is offline   Reply With Quote
Old 01-02-2013, 06:20 AM   #35
snarkophilus
Wannabe Connoisseur
snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.snarkophilus ought to be getting tired of karma fortunes by now.
 
Posts: 241
Karma: 1009530
Join Date: Apr 2011
Location: Geelong, Australia
Device: Sony PRS-T1, Sony PRS-350, Palm TX
I've had a few problems similar to this (generally unresponsive every now and then), but mainly the content manager would run continuously after a sync until the battery went flat and I got into the habit of killing it right after each sync.

I suspected a corrupt epub, but couldn't find an easy way to work out what the content manager was looking at so I put the following in a script (my T1 is rooted):
Code:
busybox find /proc/*/fd -print0 | busybox xargs -0 ls -l | busybox grep epub
This just looks for any open epub files that a process has open.

Once I found an epub that the content manager was stuck on, testing it with "unzip -t" would give errors like:

Spoiler:
Code:
sbacer 2739> unzip -t  Sony_Reader/media/books/CBUS125EP009001U.epub
Archive:  Sony_Reader/media/books/CBUS125EP009001U.epub
    testing: META-INF/                OK
    testing: META-INF/container.xml   OK
    testing: mimetype                 OK
    testing: OEBPS/                   OK
    testing: OEBPS/0123456789.opf     OK
    testing: OEBPS/0123456789_cov.html   OK
    testing: OEBPS/AroundtheWorldin80Days_1.html   OK
    testing: OEBPS/AroundtheWorldin80Days_10.html   OK
    testing: OEBPS/AroundtheWorldin80Days_11.html   OK
    testing: OEBPS/AroundtheWorldin80Days_12.html   OK
    testing: OEBPS/AroundtheWorldin80Days_13.html   OK
    testing: OEBPS/AroundtheWorldin80Days_14.html   OK
    testing: OEBPS/AroundtheWorldin80Days_15.html   OK
    testing: OEBPS/AroundtheWorldin80Days_16.html   OK
    testing: OEBPS/AroundtheWorldin80Days_17.html   OK
    testing: OEBPS/AroundtheWorldin80Days_18.html   OK
    testing: OEBPS/AroundtheWorldin80Days_19.html   OK
    testing: OEBPS/AroundtheWorldin80Days_20.html   OK
    testing: OEBPS/AroundtheWorldin80Days_21.html   OK
    testing: OEBPS/AroundtheWorldin80Days_22.html   OK
    testing: OEBPS/AroundtheWorldin80Days_23.html   OK
    testing: OEBPS/AroundtheWorldin80Days_24.html   OK
    testing: OEBPS/AroundtheWorldin80Days_25.html   OK
    testing: OEBPS/AroundtheWorldin80Days_26.html   OK
    testing: OEBPS/AroundtheWorldin80Days_27.html   OK
    testing: OEBPS/AroundtheWorldin80Days_28.html   OK
    testing: OEBPS/AroundtheWorldin80Days_29.html   OK
    testing: OEBPS/AroundtheWorldin80Days_3.html   OK
    testing: OEBPS/AroundtheWorldin80Days_30.html  
  error:  invalid compressed data to inflate
file #30:  bad zipfile offset (local header sig):  123206
file #31:  bad zipfile offset (local header sig):  129270
    testing: OEBPS/AroundtheWorldin80Days_33.html   OK
    testing: OEBPS/AroundtheWorldin80Days_34.html   OK
    testing: OEBPS/AroundtheWorldin80Days_35.html  
  error:  invalid compressed data to inflate
file #35:  bad zipfile offset (local header sig):  150475
file #36:  bad zipfile offset (local header sig):  153531
    testing: OEBPS/AroundtheWorldin80Days_38.html   OK
    testing: OEBPS/AroundtheWorldin80Days_39.html   OK
    testing: OEBPS/AroundtheWorldin80Days_4.html   OK
    testing: OEBPS/AroundtheWorldin80Days_5.html  
  error:  invalid compressed data to inflate
file #41:  bad zipfile offset (local header sig):  174327
file #42:  bad zipfile offset (local header sig):  177607
file #43:  bad zipfile offset (local header sig):  180824
    testing: OEBPS/AroundtheWorldin80Days_9.html   OK
    testing: OEBPS/AroundtheWorldin80Days_copyright.html   OK
    testing: OEBPS/contents.html      OK
    testing: OEBPS/Images/            OK
    testing: OEBPS/Images/cover.png   bad CRC 83846fbf  (should be a20118e4)
    testing: OEBPS/Images/Thumb.png   OK
    testing: OEBPS/Penn.css           OK
    testing: OEBPS/toc.ncx            OK
At least one error was detected in Sony_Reader/media/books/CBUS125EP009001U.epub.


I've fixed this (so far!) by doing a number of cycles of bad sector scan/fix. On Windows 7 with the T1 connected, right click Properties, select the Tools tab, click "Check now" and then check the "Scan for and attempt recovery of bad sectors" box and then click Start. Anything that was listed as having a bad sector/cluster I then got Calibre to re-send to the T1.

If I have any more errors, I think I'll just switch to using a micro SD card and not put anything in the internal memory of the T1. What I'm really worried about is if any of these bad sectors occur in other partitions of the T1's memory - then I suspect it'll be time for a new reader...

Cheers,
Simon.
snarkophilus is offline   Reply With Quote
Old 01-02-2013, 07:07 AM   #36
Teknikal
Evangelist
Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.Teknikal ought to be getting tired of karma fortunes by now.
 
Posts: 467
Karma: 3339234
Join Date: Jan 2012
Location: Belfast
Device: Sony T1, Nexus-7
I actually think Calibre converted books are the safest bet on the T1 if you want to avoid it crashing, I personally try and reconvert everything with calibre to get rid of any "bad/strange books" this is quite time consuming however so I recommend installing the calibre Quality Check Plugin.

I suggest using that to check for any books with oversize html files and reconverting them.
Teknikal is offline   Reply With Quote
Old 01-02-2013, 12:30 PM   #37
blazm
Junior Member
blazm doesn't litterblazm doesn't litter
 
Posts: 8
Karma: 124
Join Date: Jan 2013
Device: Sony PRS-T1
Hi guys, I have similar problems with PRS-T1 locking. I tried all sane recipes mentioned on the Internet without success... No way to cure the problem.

PROBLEM:
- OK: Power-on the reader from powered-off state.
- OK: Open any EPUB with stock reader app.
- OK: Everything works fine, dictionary works (try it multiple times).
- OK: Put reader in sleep mode.
- OK: Recover from sleep mode.
- OK: Continue to read book, go to home screen, select another book...
- ERROR: try to use dictionary during the reading. Reading app will lock, wait and force close.
OR
- ERROR: go to home screen and open the Dictionary app, it freezes when trying to enter the search word (or it will open the menu (button) but will freeze when you press any option).
- ERROR: in certain cases if you open the Dictionary app after this happens and you check the search history you will see long random strings like "aaaasdddddddddddddddddddssssssssssssss..." as your last search word (when the reading app froze).
- ERROR: once you use dictionary (in the reading app, stand-alone), the device will become unresponsive in other apps (apps will open but will generally fail when trying to do something).
- ERROR/OK: you can try to do shutdown within software and this will work most of the time (sometimes reset will be required),
- OK: after power-up from power-off state everything works fine... until next sleep...

I am guessing that this might be caused by bad NAND FLASH/MEMORY cell? When the device enters the sleep mode something goes wrong.

Best regards,

Blaz
blazm is offline   Reply With Quote
Old 01-02-2013, 12:59 PM   #38
blazm
Junior Member
blazm doesn't litterblazm doesn't litter
 
Posts: 8
Karma: 124
Join Date: Jan 2013
Device: Sony PRS-T1
I installed StabilityTest 2.7 through the Market app. Tried with power-off/power-on, no Wi-Fi mode. The test (Classic Stability Test) failed after 1 minute and 13 seconds (5 successful runs with RAM, 0 with CPU). App froze, Home button worked, Settings|Shutdown worked... Tried for the second time ( 22 sec, 1 RAM, 0 CPU)

Can somebody try the StabilityTest on working device, please? If it works fine this could indicate we are dealing with the HW issues and devices need to be replaced...

Thanks!
blazm is offline   Reply With Quote
Old 01-04-2013, 06:15 AM   #39
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
I think I have more information on this problem which might point in the direction of bad flash memory or corrupted data.

I am trying to do a full backup on linux in this manner:
1. Download the http://projects.mobileread.com/reade...upor-rescue.7z file
2. Enter recovery mode and plug usb cable.
3. Open a terminal and type:
Code:
sudo dd if=/dev/sdb of=prst1.bin bs=1024
The backup stops at 945Mb with the following message:

Code:
dd: reading `/dev/sdb': Input/output error
923056+0 records in
923056+0 records out
945209344 bytes (945 MB) copied, 108.162 s, 8.7 MB/s
I tried this three times in a row with exactly the same result.

Any ideas? Am I doing something wrong?

Last edited by entodoays; 01-04-2013 at 06:39 AM.
entodoays is offline   Reply With Quote
Old 01-05-2013, 08:28 AM   #40
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
I managed to do a full backup. First, on a Windows PC, I checked the Reader disk for bad sectors and it found some. It said it repaired it so I tried (back on Linux) to dd again. No luck, same results. I then formatted the Reader partition in linux to Fat32 (not a quick format), followed by "format internal memory" on the Reader. Tried dd command and it worked.
Then I backed up each individual partition individually as well.
I then checked each partition with
Code:
sudo fsck /dev/sdbX
where X is 1 through 10 (except 3, which is an extended partition). No errors reported but I got two warning messages for the Diag and fonts partitions:
Quote:
Warning: file extends past end of file system
. I did some googling and it seems this might be normal for cramfs file systems. Can anyone confirm?
I then ran
Code:
sudo badblocks -v /dev/sdb4 > bad-blocks4
for each partition and none were found.

Now that I can look at all the system contents, can someone indicate if there's anything to check for possible issues?

Also, I do not have a full backup of my unit before the problem started. I know that backups shouldn't be shared but I was thinking if it was possible to get backups of all partitions except the ones containing the unique information (serial number, etc).

P.S. I removed all the ebooks from my system except two to eliminate the possibility of a corrupt epub.

Last edited by entodoays; 01-05-2013 at 08:31 AM.
entodoays is offline   Reply With Quote
Old 01-05-2013, 08:45 AM   #41
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 37,268
Karma: 18149666
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Sony Reader PRS-650, iPad, nook STR
Given that your T1 is rooted, the thing to try is to remove the rooting and any partitioning so you put your T1 back to it's unrooted state. The way it was before you rooted. Then see if there's any problems with it.
JSWolf is online now   Reply With Quote
Old 01-06-2013, 08:07 AM   #42
dedgod
Enthusiast
dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.
 
Posts: 30
Karma: 15302
Join Date: Oct 2011
Device: Kindle PW2
blazm has accurately described the problem as I have seen it. I tried fix bad sectors using windows and it took hours to complete. I did report that it repaired some bad sectors. It still freezes when using the dictionary. I have only one book on it that was not made by calibre.

I agree with blazm that it looks like a flash memory problem. I guess I'll try doing the sector repair a few more times.
dedgod is offline   Reply With Quote
Old 01-07-2013, 02:18 AM   #43
blazm
Junior Member
blazm doesn't litterblazm doesn't litter
 
Posts: 8
Karma: 124
Join Date: Jan 2013
Device: Sony PRS-T1
Hi guy,

glad things are moving in promising direction; much better then just discussing whether rooting is at the root of the problem... I have send my device to be replaced since I only have few weeks left of warranty period. After being rooted, my device worked fine for about a month and then, well, you know the rest. I tried all possible approaches and the result was almost the same. The reasons that made me think this is not a software issue are:
- same result no mater what I did with software (reflash with existing version, restore old state - I had a backup, flash with new version, factory reset),
- StabilityTest failure; I really would like that somebody would confirm the test passes on good device,
- everything works before entering the sleep mode, then the problems start; I do not know the mechanism of sleep mode and what happens with memory content but I guess something happens. Or maybe there is even problem with CPU...

entodoays thanks; I was thinking of doing something like that (restoring dumps from other people to system partitions). Can you try the StabilityTest?

dedgod , I guess we are now all members of the same club...
blazm is offline   Reply With Quote
Old 01-07-2013, 06:55 AM   #44
dedgod
Enthusiast
dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.dedgod is as sexy as a twisted cruller doughtnut.
 
Posts: 30
Karma: 15302
Join Date: Oct 2011
Device: Kindle PW2
How fortunate that yours is in warranty. Doing the sector repair in windows did not help. I hadn't tested the angle of coming out of sleep but I will.
dedgod is offline   Reply With Quote
Old 01-09-2013, 09:39 AM   #45
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
I have more information. I tried to "restore" the backup I had done earlier (post #40) to a blank microSD card (not to the Reader). I was astonished to find out that the new partition table on the card was not identical to the Reader's partition table. There were at least 3 differences:
  1. The Reader partition table started with a 26Mb free space. This was not replicated on the restored card.
  2. The System partition was MISSING completely!
  3. The Data partition was also missing and, instead of these two partitions, I got unpartitioned space.
Could this point to a possible problem with the partition table on my Reader in the first place? I do have a separate disk image for each partition (not the initial free space though), but I'm afraid of doing anything, being afraid of bricking my Reader completely.

Furthermore, I have actually unrooted it again and tried, unsuccessfully, to do another backup. The backup would stop at 39 Mb, that is in the middle of the Diag partition. This is very worrying and I was ready to send it for repairs but I'm afraid that repairing it would cost too much (postage, repair, resend) so if anyone could give me a clue on what could be done (if there's anything that could be done) I would be very grateful.
entodoays is offline   Reply With Quote
Reply

Tags
amr, hanging, prst1, sony

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-T1 PRS-T1 stuck off and unresponsive...but no serial to return samadam Sony Reader 3 06-15-2012 12:13 PM
PRS-350 Unresponsive Buttons mer10 Sony Reader 9 04-05-2012 04:41 PM
PRS-350 sony prs 350: blank unresponsive screen, blinking orange light halipleumon Sony Reader 5 05-30-2011 06:49 AM
Unresponsive Prs-505 Reader 101 Sony Reader 1 09-15-2008 04:19 AM
Unresponsive honeybunny Amazon Kindle 8 07-17-2008 05:18 PM


All times are GMT -4. The time now is 04:05 PM.


MobileRead.com is a privately owned, operated and funded community.