Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Kobo Reader > Kobo Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 11-11-2012, 01:06 PM   #1
vlad59
Addict
vlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five words
 
Posts: 352
Karma: 37761
Join Date: Sep 2011
Device: Kobo eReader Touch, Kobo Aura HD
Compile Plugin and koboreader

Hi,

I tried today to compile the Kobo repository on github following this howto : http://www.mobileread.com/forums/sho...d.php?t=185680.

The install of sourcery g++ went fine.

The first components in the build of koboreader are compiling fine but qt is compiled with my g++ (amd64) and not the arm one so the linking fails after.

Is there some known tweak to fix it ?

My ultimate goal is to compile the plugin (http://code.google.com/p/kobo-plus/). there is no howto on the wiki ? can anyone help me in there ?

Thanks in advance.
vlad59 is offline   Reply With Quote
Old 11-11-2012, 03:13 PM   #2
ikarus9999
Connoisseur
ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'
 
Posts: 88
Karma: 39373
Join Date: Apr 2003
Location: Austria
Device: Kobo Touch
Quote:
Originally Posted by vlad59 View Post
Hi,

I tried today to compile the Kobo repository on github following this howto : http://www.mobileread.com/forums/sho...d.php?t=185680.

The install of sourcery g++ went fine.

The first components in the build of koboreader are compiling fine but qt is compiled with my g++ (amd64) and not the arm one so the linking fails after.

Is there some known tweak to fix it ?

My ultimate goal is to compile the plugin (http://code.google.com/p/kobo-plus/). there is no howto on the wiki ? can anyone help me in there ?

Thanks in advance.
There is a small howto in the wiki (http://code.google.com/p/kobo-plus/wiki/GettingStarted)
You have to be aware that for building the kobo-plus plugin you have to use Qt 4.8.0.

What kind of linker error are you getting?
ikarus9999 is online now   Reply With Quote
Old 11-14-2012, 11:37 AM   #3
sergeyvl12
ebook fan
sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.
 
Posts: 563
Karma: 2518608
Join Date: Dec 2010
Device: PocketBook 301+, Kindle 3 Wi-Fi, Onyx Boox A62, Kindle Touch
Quote:
Originally Posted by ikarus9999 View Post
There is a small howto in the wiki (http://code.google.com/p/kobo-plus/wiki/GettingStarted)
You have to be aware that for building the kobo-plus plugin you have to use Qt 4.8.0.

What kind of linker error are you getting?
Thanks, ikarus9999!

I've managed to compile Qt 4.8.0 and example plugin (libVideoPoker.so).

Could you explain please (I have no Kobo reader yet but I have a person who is ready to test my app)

http://www.mobileread.com/forums/sho...d.php?t=196589

1. How can I install this plugin to Kobo? How can I run it?
2. Do I need to install some kind of jailbreaks for Kobo to run my plugin?
3. What's the known limitations/restrictions to plugins?
4. What's the path to kobo flash memory? (e.g. on Kindle this path is /mnt/us)
5. Can I compile and run usual executable Qt app (not a plugin).

Thanks for help!
sergeyvl12 is offline   Reply With Quote
Old 11-14-2012, 03:03 PM   #4
ikarus9999
Connoisseur
ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'ikarus9999 can spell AND pronounce 'liseuse.'
 
Posts: 88
Karma: 39373
Join Date: Apr 2003
Location: Austria
Device: Kobo Touch
Quote:
Originally Posted by sergeyvl12 View Post
Thanks, ikarus9999!

1. How can I install this plugin to Kobo? How can I run it?
2. Do I need to install some kind of jailbreaks for Kobo to run my plugin?
3. What's the known limitations/restrictions to plugins?
4. What's the path to kobo flash memory? (e.g. on Kindle this path is /mnt/us)
5. Can I compile and run usual executable Qt app (not a plugin).

Thanks for help!
1) Plugins can be installed by creating a archive named 'Kobo.tgz' (plugin as the only content). Copy the 'Kobo.tgz' file to the '.kobo' directory on the reader (if you connect it via USB to the PC). Eject the reader and the plugin should be installed automatically. To run the plugin you have to open a book (epub) after reader startup. As long as you don't shutdown the reader (only sleep mode) the plugin stays active.

2) NO. For easier debugging and so on you could install SSH and Telnet on the reader but it's not necessary for running the plugin.

3) Plugins can fully use QT Widgets. The 'HOME' button always takes you back to the Reader Homescreen.

4) '/mnt/onboard/'

5) Yes you can but you have to implement the eink driver interface for QT first. There is already a implementation here at mobileread.
http://www.mobileread.com/forums/sho...d.php?t=187241

You also have to kill 'nickel' before starting your application. After exiting your application you have to restart 'nickel' (the correct way can be found here in the forum).

Hope this helps a little bit.
ikarus9999 is online now   Reply With Quote
Old 11-15-2012, 01:21 PM   #5
sergeyvl12
ebook fan
sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.
 
Posts: 563
Karma: 2518608
Join Date: Dec 2010
Device: PocketBook 301+, Kindle 3 Wi-Fi, Onyx Boox A62, Kindle Touch
Thanks! Your answer is very helpful!

Quote:
Originally Posted by ikarus9999
You also have to kill 'nickel' before starting your application. After exiting your application you have to restart 'nickel' (the correct way can be found here in the forum).
Sorry... didn't find how to kill/restart nickel. Also how can I start my application / script which is not a plugin?

Last edited by sergeyvl12; 11-15-2012 at 01:35 PM.
sergeyvl12 is offline   Reply With Quote
Old 11-19-2012, 04:17 AM   #6
vlad59
Addict
vlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five words
 
Posts: 352
Karma: 37761
Join Date: Sep 2011
Device: Kobo eReader Touch, Kobo Aura HD
Sorry for my late answer.

As I stated in my original post, I tried to compile the all Kobo_reader package from github.

I tried to follow the wiki and got stuck with qt compile. The script try to compile qt 4.6.2. The problem

QT 4.8 is also on the repository, I can try to compile it with same parameters. Do I need to apply the patch in Kobo-Reader / patches / qt-everywhere-opensource-src-4.8.0_kobo.patch ?

Thanks in advance.
vlad59 is offline   Reply With Quote
Old 11-19-2012, 04:24 AM   #7
sergeyvl12
ebook fan
sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.
 
Posts: 563
Karma: 2518608
Join Date: Dec 2010
Device: PocketBook 301+, Kindle 3 Wi-Fi, Onyx Boox A62, Kindle Touch
Quote:
Originally Posted by vlad59 View Post
Sorry for my late answer.

As I stated in my original post, I tried to compile the all Kobo_reader package from github.

I tried to follow the wiki and got stuck with qt compile. The script try to compile qt 4.6.2. The problem

QT 4.8 is also on the repository, I can try to compile it with same parameters. Do I need to apply the patch in Kobo-Reader / patches / qt-everywhere-opensource-src-4.8.0_kobo.patch ?

Thanks in advance.
I think you need just replace 4.6.2 with 4.8.0 in qt.sh:

ARCHIVE=qt-everywhere-opensource-src-4.8.0.tar.gz
ARCHIVEDIR=qt-everywhere-opensource-src-4.8.0

and the patch should be applied automatically.
sergeyvl12 is offline   Reply With Quote
Old 11-19-2012, 04:39 PM   #8
vlad59
Addict
vlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five wordsvlad59 can name that ebook in five words
 
Posts: 352
Karma: 37761
Join Date: Sep 2011
Device: Kobo eReader Touch, Kobo Aura HD
Found my problem (at least for now). I was missing some dependencies : libdbus-1 libxevt-dev
vlad59 is offline   Reply With Quote
Old 01-02-2013, 05:21 AM   #9
sergeyvl12
ebook fan
sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.sergeyvl12 ought to be getting tired of karma fortunes by now.
 
Posts: 563
Karma: 2518608
Join Date: Dec 2010
Device: PocketBook 301+, Kindle 3 Wi-Fi, Onyx Boox A62, Kindle Touch
Can I add a plugin without manual editing of KoboReader.sqlite?

For now this is the only way to get libHelloKobo.so work for me. I changed the MIME TYPE to "application/x-games-hellokobo" in one epub file (table: contents). But this solution looks ugly...

Another problem is that user input doesn't work. So, the only purpose from plugin is to start a standalone Qt application for now ...

Last edited by sergeyvl12; 01-02-2013 at 03:52 PM.
sergeyvl12 is offline   Reply With Quote
Old 01-03-2013, 12:25 PM   #10
koenieee
Enthusiast
koenieee doesn't litterkoenieee doesn't litterkoenieee doesn't litter
 
Posts: 49
Karma: 208
Join Date: Nov 2012
Device: Kobo Glo
I'm looking for the same, does anybody know something about that?
koenieee is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plugin not customizable: Plugin: HTML Output does not need customization flyingfoxlee Conversion 2 02-24-2012 03:24 AM
[GUI Plugin] Plugin Updater **Deprecated** kiwidude Plugins 159 06-19-2011 01:27 PM
Koboreader.sqlite gundged maxwelledison Kobo Reader 21 01-12-2011 09:24 AM
New Plugin Type Idea: Library Plugin cgranade Plugins 3 09-15-2010 01:11 PM
Who can compile a .c program for me? owl123 Workshop 14 04-19-2009 05:26 AM


All times are GMT -4. The time now is 02:58 PM.


MobileRead.com is a privately owned, operated and funded community.