Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Library Management

Notices

Reply
 
Thread Tools Search this Thread
Old 10-10-2012, 03:22 PM   #1
Greygor
Junior Member
Greygor began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2012
Device: Samsung Tab 2 GT-P3110
Unhappy Books no longer Showing as "On Device"

I transferred a lot of books last night and they showed as "OnDevice" in the correct location.

Today I reconnected and they are no longer showed as "OnDevice".

The physical files are there and in the right place but Calibre doesn't know it.

Other books are still showing correctly.

Any thoughts

Calibre 0.9.1

Tablet Samsung Galaxy Tab 2 7" GT-P3110


If I think back this has happened before and the only solution was to remove from device and resend
Greygor is offline   Reply With Quote
Old 10-10-2012, 03:34 PM   #2
DaMastah
Member
DaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it is
 
Posts: 17
Karma: 2086
Join Date: Jun 2012
Device: Kobo Glo
I have the same problem on my Kobo Glo, Happened before on my Kobo Touch also.
Seems to always happen with the same books.
DaMastah is offline   Reply With Quote
Old 10-10-2012, 03:38 PM   #3
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 15,267
Karma: 6020309
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by DaMastah View Post
I have the same problem on my Kobo Glo, Happened before on my Kobo Touch also.
Seems to always happen with the same books.
Are you waiting for all the 'Jobs' to finish after sending the book(s)?
The (devices) book list is sent after the book.
Use eject and wait for 'Safely disconnect' or the on device Tickmark row to hide
theducks is offline   Reply With Quote
Old 10-10-2012, 03:39 PM   #4
DaMastah
Member
DaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it is
 
Posts: 17
Karma: 2086
Join Date: Jun 2012
Device: Kobo Glo
Yes done that.

Really happens always on the same books so I think it's a bug.
DaMastah is offline   Reply With Quote
Old 10-10-2012, 04:01 PM   #5
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,436
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
If you think it is linked to specific file(s) open a bug report and attach the said files. The only way that this can happen that I know of is if you change the title and/or author of the book in calibre after sending it to the device and the metadata.calibre on your device gets corrupted.
kovidgoyal is offline   Reply With Quote
Old 10-10-2012, 05:09 PM   #6
DaMastah
Member
DaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it isDaMastah knows what time it is
 
Posts: 17
Karma: 2086
Join Date: Jun 2012
Device: Kobo Glo
I reverted my Kobo to factory defaults which formatted the unit and tried to reproduce the problem.

The problem definitely reappeared. I think it has maybe something to do with the metadata plugboards.

I used the steps described here (http://www.mobileread.com/forums/sho...d.php?t=193184) to include series order on the titles of my books (which is great with shelves).
I used {series_index:0>2s|| - }{title} -> title.
So maybe Calibre can't match all the titles now (though it definitely works with most of the books in the series, always the same ones are missing).

Is it the intended functionality ?
DaMastah is offline   Reply With Quote
Old 10-10-2012, 07:13 PM   #7
Greygor
Junior Member
Greygor began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2012
Device: Samsung Tab 2 GT-P3110
Quote:
Originally Posted by theducks View Post
Are you waiting for all the 'Jobs' to finish after sending the book(s)?
The (devices) book list is sent after the book.
Use eject and wait for 'Safely disconnect' or the on device Tickmark row to hide
Yes, because after it finishes sending my tablet shows the syncing screen so I can't do anything.

Then in Mantano I import them and add them to the right collection.
Greygor is offline   Reply With Quote
Old 10-10-2012, 07:18 PM   #8
Greygor
Junior Member
Greygor began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2012
Device: Samsung Tab 2 GT-P3110
Quote:
Originally Posted by DaMastah View Post
I reverted my Kobo to factory defaults which formatted the unit and tried to reproduce the problem.

The problem definitely reappeared. I think it has maybe something to do with the metadata plugboards.

I used the steps described here (http://www.mobileread.com/forums/sho...d.php?t=193184) to include series order on the titles of my books (which is great with shelves).
I used {series_index:0>2s|| - }{title} -> title.
So maybe Calibre can't match all the titles now (though it definitely works with most of the books in the series, always the same ones are missing).

Is it the intended functionality ?
I use the plugboard to retitle my books with the series, but I do that for all of them and not all are affected by this issue. And I use the same plugboard config for all.
Greygor is offline   Reply With Quote
Old 10-10-2012, 08:43 PM   #9
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 6,090
Karma: 6238033
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo Touch, Kobo Glo
Quote:
Originally Posted by DaMastah View Post
I reverted my Kobo to factory defaults which formatted the unit and tried to reproduce the problem.

The problem definitely reappeared. I think it has maybe something to do with the metadata plugboards.

I used the steps described here (http://www.mobileread.com/forums/sho...d.php?t=193184) to include series order on the titles of my books (which is great with shelves).
I used {series_index:0>2s|| - }{title} -> title.
So maybe Calibre can't match all the titles now (though it definitely works with most of the books in the series, always the same ones are missing).

Is it the intended functionality ?
It should work. The plugboard I use has the series name in it as well but it should work with both. Can you try sending one of the problem books to the Glo without deleting it first. Then disconnect the Glo, check the book is there and reconnect to see if calibre shows it n the device.

What does the device list show for the title of these books? Is the title the same as in the library, or is it the plugboard modified version?

Last edited by davidfor; 10-10-2012 at 09:16 PM. Reason: Added quesiton about the device list
davidfor is offline   Reply With Quote
Old 10-12-2012, 11:08 AM   #10
Greygor
Junior Member
Greygor began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2012
Device: Samsung Tab 2 GT-P3110
So far the only solution I have is to delete the books from my reader on the tablet and resend from Calibre. They now appear and have reappeared each time I connect to my tablet.

However, in correcting this I've noticed one thing. When searching for books on device it doesn't restrict itself to the folders you have specified.

Wouldn't it be more efficient/quicker only to search the folders you've specified instead of going through all my mp3's and films as well?
Greygor is offline   Reply With Quote
Old 10-12-2012, 04:35 PM   #11
MikeFox455
Junior Member
MikeFox455 began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Oct 2012
Device: Android 2.1 Tablet
I get this problem too. All my books were shown as 'on device' with 0.9.0 but on 0.9.1 and now with 0.9.2 about half of them are not shown as 'on device' when I haven't loaded or removed any books to the device.

As Greygor suggests I think it is something to do with using a metadata plugboard but I can't work out a pattern or reason. Like him I use a plugboard to put series information in the title. Some books in a series appear on the device OK other do not. For some a entire series is shown as 'on device', for others the whole series is not shown as "on device". They were all loaded to the device at the same time and all previous appeared in the library as "on device".
MikeFox455 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Previously imported books not showing as "on device" bowieb Library Management 1 10-02-2012 03:44 PM
Books "In Library" and "On Device" but not linked stevehuth Library Management 4 07-20-2012 02:20 AM
PRS-T1 "Google Books are no longer available via Reader Store" tomsem Sony Reader 10 03-03-2012 08:57 PM
Kindle 3 not showing "new" next to newly added books WDeranged Amazon Kindle 4 01-30-2012 08:10 PM
Nook Books Not Showing as "On Device" wawasteele Calibre 4 11-08-2010 10:29 PM


All times are GMT -4. The time now is 05:15 PM.


MobileRead.com is a privately owned, operated and funded community.