Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 10-10-2012, 01:25 PM   #1
ictstbenedicts
Junior Member
ictstbenedicts began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Oct 2012
Device: kindle
Calibre 2 behind Windows Proxy Server

I'm running Windows 7, have installed Calibre but can not connect to the internet. The problem is that Calibre is not detecting the proxy server settings

From the command prompt entering

C:\Program Files\Calibre2> calibre-debug -c "from calibre import get_
nt get_proxies()"


I get:

Using proxies: {'ftp': 'proxy:8080', 'http': 'proxy:8080', 'https':
}
{'ftp': 'proxy:8080', 'http': 'proxy:8080', 'https': 'proxy:8080'}


which is incorrect for my network

According to the FAQ http://manual.calibre-ebook.com/faq....-my-http-proxy , it says:

for example, on windows if you don’t use Internet Explorer then the proxy settings may not be up to date. You can tell calibre to use a particular proxy server by setting the http_proxy environment variable. The format of the variable is: http://usernameassword@servername you should ask your network admin to give you the correct value for this variable.

What it does not say is where the http_proxy environmental variable is located. It does not appear as a Windows environmental valable when entering set from the command prompt.

Please advise, our school library has just purchased 3x Kindles and Calibre appears to be an excellent program to help them resolve their problems managing them. If we can get it to connect to the internet, that would be excellent.
ictstbenedicts is offline   Reply With Quote
Old 10-10-2012, 01:41 PM   #2
PeterT
Taking a break; Fed up
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 7,347
Karma: 46281507
Join Date: Nov 2007
Location: Toronto
Device: Wife: Touch, Arc, Vox Me: Nexus 7, Glo
Try going to Control Panel | System & Security | System or
Control Panel | System
then Advanced System Settings | Environment variables then under the System Variables section select New and type http_proxy for variable name and the correct value in variable value.

This will set a system wide variable http_proxy.

The next time you start calibre that value will be in effect.

You could also set it as a user variable for the current user.
PeterT is offline   Reply With Quote
Reply

Tags
calibre, proxy, windows 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre Content Server and Windows Home Server 2011 HughMcC Calibre 8 10-01-2014 08:26 AM
Unreadable epub Calibre-Server not Windows zeroday Calibre 4 08-24-2012 11:27 PM
Automatic startup of calibre-server on Windows zzmijarevic Calibre 17 04-02-2012 05:26 AM
Using calibre in a proxy. fetching metadata proxy authentication required shiftymorgan Calibre 8 05-13-2011 04:45 AM
Issue with Calibre Server - Windows jawadams Calibre 13 01-13-2011 07:51 AM


All times are GMT -4. The time now is 07:24 PM.


MobileRead.com is a privately owned, operated and funded community.