Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 09-28-2012, 08:07 AM   #1
edebill
Junior Member
edebill began at the beginning.
 
Posts: 6
Karma: 10
Join Date: May 2011
Device: kindle paperwhite, kobo mini, kobo aura hd, nexus 5, nexus 7, ipad air
[Android App] Can't start wireless device on OS X 10.8.2

I'm trying to use the wireless device to sync with Calibre Companion on a Nexus 7. When I try to enable the wireless device, it fails saying "registration with bonjour failed". Any suggestions for getting past this would be welcome. Likewise, if there's anything I can do to help debug the problem, I'm all ears.

Regards,
Erik

-- log from connection failed pop
calibre, version 0.9.0
ERROR: Problem starting the wireless device: The wireless device driver did not start. It said "registration with bonjour failed"



-- actual debug log
calibre Debug log
calibre 0.9.0
Darwin-12.2.0-x86_64-i386-64bit Darwin
('Darwin', '12.2.0', 'Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64')
Python 2.7.3
OSX: ('10.8.2', ('', '', ''), 'x86_64')
Starting up...
Started up in 12.42 seconds with 331 books
SMART_DEV ( 0.00: 0.001) startup_on_demand All IP addresses {'en1': [{'broadcast': '172.16.1.255', 'netmask': '255.255.255.0', 'addr': '172.16.1.10'}], 'lo0': [{'peer': '127.0.0.1', 'netmask': '255.0.0.0', 'addr': '127.0.0.1'}]}
SMART_DEV ( 0.20: 0.001) _attach_to_port try ip address "" on port 9004
SMART_DEV ( 0.45: 0.204) startup_on_demand registration with bonjour failed
edebill is offline   Reply With Quote
Old 09-28-2012, 08:37 AM   #2
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,809
Karma: 12535517
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by edebill View Post
I'm trying to use the wireless device to sync with Calibre Companion on a Nexus 7. When I try to enable the wireless device, it fails saying "registration with bonjour failed". Any suggestions for getting past this would be welcome.
I don't have a Mac, but have you thoroughly gone through the FAQ?

Last edited by DoctorOhh; 09-28-2012 at 08:41 AM.
DoctorOhh is online now   Reply With Quote
Old 09-28-2012, 11:13 AM   #3
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,262
Karma: 821512
Join Date: Jan 2010
Location: France
Device: Many android devices
The best guess I can make is that some security setting is preventing your Mac from using multicast. Why this would be I cannot say. Alternatively, the Bonjour components might not be installed. This would surprise me given that Bonjour is Apple-made, but I suppose it is possible. Last idea: port 9004 might be somehow reserved and unusable with bonjour.

The first thing I would try is change the port to something like 12445 just to see if that makes the problem go away. If it does, then you will need to experiment with port numbers to find one that both you like and is usable on your mac. I don't have a Mac so I can't give many more hints. I suggest that you google for "enabling multicast" or some such.

Thinking about it, the wireless system can work even if bonjour registration is not successful. I will change the driver not to give up in this case. The change won't appear in a release for a week unless you run from source.
chaley is offline   Reply With Quote
Old 09-28-2012, 11:40 AM   #4
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,262
Karma: 821512
Join Date: Jan 2010
Location: France
Device: Many android devices
BTW: be sure that the port used for the wireless driver and the content server are not the same. That could cause bonjour problems, and will certainly cause connection problems.
chaley is offline   Reply With Quote
Old 09-29-2012, 06:51 AM   #5
wn1ytw
Member
wn1ytw began at the beginning.
 
Posts: 24
Karma: 10
Join Date: May 2011
Device: kindle
same problem

I am having the same problem.
I do not know what or where bonjour is on my iMac running OSx 10.8.2 and Calibre 0.9 with a Asuds Transformer TF101 and ICS 4.0.3
Sorry to be a noob
scott

Last edited by wn1ytw; 09-29-2012 at 06:58 AM. Reason: more info
wn1ytw is offline   Reply With Quote
Old 09-29-2012, 06:58 AM   #6
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,262
Karma: 821512
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by wn1ytw View Post
I am having the same problem.
I do not know what or where bonjour is on my iMac running OSx 10.8.2 and Calibre 0.9
Sorry to be a noob
scott
Please start calibre in debug mode by clicking on the little down-arrow on the Preferences button then choosing "Restart in debug mode". Once calibre restarts, verify that the content server is not running (the Connect/Share menu), then stop and restart the wireless connection (again, using Connect/Share). Close calibre and post the debug log that will be displayed when calibre closes.
chaley is offline   Reply With Quote
Old 09-29-2012, 07:12 AM   #7
wn1ytw
Member
wn1ytw began at the beginning.
 
Posts: 24
Karma: 10
Join Date: May 2011
Device: kindle
Traceback (most recent call last):
File "site-packages/calibre/customize/ui.py", line 532, in initialize_plugins
File "site-packages/calibre/customize/ui.py", line 54, in load_plugin
File "site-packages/calibre/customize/zipplugin.py", line 169, in load
File "lib/python2.7/importlib/__init__.py", line 37, in import_module
File "site-packages/calibre/customize/zipplugin.py", line 150, in load_module
File "calibre_plugins.dummy1.__init__", line 18, in <module>
ImportError: No module named fetch
calibre Debug log
calibre 0.9.0
Darwin-12.2.0-x86_64-i386-64bit Darwin
('Darwin', '12.2.0', 'Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64')
Python 2.7.3
OSX: ('10.8.2', ('', '', ''), 'x86_64')
Failed to initialize plugin: '/Users/n1sp1/Library/Preferences/calibre/plugins/LibraryThing.zip'
Starting up...
Started up in 28.55 seconds with 27017 books
SMART_DEV ( 0.00: 0.000) startup_on_demand All IP addresses {'en0': [{'broadcast': '10.0.1.255', 'netmask': '255.255.255.0', 'addr': '10.0.1.2'}], 'en1': [{'broadcast': '167.20.92.255', 'netmask': '255.255.255.0', 'addr': '167.20.92.58'}], 'lo0': [{'peer': '127.0.0.1', 'netmask': '255.0.0.0', 'addr': '127.0.0.1'}]}
SMART_DEV ( 0.12: 0.001) _attach_to_port try ip address "" on port 18107
SMART_DEV ( 10.35: 10.205) startup_on_demand registration with bonjour failed
SMART_DEV ( 0.00: 0.000) startup_on_demand All IP addresses {'en0': [{'broadcast': '10.0.1.255', 'netmask': '255.255.255.0', 'addr': '10.0.1.2'}], 'en1': [{'broadcast': '167.20.92.255', 'netmask': '255.255.255.0', 'addr': '167.20.92.58'}], 'lo0': [{'peer': '127.0.0.1', 'netmask': '255.0.0.0', 'addr': '127.0.0.1'}]}
SMART_DEV ( 0.04: 0.001) _attach_to_port try ip address "" on port 20404
SMART_DEV ( 10.29: 10.203) startup_on_demand registration with bonjour failed
wn1ytw is offline   Reply With Quote
Old 09-29-2012, 07:23 AM   #8
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,262
Karma: 821512
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by wn1ytw View Post
Traceback (most recent call last):
SMART_DEV ( 0.00: 0.000) startup_on_demand All IP addresses {'en0': [{'broadcast': '10.0.1.255', 'netmask': '255.255.255.0', 'addr': '10.0.1.2'}], 'en1': [{'broadcast': '167.20.92.255', 'netmask': '255.255.255.0', 'addr': '167.20.92.58'}], 'lo0': [{'peer': '127.0.0.1', 'netmask': '255.0.0.0', 'addr': '127.0.0.1'}]}
SMART_DEV ( 0.04: 0.001) _attach_to_port try ip address "" on port 20404
SMART_DEV ( 10.29: 10.203) startup_on_demand registration with bonjour failed
It appears that your computer has two valid IP addresses, 10.0.1.2 and 167.20.92.58. Do you have a VPN (Virtual Private Network) installed? VPNs are known to cause problems.

One thing you can try that might help, but I am not hopeful if you have a VPN. Go to Preferences -> Plugins -> Device Interface Plugins and scroll down until you see Smartdevice App Interface. Double-click the puzzle piece next to that name. A configuration dialog will open. On the bottom right you will see a box labeled "Use this IP address". Put 10.0.1.2 into that box and press OK. Restart calibre and see if the wireless device can start.
chaley is offline   Reply With Quote
Old 09-29-2012, 08:05 AM   #9
wn1ytw
Member
wn1ytw began at the beginning.
 
Posts: 24
Karma: 10
Join Date: May 2011
Device: kindle
No Joy in Mudville :-(
I used 10.0.1.2 in the plugin, the start wireless connection menu has a red dot.. is there something I need to enable in network sharing to get this to work? Pardon me, but I know very little about network stuff...
I CAN use the content server however....

I do not use VPN, but I do use a WIFI connection that is more like using a hotspot
wn1ytw is offline   Reply With Quote
Old 09-29-2012, 08:13 AM   #10
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,809
Karma: 12535517
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by wn1ytw View Post
I CAN use the content server however....
What IP address do you use for the content server?
DoctorOhh is online now   Reply With Quote
Old 09-29-2012, 08:20 AM   #11
wn1ytw
Member
wn1ytw began at the beginning.
 
Posts: 24
Karma: 10
Join Date: May 2011
Device: kindle
I did try using the other IP address... the red dot is still there
wn1ytw is offline   Reply With Quote
Old 09-29-2012, 08:23 AM   #12
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,809
Karma: 12535517
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by wn1ytw View Post
Quote:
Originally Posted by DoctorOhh View Post
What IP address do you use for the content server?
I did try using the other IP address... the red dot is still there
So what IP address do you use for the content server?
DoctorOhh is online now   Reply With Quote
Old 09-29-2012, 08:23 AM   #13
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,262
Karma: 821512
Join Date: Jan 2010
Location: France
Device: Many android devices
First, did you restart calibre after changing the IP address in the plugin? That is required for anything good to happen.

If you restarted calibre and it doesn't work, then I am sure that the problem comes from the IP address 167.20.92.58. This is a public IP address (directly on the internet), and it is not surprising that bonjour refuses to work with that. Apple wouldn't want random folks around the world using your printer. Question: do you really want your computer to be directly connected to the internet?

I have made a change to the wireless connection driver (the Smartapp Interface) to ignore bonjour errors. This change will be available in the next calibre release, that is in a week. If you don't want to wait that long, something I certainly understand, then contact Steven (my son) for a refund for CC. You can send him email from within CC. Click on the menu "button" (the three dots), select Help, then tap Email. Give him the purchase information (at least the google play account name and approximate purchase time. The transaction ID would be helpful) and he will refund your money.

FYI: the content server already ignores bonjour errors, which is why it works in this situation.
chaley is offline   Reply With Quote
Old 09-29-2012, 08:24 AM   #14
wn1ytw
Member
wn1ytw began at the beginning.
 
Posts: 24
Karma: 10
Join Date: May 2011
Device: kindle
Quote:
Originally Posted by DoctorOhh View Post
What IP address do you use for the content server?
I'm trying to find that in settings but if memory serves(no pun intended) it is 167.20.92.58
wn1ytw is offline   Reply With Quote
Old 09-29-2012, 08:30 AM   #15
wn1ytw
Member
wn1ytw began at the beginning.
 
Posts: 24
Karma: 10
Join Date: May 2011
Device: kindle
Talking

Quote:
Originally Posted by chaley View Post
First, did you restart calibre after changing the IP address in the plugin? That is required for anything good to happen.

If you restarted calibre and it doesn't work, then I am sure that the problem comes from the IP address 167.20.92.58. This is a public IP address (directly on the internet), and it is not surprising that bonjour refuses to work with that. Apple wouldn't want random folks around the world using your printer. Question: do you really want your computer to be directly connected to the internet?

I have made a change to the wireless connection driver (the Smartapp Interface) to ignore bonjour errors. This change will be available in the next calibre release, that is in a week. If you don't want to wait that long, something I certainly understand, then contact Steven (my son) for a refund for CC. You can send him email from within CC. Click on the menu "button" (the three dots), select Help, then tap Email. Give him the purchase information (at least the google play account name and approximate purchase time. The transaction ID would be helpful) and he will refund your money.

FYI: the content server already ignores bonjour errors, which is why it works in this situation.

I really don't have much choice. I'm a patient in a nursing home using their WIFI.. I can wait a week I'm patient (pun intended)
No need for a refund.
Thank you
scott
wn1ytw is offline   Reply With Quote
Reply

Tags
calibre, mac, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Android App] Coming: Android app to connect as a device to calibre using wifi chaley Devices 92 09-07-2012 08:24 PM
[Android App] Beta version: Android app to connect as a device to calibre using wifi chaley Devices 116 08-27-2012 12:42 PM
Kobo App on Android Device iGregory Kobo Reader 0 01-31-2012 10:04 PM
calibre - send to device - android running Nook App. Mad_Robot Devices 6 10-16-2011 01:49 PM
Android app for reading web articles with Kindle (app and device) fivefilters Android Devices 0 07-02-2011 09:29 PM


All times are GMT -4. The time now is 06:47 AM.


MobileRead.com is a privately owned, operated and funded community.