Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 12-09-2011, 08:58 AM   #1
joebie13
Junior Member
joebie13 began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Dec 2011
Device: PRS-T1
Gentoo problem with error :No device connected

I've tried version 8.24 provided with gentoo through an ebuild and I've tried 8.30 compiled from source. With both versions I encounter the error "No device connected" while being able to read the books from the device. But not send books to the PRS-T1.

I've started the debugger in eclipse and found in the file gui2/device.py close to line 794 in the function "device_detected" the line
"""
self.set_default_thumbnail(\
self.device_manager.device.THUMBNAIL_HEIGHT)
"""

This line causes the function to return and not set the variable self.device_connected.
When I comment out this line, Calibre work fine.

I presume this is not a bug but specifically a problem with my gentoo install. Am I missing a dependency, perhaps a missing file type support?

I also get an error when downloading news I've attached the output.
Attached Files
File Type: txt CalibreError.txt (14.4 KB, 72 views)
joebie13 is offline   Reply With Quote
Old 12-09-2011, 09:04 AM   #2
frostschutz
Linux User
frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.frostschutz ought to be getting tired of karma fortunes by now.
 
frostschutz's Avatar
 
Posts: 743
Karma: 2031399
Join Date: Sep 2010
Device: iriver Story HD
Gentoo doesn't provide 8.24, at least, not anymore.

Code:
$ ls -l /usr/portage/app-text/calibre/
total 52
-rw-r--r-- 1 root root 28162 Dec  5 20:01 ChangeLog
-rw-r--r-- 1 root root  1424 Dec  5 20:01 Manifest
-rw-r--r-- 1 root root  5495 Nov 25 17:43 calibre-0.8.28.ebuild
-rw-r--r-- 1 root root  5495 Dec  5 19:49 calibre-0.8.29.ebuild
-rw-r--r-- 1 root root   340 Nov 15 17:01 metadata.xml
Both 8.28/29 detect my device properly. Maybe your Gentoo is not updated?
frostschutz is offline   Reply With Quote
Reply

Tags
news, no device connected, prs-t1

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
calibre, version 0.8.8 ERROR: Error: Error communicating with device no such column: e-bookuser Devices 1 07-03-2011 04:09 PM
Device management really slow when device = connected folder nickdma Calibre 5 12-27-2010 02:41 PM
No device is connected error gerardpy Calibre 1 12-09-2010 10:49 AM
No device connected error Sony PRS-505 b_knits Calibre 7 02-23-2010 09:32 PM
No device is connected pope_a Calibre 18 09-20-2009 12:29 PM


All times are GMT -4. The time now is 01:41 AM.


MobileRead.com is a privately owned, operated and funded community.