Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive

Notices

 
 
Thread Tools Search this Thread
Old 09-01-2010, 05:10 AM   #1
miklos.klaar
Edge User
 
Application can not be installed - unable to install apps after Dingo

I am unable to install/upgrade some applications after the installation of Dingo. Specifically both:

Lastpass
Better Terminal Emulator Pro

will not install and the edge is telling me: Application cannot be installed.

Did the keys/certs for Dingo change? Anyone else having this problem. I also un-checked and re-checked the non-market app setting just to make sure. Also did a restart with no avail.

Thanks in Advance.
 
Old 09-01-2010, 06:27 AM   #2
miklos.klaar
Edge User
 
I fixed this by rooting the device and removing the crust of old installs from /data/app and then reinstalling. For whatever reason, the application installer did not remove the old version.

Perhaps it's better to uninstall an application before upgrading it.
 
Old 09-01-2010, 09:03 AM   #3
borisb
Edge User
 
Quote:
Originally Posted by miklos.klaar View Post
Perhaps it's better to uninstall an application before upgrading it.
I was just about to suggest that. It seems to be a common issue where installing an upgrade doesn't work without first uninstalling the old version. So, my rule of thumb is that when upgrading an app, uninstall the old version first.
 
Old 09-01-2010, 09:24 AM   #4
VenturingSoul
Edge User
 
I have a Droid phone, and it exhibits the same behavior on some but not all apps. As soon as I get the message that the app cannot be installed, I go into the app manager and uninstall any prior version of that app. Then the new installation works. Seems to be an Android thing.....
 
Old 09-01-2010, 11:28 AM   #5
cheyennedonna
Edge User
 
I can confirm that too, uninstalling the old versions works almost always when the upgraded app says unable to install.
 
Old 09-01-2010, 11:38 AM   #6
NiaTrue
Edge User
 
Yep. I've had same problem, same solution. And one other wacky thing: Occassionaly, some apps install in landscape only.
 
Old 09-01-2010, 04:15 PM   #7
sarah11918
Edge User
 
So just to confirm, you did get LastPass working? And if I uninstall it before upgrading to Dingo and then reinstall LastPass it should work? I can't function without LastPass!
 
Old 09-01-2010, 04:31 PM   #8
miklos.klaar
Edge User
 
I did get it working. I had to use the shell to manually remove the remnants of the old install. I think you should be fine with uninstalling the old using Settings->Applications and then installing the new one.

I'm sure my problems were caused by not removing the old one before attempting the upgrade/install.

Good Luck!
 
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do many apps only work with SD card installed? RAH Nook Color & Nook Tablet 17 04-28-2011 01:40 PM
Google Earnings Q01/11: 3 Billion Android Apps Installed kjk Android Devices 1 04-14-2011 07:55 PM
unable to find installed itunes pitat450 Devices 1 03-28-2011 05:55 AM
Finding Installed Apps? da2zoe Nook Developer's Corner 11 02-21-2011 05:33 PM
shortcut for market installed apps debteb Nook Developer's Corner 4 12-24-2010 10:48 PM


All times are GMT -4. The time now is 02:39 PM.


MobileRead.com is a privately owned, operated and funded community.