Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > PocketBook

Notices

Reply
 
Thread Tools Search this Thread
Old 04-03-2011, 06:29 PM   #1
tselling
Addict
tselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enough
 
Posts: 366
Karma: 510
Join Date: Apr 2008
Device: NookColor (MiRage/CM7.2 & Moon+ Reader Pro)
Non-ugly Market install for v2.0.5

**** NOTE THAT I DO NOT GUARANTEE THAT THIS WILL WORK FOR YOU. IT WORKS FOR ME. I DO NOT BELIEVE THIS CAN HARM YOUR IQ, BUT I MAKE NO GUARANTEES ***

This is for v2.0.5 of the IQ firmware. Make sure you have flashed that FIRST!

After reading the complicated instructions for getting an Android Id to install the market to the IQ.... I decided to make an install that is very similar to the one for the White Pandigital Novel.

1) Install Launcher Pro and Enable USB Debugging from the Shortcuts->Activities->Settings->Development Settings. (Long press on the screen to get Shortcuts option).
2) Unzip InstallMarketToIQ.zip
3) Connect IQ via USB and install the ADB USB Driver (you can use the driver inf in the zip file).
4) Run batch file from zipfile on your PC: install_market_only.bat
5) Unplug USB and make sure WiFi is turned on
6) Run the market application and Login
7) If you get the server error after retrying a couple of times, set the date back one day and reopen the Market.
8) Once in the market install one application and exit
9) Fix the date back if you changed it
10) Connect IQ to USB and run batch file: restoreFramework.bat

You should be good after that. The zip file: http://www.mediafire.com/?41yz9mzqoq3kmbv
contains the files you will need other than LauncherPro: http://www.launcherpro.com/

For anyone interested in the details, I decompiled the IQ framework.jar and replaced the TelephonyManager.smali with a patched one for a WPDN and recompiled the jar. The patch code generates an androidId. To give proper credit, I believe the original patch was done by Clockworx (xda-developers) and the framework.jar that I extracted patched smali file from, I got from one of kewlguys (slatedroid) patches.

Last edited by tselling; 04-04-2011 at 02:10 AM.
tselling is offline   Reply With Quote
Old 04-04-2011, 08:01 PM   #2
tselling
Addict
tselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enough
 
Posts: 366
Karma: 510
Join Date: Apr 2008
Device: NookColor (MiRage/CM7.2 & Moon+ Reader Pro)
*** Standard disclaimers apply. I tested these flashes on my IQ and they worked fine, but I cannot guarantee results. ****

This is an even EASIER way to get the Market on your IQ. You DON'T NEED the adb drivers or LauncherPro.

I assume that version 2.0.5 of the IQ firmware has already been installed. The Market flash might work on other versions but I do not have the framework.jar from any other version to restore.

You just need to copy InstallMarketOnly_PB701SWUPDATE.zip to your SD card and flash. Then login to the Market (remember to set the date back 1 day after getting the server error). Then download an app. Then copy the RestoreFramework_PB701SWUPDATE.zip file to your SD card (delete the other zip file) and flash. ** Don't change the names **

*** Make sure there is only ONE zip file in the top directory of your SD card or the IQ won't know which zip file to flash. ****

The files are in the folder here: http://www.mediafire.com/?46nnv0ycrdc01

*** Note these are NON-destructive flashes (your programs and data will not be deleted). The first flash adds the market files, modifies the build.prop, and swaps in the patched framework.jar. The second flash copies the original framework.jar back to the IQ. These flashes are very quick.

CREDIT: The files originally came from kewlguy for the WPDN on slatedroid. I changed out the build.prop and the framework.jar for the ones for the IQ.

**** You can look in the zip file and see the actual files being loaded. ****

Last edited by tselling; 04-09-2011 at 01:26 AM.
tselling is offline   Reply With Quote
Old 04-05-2011, 07:28 AM   #3
pippopelo
Connoisseur
pippopelo will become famous soon enoughpippopelo will become famous soon enoughpippopelo will become famous soon enoughpippopelo will become famous soon enoughpippopelo will become famous soon enoughpippopelo will become famous soon enough
 
Posts: 72
Karma: 620
Join Date: Feb 2011
Device: Pocketbook IQ701, HTC Wildfire, Zenithink ZT-280 C-91
Work fine!!! Thank's! Grazie!!!
pippopelo is online now   Reply With Quote
Old 04-05-2011, 01:29 PM   #4
hiaig
Addict
hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.
 
Posts: 292
Karma: 428
Join Date: Mar 2010
Location: Toronto, Canada
Device: jetbook and PocketBook IQ
Thanks tselling,

Your second method works great.

Cheers
hiaig is offline   Reply With Quote
Old 04-05-2011, 03:53 PM   #5
carolianj
Junior Member
carolianj began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Apr 2011
Device: PocketBook IQ
Thumbs up

Thank you so much. I tried the first method yesterday and could get in to market but it said I didn't have a phone connected to the account. I tried the second method today and it works great. I'm still using the beta version of 2.0.5 (no link to official update) but your market installer works.
carolianj is offline   Reply With Quote
Old 04-06-2011, 08:55 AM   #6
fjtorres
Grand Sorcerer
fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.
 
Posts: 8,057
Karma: 61732902
Join Date: May 2009
Location: 26 kly from Sgr A*
Device: PRS-T1, KT, PB701/IQ, K2, PB360, BeBook One, Axim51v, TC1000
Question: what was the build prop set to?
I have zero interest in the Android market at this time but a tweak that sets the build prop to fake 2.1 would be useful; there are several apps that can run under 2.0 but won't install unless they see the 2.1 build prop. (Aldiko 2.0 comes to mind.)
fjtorres is online now   Reply With Quote
Old 04-06-2011, 09:59 AM   #7
tselling
Addict
tselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enough
 
Posts: 366
Karma: 510
Join Date: Apr 2008
Device: NookColor (MiRage/CM7.2 & Moon+ Reader Pro)
Quote:
Originally Posted by fjtorres View Post
Question: what was the build prop set to?
I have zero interest in the Android market at this time but a tweak that sets the build prop to fake 2.1 would be useful; there are several apps that can run under 2.0 but won't install unless they see the 2.1 build prop. (Aldiko 2.0 comes to mind.)
I set the sdk=7 in the build.prop so the market thinks we have android 2.1 installed.
tselling is offline   Reply With Quote
Old 04-06-2011, 11:04 AM   #8
fjtorres
Grand Sorcerer
fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.fjtorres ought to be getting tired of karma fortunes by now.
 
Posts: 8,057
Karma: 61732902
Join Date: May 2009
Location: 26 kly from Sgr A*
Device: PRS-T1, KT, PB701/IQ, K2, PB360, BeBook One, Axim51v, TC1000
Quote:
Originally Posted by tselling View Post
I set the sdk=7 in the build.prop so the market thinks we have android 2.1 installed.
That means your patch combo should let me install Aldiko 2.
I'll have to make time to try it in the next few days...

Thanks.

Last edited by fjtorres; 04-06-2011 at 11:09 AM.
fjtorres is online now   Reply With Quote
Old 04-06-2011, 02:38 PM   #9
hiaig
Addict
hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.
 
Posts: 292
Karma: 428
Join Date: Mar 2010
Location: Toronto, Canada
Device: jetbook and PocketBook IQ
Quote:
Originally Posted by fjtorres View Post
That means your patch combo should let me install Aldiko 2.
I'll have to make time to try it in the next few days...

Thanks.
Aldiko 2 installs fine for me.

Cheers
hiaig is offline   Reply With Quote
Old 04-06-2011, 06:32 PM   #10
UrbanNightmare
Enthusiast
UrbanNightmare began at the beginning.
 
Posts: 25
Karma: 12
Join Date: Feb 2011
Device: Pocketbook IQ
I just got back to the forums after a couple of weeks and started reading about the new firmware. I was so excited that I found a copy and installed it. Its working really nice so far. Even did the app market install and that works great now too. Even Angry Birds Rio works with out a hitch.

The only problem I've had is under settings, if you click the "Accounts & Sync" area it crashes android and does a cold boot. It keeps all the settings and everything still works so not a huge problem. Is this something to do with the market hack or did I do something wrong?

Thanks for the work around BTW.
UrbanNightmare is offline   Reply With Quote
Old 04-06-2011, 07:26 PM   #11
hiaig
Addict
hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.hiaig has a complete set of Star Wars action figures.
 
Posts: 292
Karma: 428
Join Date: Mar 2010
Location: Toronto, Canada
Device: jetbook and PocketBook IQ
Quote:
Originally Posted by UrbanNightmare View Post
The only problem I've had is under settings, if you click the "Accounts & Sync" area it crashes android and does a cold boot. It keeps all the settings and everything still works so not a huge problem. Is this something to do with the market hack or did I do something wrong?

Thanks for the work around BTW.

Just noticed that "Accounts & Sync" also crashes for me.

What do we need from "Accounts & Sync"? Was it the autosync on/off feature?

If that is the case, I use quicksettings and can turn the autosync on/off.

Cheers
hiaig is offline   Reply With Quote
Old 04-06-2011, 09:19 PM   #12
tselling
Addict
tselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enoughtselling will become famous soon enough
 
Posts: 366
Karma: 510
Join Date: Apr 2008
Device: NookColor (MiRage/CM7.2 & Moon+ Reader Pro)
Is it a valid assumption that "Accounts & Sync" worked with the original 2.0.5 firmware? I never tried it... if it did work, it must be something to do with the market being installed or something with the build.prop file but very little was changed in the build.prop (only 2 lines: the ro.build.version.sdk=7 and the ro.setup.wizard=DISABLED).

Quote:
Originally Posted by hiaig View Post
Just noticed that "Accounts & Sync" also crashes for me.

What do we need from "Accounts & Sync"? Was it the autosync on/off feature?

If that is the case, I use quicksettings and can turn the autosync on/off.

Cheers

Last edited by tselling; 04-06-2011 at 09:42 PM.
tselling is offline   Reply With Quote
Old 04-07-2011, 10:45 AM   #13
UrbanNightmare
Enthusiast
UrbanNightmare began at the beginning.
 
Posts: 25
Karma: 12
Join Date: Feb 2011
Device: Pocketbook IQ
I don't think I need it Accounts & Sync that much. I do use twitter and gmail on the IQ and both you can turn on and off from with in Accounts & Sync but I've never actually used it.

I was just wondering if anyone else had seen this problem with a version of 2.0.5 that hasn't had the market mod done.

So one more question. How do you install the new TTS files that are on PB's site? I tried downloading one and just clicked on it and nothing happened so I don't think there is an installer for it.

Thanks.
UrbanNightmare is offline   Reply With Quote
Old 04-07-2011, 02:09 PM   #14
citac
Fanatic
citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.citac ought to be getting tired of karma fortunes by now.
 
Posts: 521
Karma: 1020204
Join Date: Sep 2008
Location: Bosnia and Herzegovina
Device: Prestigio Multipad PMP7100D 10.1", Prestigio MultiPhone 4040 DUO
Re: TTS, I believe you first have to remove one of the language files since the IQ can only have a maximum of four files.
citac is offline   Reply With Quote
Old 04-07-2011, 06:24 PM   #15
UrbanNightmare
Enthusiast
UrbanNightmare began at the beginning.
 
Posts: 25
Karma: 12
Join Date: Feb 2011
Device: Pocketbook IQ
Thanks for the tip. I removed the Russian tts and was able to install english (female). But when trying to select the female voice while in the library it just continues with the male voice. Not that it really matters as it pauses way to long between sentences. Wonder if they are just the same voice but with different titles
UrbanNightmare is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gizmodo: Use Dropbox to Easily Install Non-Market Android Apps kjk Android Devices 0 07-22-2010 02:26 PM
PRS-900 Sony Digital Edition Library Install, and Install, ... Hamlet53 Sony Reader 3 04-05-2010 04:29 PM
Why E-Books Look So Ugly jankovicgood News 38 09-04-2009 08:19 PM
Ugly formatting Tanzaku Workshop 62 12-25-2007 03:35 AM
Kindle is Ugly halljames Amazon Kindle 48 11-29-2007 02:45 PM


All times are GMT -4. The time now is 07:31 AM.


MobileRead.com is a privately owned, operated and funded community.