Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 01-27-2011, 07:00 PM   #1
kiwidude
calibre/Sigil Developer
kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.
 
Posts: 4,228
Karma: 1334002
Join Date: Oct 2010
Location: London, UK
Device: Kindle Paperwhite 3G, iPad 3, iPad Air
[GUI Plugin] Open With

This plugin allows you to launch external applications for editing your books in Calibre.

Common uses are to allow editing a specific format of a book in an external editor (such as to edit an EPUB in Sigil), or to edit the cover of a book in an external graphics program to crop/resize it.

Main Features of v1.5.8:
  • Launch external applications for a particular format or cover of the selected book.
  • Easy to use configuration dialog accessed via right-click context menu or Preferences->Plugins
  • A number of predefined default applications (per platform) for you to choose from, plus the ability to edit/add your own.
  • Menu is fully customisable to change ordering, add submenus, keyboard shortcuts, images and command line arguments.
  • Import and export capability for backup or sharing with other users.
  • Help file web page available from the configuration dialog.

Special Notes:
  • Requires Calibre v0.8.18 or later.

Installation Steps:
  1. Download the attached zip file and install the plugin/restart Calibre/add to context menu as described in the Introduction to plugins thread.
  2. Click on "Customize plugin" in the context menu to select the application(s) you want in your menu, alter paths etc as appropriate for your machine setup. This option is also available via the Preferences->Plugins dialog once you select it within the list.

Paypal Donations:
  • If you find this or any of my other plugins useful please feel free to show your appreciation. I have spent many hundreds of unpaid hours in their development and support so any encouragement for me to continue is appreciated!

Version History:
Spoiler:

Version 1.5.8 - 15 Apr 2013
Support for upcoming calibre 2.0

Version 1.5.7 - 15 Apr 2013
Add detached process flag for when launching on Windows.

Version 1.5.6 - 01 Dec 2012
When switching libraries, ensure keyboard shortcuts are reactivated
Prevent Open With being used in Device View or on Device View context menu

Version 1.5.5 - 01 Oct 2012
Put a special case in for loading Sigil, to workaround issues found with 0.5.9 release and conflicting C runtime paths

Version 1.5.4 - 14 Aug 2012
For Mac users support running shell scripts (contribution by Griker)

Version 1.5.3 - 20 Jul 2012
For Windows users use Win32 API rather than subprocess due to Python bug causing issues for users with non-ascii library paths

Version 1.5.2 - 28 Jan 2012
Support environment variables in paths to Unix applications
Add an Edit... right-click for the path to an application to allow manual editing of the path.

Version 1.5.1 - 17 Sep 2011
On Windows ensure the opened file is added to the MRU list, to support jump lists and recent documents

Version 1.5.0 - 11 Sep 2011
Fix bug in Import and Export menu items which were broken
Fix bug of double click on the application path should not be allowed when no menu name
Upgrade to support the centralised keyboard shortcut management in Calibre

Version 1.4.1 - 09 Apr 2011
Support skinning of icons by putting them in a plugin name subfolder of local resources/images

Version 1.4 - 03 Apr 2011
Rewritten for new plugin infrastructure in Calibre 0.7.53
Add Bliss application for Windows

Version 1.3 - 29 Jan 2011
Support for OSX (Windows/Linux already available)
Default applications list is now platform specific - don't display Windows applications to Linux/OSX users etc.
Added more applications for Windows - Adobe Digital Editions, EPUBReader (Firefox plugin)
Added default applications for OSX (Sigil, ADE, EPUBReader, Photoshop CS5, Pixelmator, Preview, Acrobat, Adobe Reader, Skim)
Added default applications for Linux (Sigil, EPUBReader, Gimp)
Bug fix for keyboard shortcuts not working if switch rows without reopening context menu

Version 1.2 - 25 Jan 2011
Rewrite with a configuration dialog to replace tweaks file
Include predefined application list

Version 1.1 - 28 Jan 2011
Renamed to 'Open with' plugin
Add support for opening covers

Version 1.0 - 05 Dec 2010
Initial release as 'Open EPUB in editor' and 'Open format externally' plugins
Attached Thumbnails
Click image for larger version

Name:	Screenshot_1_Menu.png
Views:	1752
Size:	29.4 KB
ID:	65617   Click image for larger version

Name:	Screenshot_2_Configuration.png
Views:	1287
Size:	126.6 KB
ID:	65618   Click image for larger version

Name:	Screenshot_3_Add_Image.png
Views:	1225
Size:	25.4 KB
ID:	65619  
Attached Files
File Type: zip Open With.zip (178.8 KB, 4286 views)

Last edited by kovidgoyal; 07-30-2014 at 03:20 AM. Reason: v1.5.8 Released
kiwidude is offline   Reply With Quote
Old 01-27-2011, 07:19 PM   #2
Ralob
Enthusiast
Ralob began at the beginning.
 
Posts: 49
Karma: 10
Join Date: Feb 2008
Device: PW2, along with a handful of others
Using Source of Calibre (rev 7833 atm), I get this error when trying to start the gui:

File "/home/laptop/calibre/src/calibre/gui2/main.py", line 253, in initialize
self.initialize_db()
File "/home/laptop/calibre/src/calibre/gui2/main.py", line 234, in initialize_db
self.initialize_db_stage2(db, None)
File "/home/laptop/calibre/src/calibre/gui2/main.py", line 203, in initialize_db_stage2
self.start_gui(db)
File "/home/laptop/calibre/src/calibre/gui2/main.py", line 159, in start_gui
main.initialize(self.library_path, db, self.listener, self.actions)
File "/home/laptop/calibre/src/calibre/gui2/ui.py", line 145, in initialize
ac.do_genesis()
File "/home/laptop/calibre/src/calibre/gui2/actions/__init__.py", line 97, in do_genesis
self.genesis()
File "/home/laptop/.config/calibre/plugins/Open With.zip/open_with_plugin_code.py", line 603, in genesis
File "/home/laptop/calibre/src/calibre/gui2/actions/__init__.py", line 142, in load_resources
with ZipFile(self.plugin_path, 'r') as zf:
AttributeError: ZipFile instance has no attribute '__exit__'
Ralob is offline   Reply With Quote
Old 01-27-2011, 07:25 PM   #3
kiwidude
calibre/Sigil Developer
kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.
 
Posts: 4,228
Karma: 1334002
Join Date: Oct 2010
Location: London, UK
Device: Kindle Paperwhite 3G, iPad 3, iPad Air
Ralob - I have seen that error posted previously. See the response from Kovid here, and the original user's post two above it:
http://www.mobileread.com/forums/sho...57#post1298257

Upgrading Python was the gist I got from it.
kiwidude is offline   Reply With Quote
Old 01-28-2011, 07:15 PM   #4
kiwidude
calibre/Sigil Developer
kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.
 
Posts: 4,228
Karma: 1334002
Join Date: Oct 2010
Location: London, UK
Device: Kindle Paperwhite 3G, iPad 3, iPad Air
v1.3 Released

For users who upgrade to the now available Calibre 0.7.43 or later, you should also upgrade to v1.3 of Open With plugin.

Special thanks to GRiker for adding OSX support and some suggested OSX application paths/icons.

Changes in v1.3:
  • Support for OSX (Windows/Linux already available)
  • Default applications list is now platform specific - don't display Windows applications to Linux/OSX users etc.
  • Added more applications for Windows - Adobe Digital Editions, EPUBReader (Firefox plugin)
  • Added default applications for OSX (Sigil, ADE, EPUBReader, Photoshop CS5, Pixelmator, Preview, Acrobat, Adobe Reader, Skim)
  • Added default applications for Linux (Sigil, EPUBReader, Gimp)
  • Bug fix for keyboard shortcuts not working if switch rows without reopening context menu
kiwidude is offline   Reply With Quote
Old 01-30-2011, 12:31 AM   #5
Ralob
Enthusiast
Ralob began at the beginning.
 
Posts: 49
Karma: 10
Join Date: Feb 2008
Device: PW2, along with a handful of others
Quote:
Originally Posted by kiwidude View Post
Ralob - I have seen that error posted previously. See the response from Kovid here, and the original user's post two above it:
http://www.mobileread.com/forums/sho...57#post1298257

Upgrading Python was the gist I got from it.
Unfortunately, I have the newest python 2.6. Thanks for the help anyways.
Ralob is offline   Reply With Quote
Old 01-30-2011, 12:50 AM   #6
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,861
Karma: 12755553
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by Ralob View Post
Using Source of Calibre (rev 7833 atm)
I have to admit my ignorance here, what version of calibre are you trying to run and on what OS are you running it?
DoctorOhh is offline   Reply With Quote
Old 01-30-2011, 01:35 AM   #7
kiwidude
calibre/Sigil Developer
kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.
 
Posts: 4,228
Karma: 1334002
Join Date: Oct 2010
Location: London, UK
Device: Kindle Paperwhite 3G, iPad 3, iPad Air
Quote:
Originally Posted by Ralob View Post
Unfortunately, I have the newest python 2.6. Thanks for the help anyways.
"Newest"? I use Python 2.7 with Calibre.
kiwidude is offline   Reply With Quote
Old 01-30-2011, 05:05 PM   #8
Ralob
Enthusiast
Ralob began at the beginning.
 
Posts: 49
Karma: 10
Join Date: Feb 2008
Device: PW2, along with a handful of others
Quote:
Originally Posted by dwanthny View Post
I have to admit my ignorance here, what version of calibre are you trying to run and on what OS are you running it?
I am using the latest, but through Develop_From on Linux. And I pull the latest rev daily, so I am always on the latest.

Basically, I don't use a binary installation, but rather run it through my home directory.
Ralob is offline   Reply With Quote
Old 01-30-2011, 05:09 PM   #9
Ralob
Enthusiast
Ralob began at the beginning.
 
Posts: 49
Karma: 10
Join Date: Feb 2008
Device: PW2, along with a handful of others
Quote:
Originally Posted by kiwidude View Post
"Newest"? I use Python 2.7 with Calibre.
The calibre homepage lists python 2.6 as the required dependency, hence the reason I named it. I also have the newest 2.7, and the error persists.

It isn't too big of a deal, I know how to work around it. I just thought that I would bring it up in case anyone else has a similar error.
Ralob is offline   Reply With Quote
Old 02-02-2011, 08:26 PM   #10
Visuddhi
Member
Visuddhi can extract oil from cheeseVisuddhi can extract oil from cheeseVisuddhi can extract oil from cheeseVisuddhi can extract oil from cheeseVisuddhi can extract oil from cheeseVisuddhi can extract oil from cheeseVisuddhi can extract oil from cheeseVisuddhi can extract oil from cheeseVisuddhi can extract oil from cheese
 
Posts: 20
Karma: 1204
Join Date: Jan 2011
Device: kindle 3
Thumbs up

Quote:
Originally Posted by kiwidude View Post

Changes in v1.3:
  • Support for OSX (Windows/Linux already available)
  • Default applications list is now platform specific - don't display Windows applications to Linux/OSX users etc.
  • Added more applications for Windows - Adobe Digital Editions, EPUBReader (Firefox plugin)
  • Added default applications for OSX (Sigil, ADE, EPUBReader, Photoshop CS5, Pixelmator, Preview, Acrobat, Adobe Reader, Skim)
  • Added default applications for Linux (Sigil, EPUBReader, Gimp)
  • Bug fix for keyboard shortcuts not working if switch rows without reopening context menu
Seems to work pretty well

Please add 'open with Briss' option
Visuddhi is offline   Reply With Quote
Old 02-02-2011, 09:30 PM   #11
kiwidude
calibre/Sigil Developer
kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.
 
Posts: 4,228
Karma: 1334002
Join Date: Oct 2010
Location: London, UK
Device: Kindle Paperwhite 3G, iPad 3, iPad Air
Quote:
Originally Posted by Visuddhi View Post
Seems to work pretty well

Please add 'open with Briss' option
So I googled Briss and came up with "the Jewish rite of circumcision" - I guess that wasn't the one you were after...

One of the ideas for the Export feature was exactly this scenario - users sharing shortcuts to their favourite applications without me having to continually re-release the plugin. When/if I get around to a future release of the plugin I will add any posted in this thread to be included in it.

So I just created the menu item in the plugin config dialog, right-click to "export" and renamed the resulting briss.owip file to briss.zip (forum blocks unknown extensions as attachments unfortunately).

For anyone wanting to use it, download the attachment, rename it to 'briss.owip', then from within the plugin preferences right-click on your list of menu items and choose "Import". You will almost certainly need to modify the path, but at least I have saved you the trouble of grabbing the icon etc.
Attached Files
File Type: zip briss.zip (1.1 KB, 258 views)
kiwidude is offline   Reply With Quote
Old 02-06-2011, 06:12 PM   #12
redynstruc
Junior Member
redynstruc began at the beginning.
 
Posts: 4
Karma: 10
Join Date: Dec 2010
Device: Kindle
I'm a Mac user who uses a Kindle and, until I downloaded this plugin, I had no way to open drm protected books which had been stored in Calibre. Leaving them in "My Kindle Content" for Kindle's desktop ereader to open was not much of an option because (despite how good of a library manager the Kindle, itself, is) the desktop reader is nothing more than an electronic way to thumb through hundreds of books until, hopefully, you find what you're after.
This plugin makes Calibre so much more useful by allowing me to not only read drm protected books with my desktop Kindle software, but, also, manipulate other books in my library with Sigil, Skim, etc. - without needed to drop out of Calibre to do so. Thanks a bunch.
redynstruc is offline   Reply With Quote
Old 02-06-2011, 08:33 PM   #13
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,861
Karma: 12755553
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by redynstruc View Post
I'm a Mac user who uses a Kindle and, until I downloaded this plugin, I had no way to open drm protected books which had been stored in Calibre.
This plugin works great for this but you can also turn off calibre's internal viewer for your Kindle books and it will use whatever program your Mac is set to use for these files.
DoctorOhh is offline   Reply With Quote
Old 02-23-2011, 10:06 PM   #14
jackie_w
Wizard
jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.
 
Posts: 2,834
Karma: 4199513
Join Date: Sep 2009
Location: UK
Device: Sony PRS-350, PB360, Kobo Glo/AuraHD/Aura6"/AuraH2O
@kiwidude,

Thank you for this plugin. I have been able to successfully add a couple of items via the customisation screen?

I was wondering whether it is possible to add your own programs to the list if your programs are either a Python .py file or a Windows .bat file (i.e. no .exe available) which expect a single input argument which is the selected book's EPUB for instance?

I have a couple of home grown utilities which I run just by 'Click to Open' on the book details panel followed by right-clicking on the relevant book format in Windows Explorer and using the Send-To option to drop it onto a one-line .bat which calls a .py file.

It would be quite convenient to have the option to run these directly from the calibre library window. It's not a big deal to carry on as now, but I thought I'd ask.
jackie_w is offline   Reply With Quote
Old 02-24-2011, 02:38 AM   #15
kiwidude
calibre/Sigil Developer
kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.kiwidude ought to be getting tired of karma fortunes by now.
 
Posts: 4,228
Karma: 1334002
Join Date: Oct 2010
Location: London, UK
Device: Kindle Paperwhite 3G, iPad 3, iPad Air
@jackie_w

Sure you can add your own - in fact I thought you indicated with your first sentence that you had managed to do that already?

Adding and running .bat files is no problem at all. The only issue you may have is if you need a command window to stay open to see the results of some output. I'm sure there is a way of doing that with a batch files that uses start with some arguments but can't remember what they are off top of my head. I think you could also run python scripts directly if you didn't want a .bat file wrapper - specify python.exe as the executable and in the command line arguments column specify the path to the script.
kiwidude is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[GUI Plugin] Search the Internet kiwidude Plugins 205 08-11-2014 02:22 PM
New Plugin Type Idea: Library Plugin cgranade Plugins 3 09-15-2010 12:11 PM
Gui confusements. brewt Calibre 8 12-30-2008 12:16 PM
Reference Open eBook Forum: Open eBook Publication Structure. IMP. V1.0.1 14 September 2007 DaleDe IMP Books 0 09-14-2007 05:06 PM
iLiad GUI for the iLiad tribble iRex Developer's Corner 1 06-01-2007 02:29 PM


All times are GMT -4. The time now is 02:18 PM.


MobileRead.com is a privately owned, operated and funded community.