Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 09-11-2010, 05:43 PM   #1
lunixer
Addict
lunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-books
 
lunixer's Avatar
 
Posts: 231
Karma: 928
Join Date: Aug 2010
Device: Kindle 3
Can't get calibre to *not* put space between paragraphs

I had set calibre to convert all books by removing space between paragraphs, indent of 0 and then adding a space between paragraphs. I like this format, but it can really screw stuff up sometimes, especially when the book signals soft chapter breaks with a double space. I have been trying to convert my library back to the way it originally was, with indents for new paragraphs, but every single time I convert it is doing what I talked about above. I simply can't figure it out. I uninstalled the software and reinstalled and am currently using the latest stable version. Is there any way around this?
lunixer is offline   Reply With Quote
Old 09-11-2010, 09:22 PM   #2
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,781
Karma: 12516053
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by lunixer View Post
I have been trying to convert my library back to the way it originally was, with indents for new paragraphs, but every single time I convert it is doing what I talked about above. I simply can't figure it out. I uninstalled the software and reinstalled and am currently using the latest stable version. Is there any way around this?
If you go to do a bulk convert it will use the same settings for the conversion this time that it used the previous time unless you uncheck the top left box (see attached) Use saved conversion settings for individual books. If the box is unchecked it will use whatever settings you give it in the bulk convert window.
Attached Thumbnails
Click image for larger version

Name:	bulk_convert.jpg
Views:	257
Size:	79.0 KB
ID:	58089  

Last edited by DoctorOhh; 09-11-2010 at 09:29 PM.
DoctorOhh is offline   Reply With Quote
Old 09-11-2010, 09:34 PM   #3
lunixer
Addict
lunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-books
 
lunixer's Avatar
 
Posts: 231
Karma: 928
Join Date: Aug 2010
Device: Kindle 3
Quote:
Originally Posted by dwanthny View Post
If you go to do a bulk convert it will use the same settings for the conversion this time that it used the previous time unless you uncheck the top left box (see attached) Use saved conversion settings for individual books. If the box is unchecked it will use whatever settings you give it in the bulk convert window.
I have never done a bulk convert. And when I do an individual convert I always ensure that the options that I mentioned are unchecked. I always go to the look and feel tab first. But, thanks anyway.
lunixer is offline   Reply With Quote
Old 09-11-2010, 09:44 PM   #4
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,781
Karma: 12516053
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by lunixer View Post
I have never done a bulk convert. And when I do an individual convert I always ensure that the options that I mentioned are unchecked. I always go to the look and feel tab first. But, thanks anyway.
Out of curiosity how do you expect the books to be formatted after conversion?
DoctorOhh is offline   Reply With Quote
Old 09-11-2010, 09:50 PM   #5
lunixer
Addict
lunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-books
 
lunixer's Avatar
 
Posts: 231
Karma: 928
Join Date: Aug 2010
Device: Kindle 3
Quote:
Originally Posted by dwanthny View Post
Out of curiosity how do you expect the books to be formatted after conversion?
I want the books to be formatted the same way a paper book would be. I want paragraphs with no line between them, and when a book is supposed to have two spaces to indicate that there is a "soft" chapter break or a scene break, I want that to show up. Right now those get lost because everything has a single line between paragraphs.

Oh, and BTW, I am susceptible to seizures but I can assure you your avatar is safe
lunixer is offline   Reply With Quote
Old 09-11-2010, 10:04 PM   #6
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,781
Karma: 12516053
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by lunixer View Post
I want the books to be formatted the same way a paper book would be. I want paragraphs with no line between them, and when a book is supposed to have two spaces to indicate that there is a "soft" chapter break or a scene break, I want that to show up. Right now those get lost because everything has a single line between paragraphs.

Oh, and BTW, I am susceptible to seizures but I can assure you your avatar is safe
Once you converted them then changing back requires using the original source file. Also if you use the indent feature then all spaces will be removed including soft chapter and scene breaks.

Calibre is not designed for tweaking or formatting documents. The remove spaces/add indent and the insert blank line options were giant swipes at common problems. If you use either of these it is all or nothing. I use both, but I also don't mind losing the soft chapter and scene breaks.

You can always use Sigil to fine tune ePub book content, format and the css file. If you want to just adjust indents then tweaking the css file using epub-tweak and a editor like Notepad++ might work for you.

Good Luck.
DoctorOhh is offline   Reply With Quote
Old 09-11-2010, 10:08 PM   #7
lunixer
Addict
lunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-books
 
lunixer's Avatar
 
Posts: 231
Karma: 928
Join Date: Aug 2010
Device: Kindle 3
Quote:
Originally Posted by dwanthny View Post
Once you converted them then changing back requires using the original source file. Also if you use the indent feature then all spaces will be removed including soft chapter and scene breaks.

Calibre is not designed for tweaking or formatting documents. The remove spaces/add indent and the insert blank line options were giant swipes at common problems. If you use either of these it is all or nothing. I use both, but I also don't mind losing the soft chapter and scene breaks.

You can always use Sigil to fine tune ePub book content, format and the css file. If you want to just adjust indents then tweaking the css file using epub-tweak and a editor like Notepad++ might work for you.

Good Luck.
Yes, but the problem now is that somehow, it is using both of the options even when I have them off. As a test I am using a trilogy of books that I have in rtf. I originally did an rtf=>mobi with both options on. Then I realized that this bugged me so I deleted all copies of the mobi file. I never modified the rtf file. Now, even when I do the rtf=> mobi with both options off, I still have the same result as before. I am stumped.
lunixer is offline   Reply With Quote
Old 09-11-2010, 10:15 PM   #8
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,781
Karma: 12516053
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by lunixer View Post
Yes, but the problem now is that somehow, it is using both of the options even when I have them off. As a test I am using a trilogy of books that I have in rtf. I originally did an rtf=>mobi with both options on. Then I realized that this bugged me so I deleted all copies of the mobi file. I never modified the rtf file. Now, even when I do the rtf=> mobi with both options off, I still have the same result as before. I am stumped.
Maybe it's a RTF conversion quirk. Open the rtf in Word and save as web page filtered then add the html and see if that gives you different results.

You can also run the conversion with a directory in debug and look at each stage of the conversion to see what is happening.

Last edited by DoctorOhh; 09-12-2010 at 01:52 AM.
DoctorOhh is offline   Reply With Quote
Old 09-11-2010, 10:23 PM   #9
lunixer
Addict
lunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-bookslunixer has learned how to read e-books
 
lunixer's Avatar
 
Posts: 231
Karma: 928
Join Date: Aug 2010
Device: Kindle 3
Quote:
Originally Posted by dwanthny View Post
Maybe it's a RTF conversion quirk. Open the rtf in Word and save as web page filtered then add the html and see if that gives you different results.

You can also run with a directory in debug and look at each stage of the conversion to see what is happening.
Oh, good idea. Thanks! I'll try it in the morning and report back. Too tired right now
lunixer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Paragraphs between Pages and Calibre La Nuestra Calibre 21 10-18-2010 08:03 AM
How to reduce indents without "removing space between paragraphs" Skydog Calibre 5 06-05-2010 12:58 AM
remove space between paragraphs-yes the box is checked Blurr Calibre 1 12-23-2009 06:34 AM
Unwanted space between paragraphs superanima Calibre 3 10-14-2009 02:28 PM
Fixing paragraphs with calibre? enarchay Calibre 17 08-16-2009 08:31 PM


All times are GMT -4. The time now is 11:38 AM.


MobileRead.com is a privately owned, operated and funded community.