View Single Post
Old 06-21-2010, 11:06 AM   #6
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,470
Karma: 5567061
Join Date: Aug 2009
Location: The (original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by chaley View Post
Thanks for trying.

My setting is
Code:
set CALIBRE_DEVELOP_FROM=C:\calibre_development\calibre\src
Calibre_development is the folder where I keep my various source trees (I have 6). calibre is the folder containing the managed source. It contains the files/folders: .settings, icons, resources, setup, src, .bzrignore, .project, .pydevproject, Changelog.yaml, COPYRIGHT, INSTALL, LICENSE, LICENSE.rtf, README, session.vim, setup.py, and .bzr. You won't have all of them, because some are put there the eclipse/pydev development environment. It is 'src' in this folder that must appear in the CALIBRE_DEVELOP_FROM variable.
I saw thos files
Quote:
The other trick is that you must set the environment variable so that calibre can see it. You can set it in the windows environment list (my computer, ..., environment), but that is harder to manage. For example, you usually need to reboot after changing it.
That is where I set it. I opened the command prompt and did the "echo test"
Quote:
Code:
set CALIBRE_DEVELOP_FROM=C:\calibre_development\calibre\src
calibre-debug -g
This way you will see the debug output, which will help if something goes wrong.

[/CODE]to my .bat file, having copied my production config folder to there and then modifying the library path in global.py.
Could my problem be that I had to quote the PATH location because of the spaces in the path?
theducks is offline   Reply With Quote