View Single Post
Old 06-18-2010, 10:49 PM   #2
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,851
Karma: 5654321
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by Stinger View Post
I've found some strange behaviour from the cover browser:

The cover browser functions as intended when I first start up Calibre. But certain actions seem to 'break' it so it's not interactive anymore (mousewheel, arrow buttons, or clicking on the side books no longer works). It still changes to the appropriate cover if I select a book in the Library list, but I can't navigate using the cover browser itself until the next time I restart Calibre.

Trigger:
Selecting a book from the Library list, and then clicking on on the cover browser. I've spent the past hour restarting Calibre and trying to narrow it down a little more so I could provide something more helpful to Kovid et al. without much success. Clicking on the one the trigger zones that cause a left/right flip seems to not cause the bug as much as clicking the 'non-active' areas. I've also noted that the quicker I click on the browser after selecting a book, the more likely it is to trigger.

If your first click on the browser after selecting a book from the Library list doesn't trigger the bug, subsequent clicks don't seem to matter. But repeating the sequence (select book from list, then immediately click on CV browser) a few times causes it pretty consistently. I can get it to freeze 95% of the time by 2-3 repeats of the sequence.

Let me know if I can post some kind of log file or debug output to help out narrow this down.
Running with CV browser detached on XP SP3 1G+ DRAM

Spun the wheel.
Clicked the Hot Zoned, Dead Zones: hi and lo
selected titles in the book list
Re read you message (switched applications to do so) repeated above.

I love to tone down the reflection,

that's my only issue
theducks is online now   Reply With Quote