View Single Post
Old 06-15-2010, 01:42 AM   #4
artificial
Groupie
artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.artificial got an A in P-Chem.
 
artificial's Avatar
 
Posts: 179
Karma: 6328
Join Date: May 2010
Location: Melbourne, Australia
Device: Kobo eReader
Quote:
Originally Posted by Feisty View Post
Hi!when I transferred the file to my kobo the formatting is correct except that the long lines are simply cut off entirely.
This is probably related to the fact you checked the "conserve spaces" option ON.

I imagine that option coverts all space characters to a non breaking space (in HTML,   ). This tells the HTML parser (i.e. the kobo eReader) that space characters should not break (wrap). In other words it treats a sentence of text as one long unbroken string.

Because the kobo eReader's ePub viewer does no have a function to scroll left/right it will simply truncate any long string of text when it is wider than the screen.

Unchecking the "conserve spaces" option during the conversion process should fix this problem. And remember, the option you want ON is "treat each line as a paragraph"
artificial is offline   Reply With Quote