View Single Post
Old 04-20-2010, 01:23 PM   #10
kahowson
Junior Member
kahowson began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Apr 2010
Device: Sony Reader PRS-500
I'm having the same issue, running on a Mac (PRS-500). I get the following two errors:


ERROR: ERROR: Unhandled exception: <b>Error</b>evice sent zero bytes

Traceback (most recent call last):
File "site-packages/calibre/gui2/__init__.py", line 252, in dispatch
File "site-packages/calibre/gui2/ui.py", line 898, in device_detected
File "site-packages/calibre/devices/prs500/driver.py", line 174, in run_session
File "site-packages/calibre/devices/prs500/driver.py", line 621, in card_prefix
File "site-packages/calibre/devices/prs500/driver.py", line 174, in run_session
File "site-packages/calibre/devices/prs500/driver.py", line 453, in path_properties
File "site-packages/calibre/devices/prs500/driver.py", line 424, in _bulk_read
File "site-packages/calibre/devices/prs500/driver.py", line 411, in bulk_read_packet
File "site-packages/calibre/devices/libusb.py", line 255, in bulk_read
Error: Device sent zero bytes

------------ And (this wouldn't copy, so I had to type it, I think I got it right) ---------

ERROR: Error: Error communicating with device

Device is in use by another application:
Underlying error:Failed to set device configuration to: 2. Error code: -9

Traceback (most recent call last):
File "site-packages/calibre/gui2/device.py", line 56, in run
File "site-packages/calibre/gui2/device.py", line 199 in _get_device_information
File "site-packages/calibre/devices/prs500/driver.py", line 170, in run_session
File "site-packages/calibre/devices/prs500/driver.py", line 276, in open
DeviceBusy: Device is in use by another application: Underlying error:Failed to set device configuration to: 2. Error code: -9

Trying the Debug Device Detection, I get:
ERROR: ERROR: Unhandled exception: <b>OSError</b>:[Errno 4] Interrupted system call

Traceback (most recent call last):
File "site-packages/calibre/gui2/dialogs/config/device_debug.py", line 41, in debug
File "site-packages/calibre/devices/__init__.py", line 62, in debug
File "site-packages/calibre/devices/usbms/device.py", line 332, in osx_run_mount
File "lib/python2.6/subprocess.py", line 686, in communicate
File "lib/python2.6/subprocess.py", line 1157, in wait
OSError: [Errno 4] Interrupted system call
kahowson is offline   Reply With Quote