Thread: Classic A few Nook questions
View Single Post
Old 03-19-2010, 12:21 PM   #1
jswinden
Astrophotographer
jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.jswinden ought to be getting tired of karma fortunes by now.
 
jswinden's Avatar
 
Posts: 5,224
Karma: 5642618
Join Date: Sep 2006
Location: USA
Device: iPad Mini 2, iPhone 5, Nexus 7.2
Question A few Nook questions

I went to B&N yesterday to check out the Nook. I really liked the form factor and the build quality. Unlike the K2 I once had, the Nook felt like it was solidly built. But I've got a few questions based on my experience.

BTW: I forgot to check the firmware on the demo in B&N, so it might be an earlier version.

There seems to be a huge lag time between input on the LCD and reaction to same on the e-Ink display. Has the most recent firmware drastically reduced this? To be honest, I could select words a lot faster on the K2 than on the demo Nook, and the K2 was not a pleasant experience as it was clunkie and slow using their mouse button.

On several occasions when viewing a book and trying to change settings like the font size, the Nook closed the book and went to the library (book list). Has this been fixed?

In cover mode, the covers kept disappearing. It took several attempts for them to display and remain displaying. Has this been fixed?

The Nook seems to be having growing pains, but I like the form factor. But based on the demo model I played with I think they might be a few firmware updates away from getting it working correctly.
jswinden is offline   Reply With Quote