View Single Post
Old 12-27-2009, 04:36 PM   #3
Tamara
Evangelist
Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.Tamara once ate a cherry pie in a record 7 seconds.
 
Posts: 446
Karma: 1812
Join Date: Dec 2007
Device: iPhone
Quote:
Originally Posted by Grayghost View Post
Hmmm..same issue here. I upgraded to 0.6.30 last night. I tried connecting my (non-updated) PRS-500 today and have received two different error messages. The first occurred during "Get device information"

ERROR: ERROR: Unhandled exception: <b>PacketError</b>:Response packets must have their number set to 0x1000

Traceback (most recent call last):
File "site-packages\calibre\gui2\__init__.py", line 243, in dispatch
File "site-packages\calibre\gui2\ui.py", line 799, in device_detected
File "site-packages\calibre\devices\prs500\driver.py", line 172, in run_session
File "site-packages\calibre\devices\prs500\driver.py", line 612, in card_prefix
File "site-packages\calibre\devices\prs500\driver.py", line 172, in run_session
File "site-packages\calibre\devices\prs500\driver.py", line 442, in path_properties
File "site-packages\calibre\devices\prs500\driver.py", line 338, in send_validated_command
File "site-packages\calibre\devices\prs500\driver.py", line 322, in _send_command
File "site-packages\calibre\devices\prs500\prstypes.py", line 652, in __init__
PacketError: Response packets must have their number set to 0x1000


Sometimes it will successfully complete "Get device information" but then fail during "Get list of books on device"...

'calibre.devices.prs500.prstypes.Answer packets must have a length of atleast 16 bytes. Got initializer of 15 bytes.

Traceback (most recent call last):
File "site-packages\calibre\gui2\device.py", line 57, in run
File "site-packages\calibre\gui2\device.py", line 208, in _books
File "site-packages\calibre\devices\prs500\driver.py", line 172, in run_session
File "site-packages\calibre\devices\prs500\driver.py", line 836, in books
File "site-packages\calibre\devices\prs500\driver.py", line 172, in run_session
File "site-packages\calibre\devices\prs500\driver.py", line 498, in get_file
File "site-packages\calibre\devices\prs500\driver.py", line 415, in _bulk_read
File "site-packages\calibre\devices\prs500\driver.py", line 402, in bulk_read_packet
File "site-packages\calibre\devices\prs500\prstypes.py", line 741, in __init__
PacketError: 'calibre.devices.prs500.prstypes.Answer packets must have a length of atleast 16 bytes. Got initializer of 15 bytes.


It looks like I might be reinstalling 0.6.29 for the time being.
That's the same error that I'm seeing. Thanks for confirming that I'm not alone.
Tamara is offline   Reply With Quote