View Single Post
Old 12-27-2009, 08:41 AM   #4
Valloric
Created Sigil, FlightCrew
Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.Valloric ought to be getting tired of karma fortunes by now.
 
Valloric's Avatar
 
Posts: 1,978
Karma: 350515
Join Date: Feb 2008
Device: Sony Reader PRS 505
Quote:
Originally Posted by moz View Post
OK, now when I load an epub in the Calibre reader, or previously when I loaded it in Sigil the text was small (perhaps 12pt) and the images displayed at whatever their native size is. The problem is that now when I load an epub in Sigil the images are scaled up and the text is about 30pt. On a 1024 pixel wide Sigil window I get about 5 words per line and there doesn't seem to be a way to change that (image here). By comparison Calibre opens the exact same file with reasonable defaults.
When in Book View, look at the zoom controls at the bottom. Does it say 100%? If it doesn't, zoom it down to 100%.

Quote:
Originally Posted by moz View Post
Based on the Sigil XHTML view showing a changed "don't change this" section, I think that's the problem. But regardless, I'd like to be able to change it back. There doesn't seem to be anything useful in the registry, nor in the assortment of file locations that I've checked. So how do I change back to the way it was when I first installed it?
I still don't know what you mean by the changed "don't change this" section. I know what you're referring to, but I can assure you it's not the cause of your problem. That section never changes unless the user does it himself. Tidy can perhaps merge those CSS styles into other CSS style tags, but the styles themselves are the same.

Again, it's not causing the large text/image size. The zoom mode is. It's the only thing that can enlarge both the images and the text.

And if you want to know, Sigil stores its settings in the registry, under HKEY_CURRENT_USER/Software/Strahinja Markovic/Sigil. Just delete that folder and you'll have a "fresh" installation. Deleting this folder will also reset any stored zoom settings, but as I've said, you can always change it with the controls at the bottom of the window.

Quote:
Originally Posted by moz View Post
At the risk of adding extraneous detail, I've been doing a fair bit of large-scale editing - take a full novel with HTML next/prev links on every page, and use regex replacement to strip them out. Which at times involves clipboard copying the whole thing into my text editor of choice, using a regex engine I know, then pasting it back in to Sigil. I'm very used to the 100% cpu pause while Sigil loads, saves or changes view mode Sometime in the middle of that Sigil lost the plot as above. I can zip up and send you files or whatever, let me know what you need.
Try not to paste rich text directly into Sigil. Always import it. The reason is that Webkit takes over the pasting functionality and it's hard to work around this behavior. So export everything to HTML and then import it into Sigil.

And copying an entire novel worth of text onto the clipboard and pasting that somewhere? A horrible idea for any text editor. On Windows, all of that text will be UTF-16 on the clipboard and take up 30MB+ for an average novel. Parsing all of that on the fly...

Import that text, don't paste it.
Valloric is offline   Reply With Quote