View Single Post
Old 12-26-2009, 08:35 PM   #1
moz
Addict
moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.moz once ate a cherry pie in a record 7 seconds.
 
moz's Avatar
 
Posts: 368
Karma: 1553
Join Date: Feb 2008
Location: Melbun
Device: Sony PRS-505
Sigil displaying WYSIWYG oddly

Sigil is excellent, especially for something still in very early release stages. I'm just grinding through cleaning up a bunch of epub conversions and it's doing most things really well. Unfortunately when I tried to report a bug I discovered that you require me to have a google account for that. I want not to have one. So instead I'm going to report bugs here.

Sigil on my WinXP laptop has started displaying WYSIWYG oddly, and the CSS header is breaking. I've restarted Sigil (but not the laptop) and the problem presists. It happens for any epub file, not just the one I was editing when the problem started. When I switch to code view I see the header like so:
Code:
...
  img.sgc-1 {height: 100%}

  /*SG    DO NOT MODIFY.
        This style is used by Sigil.
        It will be removed on export
        along with the "sigilChapterBreak" HR tags. SG*/
  hr.sigilChapterBreak {
    border: none 0;
    border-top: 3px double #c00;
    height: 3px;
    clear: both;
  }
  /*]]>*/
  </style>
</head>
Viz, I'm missing the
Code:
  /*]]>*/
  </style>
<style type="text/css">
  /*SG    DO NOT MODIFY.
Section that delinates the Sigil parts.

But since the first time I got that, I can't not have it. Starting sigil, open a random epub, it's there. The effect is that images are resized to nearly full screen and the text is very large.

I can't see anything other than executable files in the "program files" directory, so I assume that somewhere there's a stash of information that's been corrupted. I closed Sigil, deleted the contents of "C:\Documents and Settings\User\My Documents\Sigil\scratchpad" and restarted without effect. Uninstalling and reinstalling also had no effect, but interestingly my modified startup menu shortcut was re-created when I reinstalled (it starts in my books folder instead of "program files\sigil" - any chance you can make that "my documents" or something?)

Currently I can no longer use Sigil, since this fault makes it unusable. Do I need to manually delete stuff out of the registry or delete a template file? Any tips would be much appreciated.

thanks
moz
moz is offline   Reply With Quote