View Single Post
Old 12-21-2009, 08:13 PM   #2
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 36,680
Karma: 17734032
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Sony Reader PRS-650, iPad, nook STR
Quote:
Originally Posted by ritoroy View Post
I received my PRS500 by UPS today, exactly a week after sending it in. As others have observed, everything was packed very well. Unfortunately, upon powering on the unit, it has been stuck on the "Starting up ..." screen for the last several hours. Trying to toggle the power switch and pressing the reset button on the rear has had no effect. I have sent an email to Sony Repair and am awaiting their reply, but in the meanwhile I was wondering if anybody else has had a similar experience after the upgrade and how it was resolved.
When the 500 I had sent out came back, the battery was drained and needed to be charged. So I'm thinking yours may be the same way. Plug in the AC adapter and give it a charge. While it's plugged into the AC adapter, you should be able to boot it up and read away.
JSWolf is offline   Reply With Quote