View Single Post
Old 03-27-2007, 05:55 PM   #2
Adam B.
Addicted to Porting
Adam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the roughAdam B. is a jewel in the rough
 
Adam B.'s Avatar
 
Posts: 1,695
Karma: 7194
Join Date: Oct 2006
Location: Indianapolis, IN
Device: iRex iLiad, Nokia 770, Samsung i760
How are you running scratchbox? Is it inside a virtual machine, or in a regular desktop linux install (Ubuntu?)?

By default, most linux distros don't allow remote X connections. You'll have to enable it in your display manager. For Ubuntu using GDM, edit /etc/gdm/gdm.conf. Change DisallowTCP=true to DisallowTCP=false. Then you'll need to restart you X session (Ctrl + Alt + Backspace or full restart). Then, you'll need to allow remote connections. You can allow all remote connections by entering "xhost +" in the command line, or "xhost + ipaddress" for a specific host.

If you're still having problems connecting to your xsession, make sure the port is open. Install nmap "sudo apt-get install nmap", and then test your computer "nmap -v -A localhost". If everything is setup correctly, you should see: "Discovered open port 6000/tcp on 127.0.0.1".
Adam B. is offline   Reply With Quote