View Single Post
Old 09-26-2009, 08:50 AM   #1
rogue_ronin
Banned
rogue_ronin has learned how to read e-booksrogue_ronin has learned how to read e-booksrogue_ronin has learned how to read e-booksrogue_ronin has learned how to read e-booksrogue_ronin has learned how to read e-booksrogue_ronin has learned how to read e-booksrogue_ronin has learned how to read e-books
 
Posts: 475
Karma: 796
Join Date: Sep 2008
Location: Honolulu
Device: Nokia 770 (fbreader)
Smart Q7: Get FBReader 0.10.7 on OS 5.0

Easiest way is to install synaptic first:

Code:
sudo apt-get install synaptic
Then open pcmanfm by clicking on My Documents on the desktop.

Click the up arrow until you've navigated to /.

Enter the etc folder, then the apt folder.

On pcmanfm's tool menu, select Tool --> Open Current Folder as Root. A new window will open with a bar, warning you that you are now in super-user mode. Close the old pcmanfm window so you don't get confused.

From the new window, open the file named 'preferences' (right click and hold, select "Open with Leafpad" -- or just click it. It should open in leafpad if you haven't changed pcmanfm's settings.

In the new leafpad window, select File --> Save As... and save the file as 'preferences.bak'.

Go to the very end of the file. Delete the bottom three lines. The three lines should be:

Code:
Package: fbreader libzltext libzlui-gtk libzlcore
Pin: release a=hhtech
Pin-Priority: 1001
Select File --> Save As... and save the file as 'preferences'. Confirm to overwrite.

Close leafpad and pcmanfm.

Launch synaptic. You may get a window saying something about how synaptic works. No worries, it's just a first-run window.

Click the Reload button. Wait for synaptic to finish; click Close on the popup window if you need to.

Search for fbreader. (Not FBReader.) Select 'upgrade'. Confirm any changes it wants.

Click the big Apply button.

Confirm.

Let it download and install the files.

Close synaptic. You should be good to go.

It seems to be working for me. No guarantees it will work for you.

NB: I think that Smart pinned the reader at v. 0.8.7 to allow for Chinese character display. If you need them (or other glyphs), this may not be a good idea for you. Or try it and confirm it! I don't know for sure, after all.

Last edited by rogue_ronin; 09-26-2009 at 08:59 AM. Reason: Forgot to note that it was for a Smart Q7
rogue_ronin is offline   Reply With Quote