View Single Post
Old 09-14-2009, 06:21 AM   #85
orwell2k
Addict
orwell2k can extract oil from cheeseorwell2k can extract oil from cheeseorwell2k can extract oil from cheeseorwell2k can extract oil from cheeseorwell2k can extract oil from cheeseorwell2k can extract oil from cheeseorwell2k can extract oil from cheeseorwell2k can extract oil from cheeseorwell2k can extract oil from cheese
 
orwell2k's Avatar
 
Posts: 357
Karma: 1112
Join Date: Oct 2008
Location: Euroland
Device: PocketBook 360°, BeBook (Hanlin V3), iRex DR1000S, iPad
Em-dashes become hyphens

I am using Book Cleaner files v1.7, and I have two problems:

(1) Embedded images are not preserved - this problem has been mentioned earlier and is related to the replacement of symbols in the "characters" representing the enoded images, so not much can be done.

(2) All em-dashes are replaced as hyphens. Em-dashes are never preserved, and I thought that this was specifically something that book cleaner files were supposed to take care of. As em-dashes tend to be without spaces between the words they separate in ebooks (word1—word2) since they are replaced as hyphens I lose all em-dashes when I create a new book (usually FB2).

Unfortunately I have stopped using the Book Cleaner files because these problems are worse than the occaissional small errors the files do fix. I have resorted to manually cleaning up the source file prior to loading into book designer, primarily:

Quote:
Replace all em-dashes with <space>—<space>, which then allows me to do a global search and replace in book designer to replace all <space>-<space> with <space>—<space> (because em-dashes become dashes on import - I could just go back to replacing the spaced dashes with em-dashes alone "—" but I prefer having spaced em-dashes for readability (although not perhaps "correct" formatting). In truth I create FB2 books using middle dashes (effectively en-dashes) so I like the spaced dashes for seperators in this case - em-dashes are just too large for my taste.
Of course, I then have to go and check manually for things like weapons calibres (.38, .45, etc.) as they tend to be without leading spaces. After FB2 creation I also have to do the ampersand check as these are incorrectly generated. First I open the FB2 file (XML) in a text editor then do a global search and replace in two stages:

Quote:
Find (without quotes) " amp; " and Replace with " &amp; "
Find (without quotes) " amp;" and Replace with "&amp;"
The first case handles situations like "Henry & Co." by keeping spaces around the ampersand. Once these are fixed, the second case picks up all the other non-spaced ampersand instances (such as R&D).

Of course, perhaps I am using Book Designer incorrectly, although I seem to have all the usual settings in place (language = German, etc.). So perhaps the BC files can be tweaked, but I'm not sure how. Does anyone else have these problems? It seems the handling of em-dashes is OK for most people as there have been few complaints. Cheers!
orwell2k is offline   Reply With Quote