View Single Post
Old 06-14-2009, 11:06 AM   #6
unrequited
Zealot
unrequited doesn't litterunrequited doesn't litter
 
unrequited's Avatar
 
Posts: 133
Karma: 118
Join Date: Feb 2009
Device: Kindle 2 DX
After playing around with PDFs for the last 2 hours...

Any PDF I resaved wouldn't read metadata, but it's strangely related to document PDF compatibility version, I have "good" PDFs ranging from v1.4 (Acrobat 5.x or higher) to v1.6 (Acrobat 7.x or higher). However, when I take any "bad" PDF and resave it using Advanced --> PDF Optimizer I can only generate "good" PDF's that are v1.4 (Acrobat 5.x). Make sure even though you change the PDF version, you deselect any of the rendering options on the left, you only want to change the PDF version.

Eventhough I have "good" PDFs all the way up to PDF v1.6 (Acrobat 7.x) if I try and convert any "bad" PDFs, the highest that the Kindle 2 DX will read is v1.4 (Acrobat 5.x). VERY ANNOYING.

Long story short, if you have Adobe Acrobat (not reader), go to the Advanced menu --> PDF Optimizer and resave your finicky PDFs by selecting "Make compatible with: Acrobat 5.x" and unchecking all of the options on the left.

AMAZON FIX YOUR PDF READER.
unrequited is offline   Reply With Quote