View Single Post
Old 04-16-2009, 10:35 AM   #1
dpierron
calibre2opds guru
dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.dpierron shines like a glazed doughnut.
 
dpierron's Avatar
 
Posts: 532
Karma: 8792
Join Date: Aug 2005
Location: Metz, France
Device: iPhone, iPad, PRS-650
Lightbulb Downgrading european 505's to US firmware

Hi folks,

As much as I love my new PRS-505, I wanted to try and use PrsCustomizer on it, to change the default fonts, add a name tag and make it display the time.

Unfortunately, I bought it in France, and therefore it had a French 1.3.xxx, which made PrsCustomizer unhappy.

I needed to downgrade it to the US firmware, but the Sony Updater program refused to do it because my firmware version was higher than the US firmware version...

After meddling with the Updater, I found a (quite simple) way to make it update my Reader, which I share with you here :
  1. download the Sony Updater program containing the US firmware (named PRS-505 Updater 1.1.00.18040.exe)
  2. extract "PRS-505 Updater 1.1.00.18040.exe" to a new directory (it's a ZIP archive in disguise)
  3. in this directory, edit the eBookUpdater\scripts\updater.xml file : search for the following :
    Code:
    if (this.compareDeviceVersion(version)) { this.checkmark.show(true) this.button.enable(false) this.container.setVariable("updateStatus", "This PRS-505 is up-to-date") } else { this.checkmark.show(false) this.button.enable(true) this.container.setVariable("updateStatus", "Please click below to continue") }
    and replace it by this :
    Code:
    this.checkmark.show(false) this.button.enable(true) this.container.setVariable("updateStatus", "Please click below to continue")
    In fact, you are simply bypassing a test on the device version...

  4. run the PRS-505 Updater.exe program and update your Reader

@moderators, please sticky this thread if you think it's worth it...

Last edited by dpierron; 04-19-2009 at 04:38 AM. Reason: modified the explanation so it is more generic...
dpierron is offline   Reply With Quote